summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2020-08-18 19:24:35 -0700
committerZac Medico <zmedico@gentoo.org>2020-08-18 19:26:36 -0700
commit0aae82dd79585c8ce79a52b09ffebaff21166023 (patch)
treee4c63aa34c1cff8eb17b5b1bce240dd118890198
parentdev-python/pyside2: fix some pkgcheck warnings (diff)
downloadgentoo-0aae82dd79585c8ce79a52b09ffebaff21166023.tar.gz
gentoo-0aae82dd79585c8ce79a52b09ffebaff21166023.tar.bz2
gentoo-0aae82dd79585c8ce79a52b09ffebaff21166023.zip
sys-fabric/mstflint: Bump to version 4.14.0_p3
Package-Manager: Portage-3.0.3, Repoman-3.0.0 Signed-off-by: Zac Medico <zmedico@gentoo.org>
-rw-r--r--sys-fabric/mstflint/Manifest1
-rw-r--r--sys-fabric/mstflint/metadata.xml1
-rw-r--r--sys-fabric/mstflint/mstflint-4.14.0_p3.ebuild46
3 files changed, 48 insertions, 0 deletions
diff --git a/sys-fabric/mstflint/Manifest b/sys-fabric/mstflint/Manifest
index 9585fabb6e5b..525d0558b8f4 100644
--- a/sys-fabric/mstflint/Manifest
+++ b/sys-fabric/mstflint/Manifest
@@ -1,3 +1,4 @@
DIST mstflint-4.10.0_p3.tar.gz 3208065 BLAKE2B 9d27bc41f3af4af2d430814a892bc26b302f4a57b2287cca4d5a64a37d7dd1b47e3f167b671be9ef1fadaf5dc51dff6094db811951ef1b5c6ad3ce746eb78546 SHA512 72077557f032bfa9c2c0b94f485b58c2d9efa955281997fed605e6351b1cfe73c46d8e4f293f93b58ebc4315d47b3dc3a4e8d72c8938647d34d291a2db89198f
DIST mstflint-4.11.0_p5.tar.gz 3622665 BLAKE2B 119d1ca04eaf3ebc2e4b8175525fdc87079b27742013f210f8c38d2ac0e83b46c555e4b8b49d7f1562180473c0873456932939e942b1050e9c952a2e3172185a SHA512 c98f24acda519e62fd8db8e170c39c8ffe69b980bc2c9a167f20cfcb2575038648e463de0c7dfad3ddebe098b8a466640b7a125901c033f193a42ef1bfef00d8
DIST mstflint-4.13.3_p2.tar.gz 3809937 BLAKE2B bfe0d5a531a26547779f2e9377c4c6f393c28623d56c87a1f0210a0fbb767a43f5186c481609722ef2e5066bcdf0110009468b047ca0a8b25c096f4802b43229 SHA512 bd7e937eaed30c4b4479c3bc184d9bd8edff9aba23824fdd6a82f0e62d319854aa74954c783eb483074e322eec94f9a0cd5bd6a0ff4de2422f9b011680324706
+DIST mstflint-4.14.0_p3.tar.gz 4012564 BLAKE2B 4203c398665cbc7a0e9f86158e58270c903f546372aecf697c09b75f7fc44944304a4c5f1524362d442ed8e16f5dd9f35fe08ec638c5c556ed182cbac9f1c27b SHA512 c27872e34443df24fb152f2837d2fa31a7a459eff859654d00c815fc942182dc48d18991e83b79cc99bbd5fafe5b721b69e9bee9c927e2d54581eb78d7a5548e
diff --git a/sys-fabric/mstflint/metadata.xml b/sys-fabric/mstflint/metadata.xml
index 3a04694a94c0..0f7655bbf7bf 100644
--- a/sys-fabric/mstflint/metadata.xml
+++ b/sys-fabric/mstflint/metadata.xml
@@ -5,6 +5,7 @@
<remote-id type="github">Mellanox/mstflint</remote-id>
</upstream>
<use>
+ <flag name="adb-generic-tools">Enable compiling the following tools: mstreg and mstlink</flag>
<flag name="inband">Enable firmware updates for Mellanox SwitchX and ConnectIB devices</flag>
</use>
<maintainer type="person">
diff --git a/sys-fabric/mstflint/mstflint-4.14.0_p3.ebuild b/sys-fabric/mstflint/mstflint-4.14.0_p3.ebuild
new file mode 100644
index 000000000000..0beaafa4fa00
--- /dev/null
+++ b/sys-fabric/mstflint/mstflint-4.14.0_p3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Mstflint - an open source version of MFT (Mellanox Firmware Tools)"
+HOMEPAGE="https://github.com/Mellanox/mstflint"
+LICENSE="|| ( GPL-2 BSD-2 )"
+KEYWORDS="~amd64 ~x86"
+EGIT_COMMIT="f8056f78a64debbdbb2522db7181848b9203e428"
+MY_PV=${PV/_p/-}
+MY_P=""
+SRC_URI="https://github.com/Mellanox/mstflint/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+IUSE="adb-generic-tools inband ssl"
+SLOT="0"
+RDEPEND="dev-db/sqlite:3=
+ sys-libs/zlib:=
+ inband? ( sys-fabric/libibmad )
+ adb-generic-tools? (
+ dev-libs/boost:=
+ dev-libs/expat:=
+ )
+ ssl? ( dev-libs/openssl:= )"
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ default
+ echo '#define TOOLS_GIT_SHA "'${EGIT_COMMIT}'"' > ./common/gitversion.h || die
+}
+
+src_configure() {
+ eautoreconf
+ econf $(use_enable inband) $(use_enable ssl openssl) $(use adb-generic-tools && printf -- '--enable-adb-generic-tools')
+}
+
+src_compile() {
+ if use adb-generic-tools; then
+ pushd ext_libs/json >/dev/null || die
+ emake
+ popd >/dev/null || die
+ fi
+ default
+}