summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-01-09 12:31:13 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-01-09 12:31:31 -0600
commit0adb2e1d0cb71e9785a639d6c7c213299960b304 (patch)
tree6f8b05e28fb510f96a37a694d43b7dc1a523319e
parentdev-libs/botan: cleanup (diff)
downloadgentoo-0adb2e1d0cb71e9785a639d6c7c213299960b304.tar.gz
gentoo-0adb2e1d0cb71e9785a639d6c7c213299960b304.tar.bz2
gentoo-0adb2e1d0cb71e9785a639d6c7c213299960b304.zip
dev-python/keyring: updating setuptools_scm version for bug 605204
Package-Manager: portage-2.3.0
-rw-r--r--dev-python/keyring/keyring-10.1-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/keyring/keyring-10.1-r1.ebuild b/dev-python/keyring/keyring-10.1-r1.ebuild
new file mode 100644
index 000000000000..fbafe6870bdd
--- /dev/null
+++ b/dev-python/keyring/keyring-10.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides access to the system keyring service"
+HOMEPAGE="https://github.com/jaraco/keyring"
+SRC_URI="mirror://pypi/k/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="PSF-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+ dev-python/secretstorage[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ )"
+RDEPEND=""
+
+python_test() {
+ py.test -v -v || die "testsuite failed under ${EPYTHON}"
+}