summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbrahmajit das <listout@protonmail.com>2023-01-14 15:38:56 +0000
committerSam James <sam@gentoo.org>2023-01-14 15:49:54 +0000
commit0b6fc35a003a77d3ff69fd6e5e46151d63ffa19b (patch)
tree92a32a82eaa662d9f4099a9449a0ee68bda93d07
parentmedia-plugins/gst-plugins-x264: add 1.20.5 (diff)
downloadgentoo-0b6fc35a003a77d3ff69fd6e5e46151d63ffa19b.tar.gz
gentoo-0b6fc35a003a77d3ff69fd6e5e46151d63ffa19b.tar.bz2
gentoo-0b6fc35a003a77d3ff69fd6e5e46151d63ffa19b.zip
media-plugins/gst-plugins-x265: add 1.20.5
Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: brahmajit das <listout@protonmail.com>
-rw-r--r--media-plugins/gst-plugins-x265/Manifest1
-rw-r--r--media-plugins/gst-plugins-x265/gst-plugins-x265-1.20.5.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-x265/Manifest b/media-plugins/gst-plugins-x265/Manifest
index 07277e1d2e60..c06a8695481f 100644
--- a/media-plugins/gst-plugins-x265/Manifest
+++ b/media-plugins/gst-plugins-x265/Manifest
@@ -1,2 +1,3 @@
DIST gst-plugins-bad-1.20.3.tar.xz 6222824 BLAKE2B 01aae59adbe76b8e50a49fb8bb8037e6f3aa93cbc2b658aab05ebbf30f8d1aef98c1981712caa39e3c9d08f1e0c9d76f2f874f7d2fdd994b3a0735b2809eafdf SHA512 cfcf126eabff550455decd7054a269b73489708c10a6b6090dddb5fde29bfba07ed330c339927ff170e025fa3a08d2ffb822322dc3798679366207a54132c71b
DIST gst-plugins-bad-1.20.4.tar.xz 6229992 BLAKE2B 2cd276cec9991e2ca7367a43024d7aee43adaa185a4a06ec08d1e736e72333f7f38cb54257120b9a313feb1fdc285a50d456b4c1fb33627d83acfcd3ece20687 SHA512 31b28d4a1bbecf021a90f2aa49dd344ccea12533b65f3bf3a8426ca2175469fff7b7f8e08af7d3d22c18db2fe48b9d5fbea2b325d296aee04b019cebef1eaec4
+DIST gst-plugins-bad-1.20.5.tar.xz 6237720 BLAKE2B bf379da420d1f7f148cf51373f6f2d0800685487c8bdb7a768e79e0a2e4f1721053922be9321958b4ce318de12ea390de4cd89c345329ac41dd0425815e0e7f6 SHA512 4b4603d755d17a0fa072d771521bdcbf554fc9abdc8105b9d9189062e5725ae2989f430e1de77363a69d8c969ecbf15e73e9c478fabe8efac83b2d9b1b0a4a0a
diff --git a/media-plugins/gst-plugins-x265/gst-plugins-x265-1.20.5.ebuild b/media-plugins/gst-plugins-x265/gst-plugins-x265-1.20.5.ebuild
new file mode 100644
index 000000000000..8ae0a17a9eee
--- /dev/null
+++ b/media-plugins/gst-plugins-x265/gst-plugins-x265-1.20.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GST_ORG_MODULE="gst-plugins-bad"
+
+inherit gstreamer-meson
+
+DESCRIPTION="H.265 encoder plugin for GStreamer"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-libs/x265:=[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dgpl=enabled
+ )
+
+ gstreamer_multilib_src_configure
+}