summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2016-11-06 12:10:26 +0100
committerTiziano Müller <dev-zero@gentoo.org>2016-11-06 12:23:48 +0100
commit0c69eda8809f21cbee060e57164737627bff5ef9 (patch)
tree2e44460c121f31143ed9d8febe6cf76f1b0de2df
parentdev-python/shapely: initial commit, required for (testing) Flask-Admin (diff)
downloadgentoo-0c69eda8809f21cbee060e57164737627bff5ef9.tar.gz
gentoo-0c69eda8809f21cbee060e57164737627bff5ef9.tar.bz2
gentoo-0c69eda8809f21cbee060e57164737627bff5ef9.zip
dev-python/geoalchemy2: initial commit, required for (testing) Flask-Admin
Package-Manager: portage-2.3.0
-rw-r--r--dev-python/geoalchemy2/Manifest1
-rw-r--r--dev-python/geoalchemy2/geoalchemy2-0.3.ebuild33
-rw-r--r--dev-python/geoalchemy2/metadata.xml11
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/geoalchemy2/Manifest b/dev-python/geoalchemy2/Manifest
new file mode 100644
index 000000000000..af7253d45cba
--- /dev/null
+++ b/dev-python/geoalchemy2/Manifest
@@ -0,0 +1 @@
+DIST geoalchemy2-0.3.tar.gz 93256 SHA256 029550f36695b48452907c834cf23ef24390d81e1e59d19bc2ba2de89e9a4835 SHA512 5f94f6459eba1266c3b31b6d0b1f16478c1641a29b3dbe26cfdc3983d3aa5642b075871fb4722e6bccca7d1960ac1d87103351d846a061891f17d407df4867c8 WHIRLPOOL e99361c67b8cb1ad727d20e649e51f898ed6d426eae866464db7460d8ca36fa78fa5fb055d0e63474b38df42d4f7f2492fe162729b1beb5a1ce27ac1891d14d6
diff --git a/dev-python/geoalchemy2/geoalchemy2-0.3.ebuild b/dev-python/geoalchemy2/geoalchemy2-0.3.ebuild
new file mode 100644
index 000000000000..6654abbd6cd3
--- /dev/null
+++ b/dev-python/geoalchemy2/geoalchemy2-0.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Geospatial extension to SQLAlchemy with PostGIS support"
+HOMEPAGE="http://geoalchemy.org/ http://geoalchemy-2.readthedocs.org"
+SRC_URI="https://github.com/geoalchemy/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+# ^^ tarball on pypi is missing tests
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/sqlalchemy-0.8[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/shapely[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+RESTRICT="test"
+# tests require a running PostgreSQL database
+
+python_test() {
+ py.test tests || die
+}
diff --git a/dev-python/geoalchemy2/metadata.xml b/dev-python/geoalchemy2/metadata.xml
new file mode 100644
index 000000000000..4f16fb134ac1
--- /dev/null
+++ b/dev-python/geoalchemy2/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">GeoAlchemy2</remote-id>
+ </upstream>
+</pkgmetadata>