summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-07-20 15:47:43 +0200
committerPacho Ramos <pacho@gentoo.org>2022-07-20 15:59:28 +0200
commit0c8091fad28a3378f48c7be1dbf0c959244b5175 (patch)
tree5c71a6e2a11495a594c5322ebe3ccea61d94bde4
parentmedia-libs/vulkan-loader: x86 stable wrt bug #859409 (diff)
downloadgentoo-0c8091fad28a3378f48c7be1dbf0c959244b5175.tar.gz
gentoo-0c8091fad28a3378f48c7be1dbf0c959244b5175.tar.bz2
gentoo-0c8091fad28a3378f48c7be1dbf0c959244b5175.zip
sys-apps/usb_modeswitch: Reload udev rules
Closes: https://bugs.gentoo.org/851891 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--sys-apps/usb_modeswitch/usb_modeswitch-2.6.1.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/sys-apps/usb_modeswitch/usb_modeswitch-2.6.1.ebuild b/sys-apps/usb_modeswitch/usb_modeswitch-2.6.1.ebuild
index 78af89e7578d..d20c200a940a 100644
--- a/sys-apps/usb_modeswitch/usb_modeswitch-2.6.1.ebuild
+++ b/sys-apps/usb_modeswitch/usb_modeswitch-2.6.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -65,3 +65,11 @@ src_install() {
keepdir /var/lib/${PN}
}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}