summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-02-07 09:31:49 -0800
committerZac Medico <zmedico@gentoo.org>2017-02-07 09:31:49 -0800
commit0cd0bc20566e4835095e0bff5e016c6e734ea7ea (patch)
treeae0047b6aa4232c0e6701b722532414159f3564a
parentnet-misc/capi4hylafax: Fix DEPEND/RDEPEND. (diff)
downloadgentoo-0cd0bc20566e4835095e0bff5e016c6e734ea7ea.tar.gz
gentoo-0cd0bc20566e4835095e0bff5e016c6e734ea7ea.tar.bz2
gentoo-0cd0bc20566e4835095e0bff5e016c6e734ea7ea.zip
app-text/podofo: version bump to 0.9.5
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--app-text/podofo/Manifest1
-rw-r--r--app-text/podofo/podofo-0.9.5.ebuild134
2 files changed, 135 insertions, 0 deletions
diff --git a/app-text/podofo/Manifest b/app-text/podofo/Manifest
index 55d142e6d558..0cce346fcf07 100644
--- a/app-text/podofo/Manifest
+++ b/app-text/podofo/Manifest
@@ -2,3 +2,4 @@ DIST podofo-0.9.2-freetype251.patch 1106 SHA256 324889c99eccafb5e4732d65d3254534
DIST podofo-0.9.2.tar.gz 1092131 SHA256 465191618c57da9ae9230e7919e1985a242ddc7d1045cfdb6fb066140ed0a3f3 SHA512 e0bda743b192edfd42f381498edc56f30e6d89f45e7abd2b4351e15fd672a432d07f067ab8ed5cf378b0ecbab6d98abb32c22c1ce860c0021e31235fc5683a21 WHIRLPOOL f22c5ec0c3de1ef661198e8c94b2ac9faab88c6b12ebe27da14642c6eaed154f2e1fbf4f404807d7e33f895ffb64663eb7e403ec8a9e0f87b32e3470b7f5acfb
DIST podofo-0.9.3.tar.gz 1135095 SHA256 ec261e31e89dce45b1a31be61e9c6bb250532e631a02d68ec5bb849ef0a222d8 SHA512 c9a8076821502225d3ecf5a7e79ef2ebd7b9cc3e7d0902eabff33325b124109a1f5038f57b83e3fad0d82cff9cd557a9ed177adc7c176064085070aebcd7602d WHIRLPOOL 44268efd48d6ab35fecf31e3ff773f6d9fcca091026f423ccffbe8afdb09fff9446eed8c64db9a4482695d6e4f4ae4585d7e51036197f619a7c304df1a8de8c2
DIST podofo-0.9.4.tar.gz 1147939 SHA256 ccdf505fcb4904617e728b15729da8700ff38442c1dd2f24fbd52934287ff859 SHA512 2f675757d76ccfe2472358b04dc4cd55e2cf00ae447731af75645c7091a338b6d91dcd4b16240b305cdbb02384ddcd38048c0e3f1700185347d4e1eb5df9ee39 WHIRLPOOL 9461b288fe515eff96333d73c670cd4f464e0c43121968f4fc76418c4f2d7a9dfd9600eb315c52995a30c99d90d7c4249bd64a4c9b300e60b509ddc8c1143679
+DIST podofo-0.9.5.tar.gz 1160799 SHA256 854981cb897ebc14bac854ea0f25305372261a48a205363fe1c61659ba7b5304 SHA512 d13b30bfebc89b809173cd2251eed1f15dfa90abb58371bfdce875797d40663923571824ad2b0b1d97aa1be212bdbb710c3a0439bc05bed7022b8eb75ca74705 WHIRLPOOL 41ad1a1a7992bc186bd2c8b77b38479b47094b00631ee8e5990745ae88e554a1b34557637e3c4b86959ec071019d33ab11bda394c8181ab21b6df2f7b09a44b7
diff --git a/app-text/podofo/podofo-0.9.5.ebuild b/app-text/podofo/podofo-0.9.5.ebuild
new file mode 100644
index 000000000000..79cf8f52afce
--- /dev/null
+++ b/app-text/podofo/podofo-0.9.5.ebuild
@@ -0,0 +1,134 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit cmake-utils flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="PoDoFo is a C++ library to work with the PDF file format"
+HOMEPAGE="https://sourceforge.net/projects/podofo/"
+SRC_URI="mirror://sourceforge/podofo/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+boost idn libressl debug test"
+
+RDEPEND="dev-lang/lua:=
+ idn? ( net-dns/libidn:= )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ media-libs/fontconfig:=
+ media-libs/freetype:2=
+ virtual/jpeg:0=
+ media-libs/libpng:0=
+ media-libs/tiff:0=
+ sys-libs/zlib:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ boost? ( dev-util/boost-build )
+ test? ( dev-util/cppunit )"
+
+DOCS="AUTHORS ChangeLog TODO"
+
+src_prepare() {
+ local x sed_args
+
+ # bug 556962
+ sed -i -e 's|Decrypt( pEncryptedBuffer, nOutputLen, pDecryptedBuffer, m_lLen );|Decrypt( pEncryptedBuffer, (pdf_long)nOutputLen, pDecryptedBuffer, (pdf_long\&)m_lLen );|' \
+ test/unit/EncryptTest.cpp || die
+
+ sed -i \
+ -e "s:LIBDIRNAME \"lib\":LIBDIRNAME \"$(get_libdir)\":" \
+ -e "s:LIBIDN_FOUND:HAVE_LIBIDN:g" \
+ CMakeLists.txt || die
+
+ # Use pkg-config to find headers for bug #459404.
+ sed_args=
+ for x in $($(tc-getPKG_CONFIG) --cflags freetype2) ; do
+ [[ ${x} == -I* ]] || continue
+ x=${x#-I}
+ if [[ -f ${x}/ft2build.h ]] ; then
+ sed_args+=" -e s:/usr/include/\\r\$:${x}:"
+ elif [[ -f ${x}/freetype/config/ftheader.h ]] ; then
+ sed_args+=" -e s:/usr/include/freetype2\\r\$:${x}:"
+ fi
+ done
+ [[ -n ${sed_args} ]] && \
+ { sed -i ${sed_args} cmake/modules/FindFREETYPE.cmake || die; }
+
+ # Bug #439784: Add missing unistd include for close() and unlink().
+ sed -i 's:^#include <stdio.h>$:#include <unistd.h>\n\0:' -i \
+ test/unit/TestUtils.cpp || die
+
+ # TODO: fix these test cases
+ # ColorTest.cpp:62:Assertion
+ # Test name: ColorTest::testDefaultConstructor
+ # expected exception not thrown
+ # - Expected: PdfError
+ sed -e 's:CPPUNIT_TEST( testDefaultConstructor ://\0:' \
+ -e 's:CPPUNIT_TEST( testGreyConstructor ://\0:' \
+ -e 's:CPPUNIT_TEST( testRGBConstructor ://\0:' \
+ -e 's:CPPUNIT_TEST( testCMYKConstructor ://\0:' \
+ -e 's:CPPUNIT_TEST( testColorSeparationAllConstructor ://\0:' \
+ -e 's:CPPUNIT_TEST( testColorSeparationNoneConstructor ://\0:' \
+ -e 's:CPPUNIT_TEST( testColorSeparationConstructor ://\0:' \
+ -e 's:CPPUNIT_TEST( testColorCieLabConstructor ://\0:' \
+ -i test/unit/ColorTest.h || die
+
+ # ColorTest.cpp:42:Assertion
+ # Test name: ColorTest::testHexNames
+ # assertion failed
+ # - Expression: static_cast<int>(rgb.GetGreen() * 255.0) == 0x0A
+ sed -e 's:CPPUNIT_TEST( testHexNames ://\0:' \
+ -i test/unit/ColorTest.h || die
+
+ # Bug #352125: test failure, depending on installed fonts
+ # ##Failure Location unknown## : Error
+ # Test name: FontTest::testFonts
+ # uncaught exception of type PoDoFo::PdfError
+ # - ePdfError_UnsupportedFontFormat
+ sed -e 's:CPPUNIT_TEST( testFonts ://\0:' \
+ -i test/unit/FontTest.h || die
+
+ # Test name: EncodingTest::testDifferencesEncoding
+ # equality assertion failed
+ # - Expected: 1
+ # - Actual : 0
+ sed -e 's:CPPUNIT_TEST( testDifferencesEncoding ://\0:' \
+ -i test/unit/EncodingTest.h || die
+
+ # Bug #407015: fix to compile with Lua 5.2
+ if has_version '>=dev-lang/lua-5.2' ; then
+ sed -e 's: lua_open(: luaL_newstate(:' \
+ -e 's: luaL_getn(: lua_rawlen(:' -i \
+ tools/podofocolor/luaconverter.cpp \
+ tools/podofoimpose/planreader_lua.cpp || die
+ fi
+ eapply_user
+}
+
+src_configure() {
+
+ # Bug #381359: undefined reference to `PoDoFo::PdfVariant::DelayedLoadImpl()'
+ filter-flags -fvisibility-inlines-hidden
+
+ mycmakeargs+=(
+ "-DPODOFO_BUILD_SHARED=1"
+ "-DPODOFO_HAVE_JPEG_LIB=1"
+ "-DPODOFO_HAVE_PNG_LIB=1"
+ "-DPODOFO_HAVE_TIFF_LIB=1"
+ "-DWANT_FONTCONFIG=1"
+ "-DUSE_STLPORT=0"
+ -DWANT_BOOST=$(usex boost ON OFF)
+ -DHAVE_LIBIDN=$(usex idn ON OFF)
+ -DHAVE_CPPUNIT=$(usex test ON OFF)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_test() {
+ cd "${CMAKE_BUILD_DIR}"/test/unit
+ ./podofo-test --selftest || die "self test failed"
+}