summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-10-09 12:18:56 +0200
committerJeroen Roovers <jer@gentoo.org>2016-10-09 12:18:56 +0200
commit0e4cf0a5d080771c36b1889d7404143883194ac5 (patch)
tree31df03d9c28c3eb2142afc5b4f204bf5483c7722
parentsys-devel/kgcc64: Stable for HPPA (bug #595560). (diff)
downloadgentoo-0e4cf0a5d080771c36b1889d7404143883194ac5.tar.gz
gentoo-0e4cf0a5d080771c36b1889d7404143883194ac5.tar.bz2
gentoo-0e4cf0a5d080771c36b1889d7404143883194ac5.zip
x11-misc/xsel: Add live ebuild.
Package-Manager: portage-2.3.1
-rw-r--r--x11-misc/xsel/xsel-9999.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-misc/xsel/xsel-9999.ebuild b/x11-misc/xsel/xsel-9999.ebuild
new file mode 100644
index 000000000000..44d008893fbb
--- /dev/null
+++ b/x11-misc/xsel/xsel-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools git-r3
+
+DESCRIPTION="command-line program for getting and setting the contents of the X selection"
+HOMEPAGE="http://www.vergenet.net/~conrad/software/xsel"
+EGIT_REPO_URI="https://github.com/kfish/xsel.git"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS=""
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+"
+DEPEND="
+ ${RDEPEND}
+ x11-proto/xproto
+ x11-libs/libXt
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+}