summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2018-10-15 09:47:56 -0400
committerMike Gilbert <floppym@gentoo.org>2018-10-15 09:47:56 -0400
commit0e99f0212017dd9dd5fcec9805da564ef666e457 (patch)
treebc784826df57eb14703fd7dcb15396edf80a6365
parentapp-emulation/virt-manager: Don's pass --qemu-user to configure (diff)
downloadgentoo-0e99f0212017dd9dd5fcec9805da564ef666e457.tar.gz
gentoo-0e99f0212017dd9dd5fcec9805da564ef666e457.tar.bz2
gentoo-0e99f0212017dd9dd5fcec9805da564ef666e457.zip
www-client/chromium: copy CHROMIUM_FORCE_CLANG for M69 and M70
Package-Manager: Portage-2.3.50_p14, Repoman-2.3.11_p21 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--www-client/chromium/chromium-69.0.3497.100.ebuild11
-rw-r--r--www-client/chromium/chromium-70.0.3538.54.ebuild9
2 files changed, 15 insertions, 5 deletions
diff --git a/www-client/chromium/chromium-69.0.3497.100.ebuild b/www-client/chromium/chromium-69.0.3497.100.ebuild
index 9b12bab541e7..dc4c6f3f3342 100644
--- a/www-client/chromium/chromium-69.0.3497.100.ebuild
+++ b/www-client/chromium/chromium-69.0.3497.100.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -101,11 +101,16 @@ DEPEND="${COMMON_DEPEND}
sys-apps/hwids[usb(+)]
>=sys-devel/bison-2.4.3
sys-devel/flex
- >=sys-devel/clang-5
virtual/pkgconfig
dev-vcs/git
"
+: ${CHROMIUM_FORCE_CLANG=yes}
+
+if [[ ${CHROMIUM_FORCE_CLANG} == yes ]]; then
+ DEPEND+=" >=sys-devel/clang-5"
+fi
+
if ! has chromium_pkg_die ${EBUILD_DEATH_HOOKS}; then
EBUILD_DEATH_HOOKS+=" chromium_pkg_die";
fi
@@ -371,7 +376,7 @@ src_configure() {
# Make sure the build system will use the right tools, bug #340795.
tc-export AR CC CXX NM
- if ! tc-is-clang; then
+ if [[ ${CHROMIUM_FORCE_CLANG} == yes ]] && ! tc-is-clang; then
# Force clang since gcc is pretty broken at the moment.
CC=${CHOST}-clang
CXX=${CHOST}-clang++
diff --git a/www-client/chromium/chromium-70.0.3538.54.ebuild b/www-client/chromium/chromium-70.0.3538.54.ebuild
index 536322cbe16a..6f9776159858 100644
--- a/www-client/chromium/chromium-70.0.3538.54.ebuild
+++ b/www-client/chromium/chromium-70.0.3538.54.ebuild
@@ -101,11 +101,16 @@ DEPEND="${COMMON_DEPEND}
sys-apps/hwids[usb(+)]
>=sys-devel/bison-2.4.3
sys-devel/flex
- >=sys-devel/clang-5
virtual/pkgconfig
dev-vcs/git
"
+: ${CHROMIUM_FORCE_CLANG=yes}
+
+if [[ ${CHROMIUM_FORCE_CLANG} == yes ]]; then
+ DEPEND+=" >=sys-devel/clang-5"
+fi
+
if ! has chromium_pkg_die ${EBUILD_DEATH_HOOKS}; then
EBUILD_DEATH_HOOKS+=" chromium_pkg_die";
fi
@@ -381,7 +386,7 @@ src_configure() {
# Make sure the build system will use the right tools, bug #340795.
tc-export AR CC CXX NM
- if ! tc-is-clang; then
+ if [[ ${CHROMIUM_FORCE_CLANG} == yes ]] && ! tc-is-clang; then
# Force clang since gcc is pretty broken at the moment.
CC=${CHOST}-clang
CXX=${CHOST}-clang++