summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-03-09 19:43:21 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-03-09 20:25:59 +0200
commit0ec09281e27f4f4654b865037b317db53e2a7dc5 (patch)
tree403d70e75ffe68abe0ce7dd0e09f01623a4cbc79
parentdev-python/botocore: add 1.24.15 (diff)
downloadgentoo-0ec09281e27f4f4654b865037b317db53e2a7dc5.tar.gz
gentoo-0ec09281e27f4f4654b865037b317db53e2a7dc5.tar.bz2
gentoo-0ec09281e27f4f4654b865037b317db53e2a7dc5.zip
dev-python/cfn-lint: add 0.58.3
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.58.3.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index d7cb58070aa0..6a04d079f0d9 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -1,3 +1,4 @@
DIST cfn-lint-0.58.0.tar.gz 8645209 BLAKE2B b198c8e6a56095782ab5fbd70f1f5872d951da133ee7056ef468e5d1cd0ba1a7831ebd4263248ec2cec04980211e01cf3525e18f8ad272d6b1aaeee07527028d SHA512 238929a79d25b6a5945fd43f29fa3c432c650923634495c2ace7e3f6ace0c7701bcc278ea151a9172691bd04164f8a7b409dd8387e82e5917a9f65e1a556a4d2
DIST cfn-lint-0.58.1.tar.gz 8711246 BLAKE2B 28655e076f3bdee358b1a1bb61170b176d0c90ab04ae43f1892798a239d0fd92e5dd939433a263321da02b349b9299e4f4916ccc5091df081a8b6fdf2aa0e050 SHA512 06bb38462c1cb7d4da8159eba6fa1ff05de8849bc4374a7df799d41a1f023eb38c75636956616cdc0e45a800f870bd0694575d9773b6dff91aaf2dfdbfe45169
DIST cfn-lint-0.58.2.tar.gz 8780583 BLAKE2B 8675ab1658b2ad75fc2be550eaf8bee8e6fd93389168cf2c127fed4e77a68aa849a5f3b2dbd6296d449fce538d69926dd108684c78dcd959483c56b9a44c35b7 SHA512 fe7adbb7b78ca8a978be447e29debb45d8bd26e822dff6872c4b8c6e6f5363b7d734e7105d89326af60bbeba6411f0e60bf798fd638ef8652ce109285e5f864d
+DIST cfn-lint-0.58.3.tar.gz 8779688 BLAKE2B 0964d477f61ec3dc4f80d59e3b05bc92cba27c0c9293a343bf15ee25df967643adf4d8aaa0c11d336a857957bc19dd1cc711b7fe9014c9c43ffd0171b197c4f5 SHA512 9f88f533a6533cf23ce9be83f61cc7418df7775e331ea932f469b391e136a370e5adef9a41a5378dc99d4aec352ababebc1eb59b15d19c0c0c6f19e12410ae06
diff --git a/dev-python/cfn-lint/cfn-lint-0.58.3.ebuild b/dev-python/cfn-lint/cfn-lint-0.58.3.ebuild
new file mode 100644
index 000000000000..b8ea9d7827e1
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.58.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="https://pypi.org/project/cfn-lint/ https://github.com/aws-cloudformation/cfn-lint/"
+SRC_URI="
+ https://github.com/aws-cloudformation/cfn-lint/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.42.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema_to_python-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/sarif_om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.11[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_2
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+)
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}