summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-16 08:34:18 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-16 10:27:33 +0200
commit0eff7e76578c5e18e7347fbad6638a6f8c99f93e (patch)
treefdef85361a4ca44796e504cc131e0fdcff36a284
parentdev-python/lmdb: Bump to 1.2.0 (diff)
downloadgentoo-0eff7e76578c5e18e7347fbad6638a6f8c99f93e.tar.gz
gentoo-0eff7e76578c5e18e7347fbad6638a6f8c99f93e.tar.bz2
gentoo-0eff7e76578c5e18e7347fbad6638a6f8c99f93e.zip
dev-python/scrypt: Bump to 0.8.18 (NFC)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/scrypt/Manifest1
-rw-r--r--dev-python/scrypt/scrypt-0.8.18.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/scrypt/Manifest b/dev-python/scrypt/Manifest
index 0d6cd20ea785..2f6ed1652e95 100644
--- a/dev-python/scrypt/Manifest
+++ b/dev-python/scrypt/Manifest
@@ -1 +1,2 @@
DIST scrypt-0.8.16.tar.gz 54205 BLAKE2B ce4f86f8bacb4f12408604822a32c9f63f96a155469cca1d2aa50cf67fc9e9576432f13ef49694a9d7ce21696aedcef27419fc0d3aad67a87d16c3bf8c0f94c4 SHA512 9498637d1354a84021f2c069a919ff157ff189d1385453397a9c43e522de77af9d628a90d649d50e9243abfc0b96efe4e38b615322d83133137bad94d448ef06
+DIST scrypt-0.8.18.tar.gz 56651 BLAKE2B d0e71e0677ab5f159da829eaf8e794fab9fa9290ff3688e525c4f2e9c60fda532d1c302fe4088bd8e88e06e926ef95d06bad145697e8a13e2662eda7027479b7 SHA512 b033203f65dd63c1e915eeff6232c01f806eb01d3ce18e753b6161ae667555095fe775585dd0d4e15ae228f2d4862860093c1a18d5b810b438d032df9fb24d81
diff --git a/dev-python/scrypt/scrypt-0.8.18.ebuild b/dev-python/scrypt/scrypt-0.8.18.ebuild
new file mode 100644
index 000000000000..57fbe197e0e7
--- /dev/null
+++ b/dev-python/scrypt/scrypt-0.8.18.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Bindings for the scrypt key derivation function library"
+HOMEPAGE="https://github.com/holgern/py-scrypt/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+# no functional changes since 0.8.16, so no point in upgrading
+KEYWORDS=""
+SLOT="0"
+IUSE="libressl"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest