summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2016-07-14 09:19:36 -0600
committerChristoph Junghans <ottxor@gentoo.org>2016-07-14 09:19:52 -0600
commit0f26951d2d7ebc189986b12a197d8262085a0b07 (patch)
treed17a4be6dcb21fd0c6716221b93c5da9f7aa22ba
parentdev-python/id3-py: Clean up old. (diff)
downloadgentoo-0f26951d2d7ebc189986b12a197d8262085a0b07.tar.gz
gentoo-0f26951d2d7ebc189986b12a197d8262085a0b07.tar.bz2
gentoo-0f26951d2d7ebc189986b12a197d8262085a0b07.zip
dev-util/cwdiff: added live ebuild
Package-Manager: portage-2.2.28
-rw-r--r--dev-util/cwdiff/cwdiff-9999.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-util/cwdiff/cwdiff-9999.ebuild b/dev-util/cwdiff/cwdiff-9999.ebuild
new file mode 100644
index 000000000000..c0667660f592
--- /dev/null
+++ b/dev-util/cwdiff/cwdiff-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="git://github.com/junghans/${PN}.git https://github.com/junghans/${PN}.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/junghans/cwdiff/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x64-macos ~x86-macos"
+fi
+
+DESCRIPTION="A script that wraps wdiff to support directories and colorize the output"
+HOMEPAGE="https://github.com/junghans/cwdiff"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="mercurial"
+
+DEPEND="sys-apps/help2man
+ sys-apps/coreutils"
+RDEPEND="
+ sys-apps/sed
+ app-shells/bash
+ app-text/wdiff
+ sys-apps/diffutils
+ mercurial? ( dev-vcs/mercurial )
+ "
+
+src_install() {
+ emake DESTDIR="${ED}" $(usex mercurial '' 'HGRCDIR=') install
+ dodoc README.md
+}