summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-09-28 08:57:42 -0400
committerMatt Turner <mattst88@gentoo.org>2022-09-28 09:03:27 -0400
commit0f327a0b03e5e3e7917cbd49423d3dfaaa44865a (patch)
treee4b9531700b0543f72c77e96a299bddd321820da
parentdev-python/trio: add 0.22.0 (diff)
downloadgentoo-0f327a0b03e5e3e7917cbd49423d3dfaaa44865a.tar.gz
gentoo-0f327a0b03e5e3e7917cbd49423d3dfaaa44865a.tar.bz2
gentoo-0f327a0b03e5e3e7917cbd49423d3dfaaa44865a.zip
net-libs/uhttpmock: Version bump to 0.9.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--net-libs/uhttpmock/Manifest1
-rw-r--r--net-libs/uhttpmock/uhttpmock-0.9.0.ebuild42
-rw-r--r--profiles/package.mask1
3 files changed, 44 insertions, 0 deletions
diff --git a/net-libs/uhttpmock/Manifest b/net-libs/uhttpmock/Manifest
index 6f6d9f2981b0..685594a8c641 100644
--- a/net-libs/uhttpmock/Manifest
+++ b/net-libs/uhttpmock/Manifest
@@ -1 +1,2 @@
DIST uhttpmock-0.5.5.tar.bz2 47013 BLAKE2B 1b59801c13909525e05ec88f5ccfde1606cf427fc41896b14411344281046148bbe652162726aa643610bda447d04c64041a292b46838a3b98b849d670ce6909 SHA512 0fa6e03095c7b66ebd02736b95222b66e1232e5854839a352ee2ec59822ab027bdcf6c871b23433da46725a9807232b0b6bdd0c4cb8a59a23604787acd3d5f0f
+DIST uhttpmock-0.9.0.tar.bz2 48659 BLAKE2B 02eb787e2bf778a107088b0361fd9efb9e68be16c1c9db656fb9692cbedf5bd0012c085c753a5c2f26317afd7d963c9c79d668836872b583890a4437a5c43930 SHA512 5f238b6aee339608000c2b1fb62a62197935555842d335517beb57319f427a618166c29ce67d929199af94ecc5de1a4a0641d049fecc66dcd9b49a5c539fbbf1
diff --git a/net-libs/uhttpmock/uhttpmock-0.9.0.ebuild b/net-libs/uhttpmock/uhttpmock-0.9.0.ebuild
new file mode 100644
index 000000000000..a295d7b4cd13
--- /dev/null
+++ b/net-libs/uhttpmock/uhttpmock-0.9.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson vala
+
+DESCRIPTION="HTTP web service mocking library"
+HOMEPAGE="https://gitlab.freedesktop.org/pwithnall/uhttpmock"
+SRC_URI="https://gitlab.freedesktop.org/pwithnall/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+"
+SLOT="1.0"
+
+IUSE="gtk-doc +introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.38.0:2
+ >=net-libs/libsoup-3.1.2:3.0
+ introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ default
+ use vala && vala_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use introspection)
+ $(meson_feature vala vapi)
+ $(meson_use gtk-doc gtk_doc)
+ )
+ meson_src_configure
+}
diff --git a/profiles/package.mask b/profiles/package.mask
index f8262658f448..dcb0b2bbb0e0 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -558,6 +558,7 @@ sys-devel/automake:1.11
# Migration to it is expected for GNOME 42, NOT to be unmasked with GNOME 41.
>=gnome-extra/gnome-calculator-43
media-libs/libshumate
+net-libs/uhttpmock:1.0
net-libs/libsoup:3.0
net-libs/rest:1.0
net-libs/webkit-gtk:4.1