summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-25 08:13:03 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-25 09:11:22 +0200
commit0fb6e70c611fd2ead2bfe7a9ecdfb43fd3bfae47 (patch)
treeffc7eefe5ed5ae6788a9e5c426a992f22260dd9b
parentnet-p2p/gtk-gnutella: cleanup (diff)
downloadgentoo-0fb6e70c611fd2ead2bfe7a9ecdfb43fd3bfae47.tar.gz
gentoo-0fb6e70c611fd2ead2bfe7a9ecdfb43fd3bfae47.tar.bz2
gentoo-0fb6e70c611fd2ead2bfe7a9ecdfb43fd3bfae47.zip
eclass: gentoo.org has https per default
Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--eclass/ant-tasks.eclass12
-rw-r--r--eclass/apache-2.eclass4
-rw-r--r--eclass/common-lisp-common-3.eclass2
-rw-r--r--eclass/cron.eclass2
-rw-r--r--eclass/emul-linux-x86.eclass6
-rw-r--r--eclass/eutils.eclass6
-rw-r--r--eclass/games.eclass2
-rw-r--r--eclass/gnatbuild.eclass2
-rw-r--r--eclass/gnome.org.eclass2
-rw-r--r--eclass/gst-plugins10.eclass4
-rw-r--r--eclass/gstreamer.eclass4
-rw-r--r--eclass/java-utils-2.eclass6
-rw-r--r--eclass/kde4-base.eclass2
-rw-r--r--eclass/kernel-2.eclass2
-rw-r--r--eclass/mozilla-launcher.eclass6
-rw-r--r--eclass/mysql-multilib.eclass6
-rw-r--r--eclass/mysql-v2.eclass6
-rw-r--r--eclass/nvidia-driver.eclass2
-rw-r--r--eclass/qmail.eclass2
-rw-r--r--eclass/ruby-ng.eclass2
-rw-r--r--eclass/selinux-policy-2.eclass2
-rw-r--r--eclass/subversion.eclass2
-rw-r--r--eclass/toolchain-binutils.eclass4
-rw-r--r--eclass/toolchain-funcs.eclass2
-rw-r--r--eclass/toolchain.eclass6
-rw-r--r--eclass/unpacker.eclass2
-rw-r--r--eclass/vim-plugin.eclass2
-rw-r--r--eclass/vim-spell.eclass2
-rw-r--r--eclass/webapp.eclass10
29 files changed, 56 insertions, 56 deletions
diff --git a/eclass/ant-tasks.eclass b/eclass/ant-tasks.eclass
index fe9405d1da1..0b7293fedf3 100644
--- a/eclass/ant-tasks.eclass
+++ b/eclass/ant-tasks.eclass
@@ -63,12 +63,12 @@ ANT_TASK_PV="${PV}"
if [[ ${PV} == *beta2* ]]; then
MY_PV=${PV/_beta2/beta}
UPSTREAM_PREFIX="http://people.apache.org/dist/ant/v1.7.1beta2/src"
- GENTOO_PREFIX="http://dev.gentoo.org/~caster/distfiles"
+ GENTOO_PREFIX="https://dev.gentoo.org/~caster/distfiles"
ANT_TASK_PV=$(get_version_component_range 1-3)
elif [[ ${PV} == *_rc* ]]; then
MY_PV=${PV/_rc/RC}
- UPSTREAM_PREFIX="http://dev.gentoo.org/~caster/distfiles"
- GENTOO_PREFIX="http://dev.gentoo.org/~caster/distfiles"
+ UPSTREAM_PREFIX="https://dev.gentoo.org/~caster/distfiles"
+ GENTOO_PREFIX="https://dev.gentoo.org/~caster/distfiles"
ANT_TASK_PV=$(get_version_component_range 1-3)
else
# default for final releases
@@ -76,13 +76,13 @@ else
UPSTREAM_PREFIX="mirror://apache/ant/source"
case ${PV} in
1.9.*)
- GENTOO_PREFIX="http://dev.gentoo.org/~tomwij/files/dist"
+ GENTOO_PREFIX="https://dev.gentoo.org/~tomwij/files/dist"
;;
1.8.4)
- GENTOO_PREFIX="http://dev.gentoo.org/~sera/distfiles"
+ GENTOO_PREFIX="https://dev.gentoo.org/~sera/distfiles"
;;
*)
- GENTOO_PREFIX="http://dev.gentoo.org/~caster/distfiles"
+ GENTOO_PREFIX="https://dev.gentoo.org/~caster/distfiles"
;;
esac
fi
diff --git a/eclass/apache-2.eclass b/eclass/apache-2.eclass
index 549b43abcd6..d0621527649 100644
--- a/eclass/apache-2.eclass
+++ b/eclass/apache-2.eclass
@@ -71,7 +71,7 @@ esac
[[ -n "$GENTOO_PATCH_A" ]] || GENTOO_PATCH_A="${GENTOO_PATCHNAME}-${GENTOO_PATCHSTAMP}.tar.bz2"
SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2
- http://dev.gentoo.org/~${GENTOO_DEVELOPER}/dist/apache/${GENTOO_PATCH_A}"
+ https://dev.gentoo.org/~${GENTOO_DEVELOPER}/dist/apache/${GENTOO_PATCH_A}"
# @VARIABLE: IUSE_MPMS_FORK
# @DESCRIPTION:
@@ -365,7 +365,7 @@ check_upgrade() {
eerror "(${EROOT}etc/apache2/apache2-builtin-mods) exists on your"
eerror "system."
eerror
- eerror "Please read http://www.gentoo.org/doc/en/apache-upgrading.xml"
+ eerror "Please read https://www.gentoo.org/doc/en/apache-upgrading.xml"
eerror "for detailed information how to convert this file to the new"
eerror "APACHE2_MODULES USE_EXPAND variable."
eerror
diff --git a/eclass/common-lisp-common-3.eclass b/eclass/common-lisp-common-3.eclass
index b652b8397c8..f8d62cdd544 100644
--- a/eclass/common-lisp-common-3.eclass
+++ b/eclass/common-lisp-common-3.eclass
@@ -32,7 +32,7 @@ do-debian-credits() {
# The following `impl-*-timestamp-hack' functions SHOULD NOT be used
# outside of this eclass.
-# Bug http://bugs.gentoo.org/show_bug.cgi?id=16162 should remove the
+# Bug https://bugs.gentoo.org/show_bug.cgi?id=16162 should remove the
# need for this hack.
impl-save-timestamp-hack() {
diff --git a/eclass/cron.eclass b/eclass/cron.eclass
index 57ab4463d50..8395d41d82d 100644
--- a/eclass/cron.eclass
+++ b/eclass/cron.eclass
@@ -156,6 +156,6 @@ cron_pkg_postinst() {
einfo "You may wish to read the Gentoo Linux Cron Guide, which can be"
einfo "found online at:"
- einfo " http://www.gentoo.org/doc/en/cron-guide.xml"
+ einfo " https://www.gentoo.org/doc/en/cron-guide.xml"
echo
}
diff --git a/eclass/emul-linux-x86.eclass b/eclass/emul-linux-x86.eclass
index 80f6faf0129..18849c6bc63 100644
--- a/eclass/emul-linux-x86.eclass
+++ b/eclass/emul-linux-x86.eclass
@@ -18,9 +18,9 @@ case "${EAPI:-0}" in
esac
DESCRIPTION="Provides precompiled 32bit libraries"
-#HOMEPAGE="http://amd64.gentoo.org/emul/content.xml"
-HOMEPAGE="http://dev.gentoo.org/~pacho/emul.html"
-SRC_URI="http://dev.gentoo.org/~pacho/emul/${P}.tar.xz"
+#HOMEPAGE="https://amd64.gentoo.org/emul/content.xml"
+HOMEPAGE="https://dev.gentoo.org/~pacho/emul.html"
+SRC_URI="https://dev.gentoo.org/~pacho/emul/${P}.tar.xz"
IUSE="+development"
diff --git a/eclass/eutils.eclass b/eclass/eutils.eclass
index fecd375a623..b7f097041fe 100644
--- a/eclass/eutils.eclass
+++ b/eclass/eutils.eclass
@@ -55,11 +55,11 @@ ebeep() {
else
ebeep() {
- ewarn "QA Notice: ebeep is not defined in EAPI=${EAPI}, please file a bug at http://bugs.gentoo.org"
+ ewarn "QA Notice: ebeep is not defined in EAPI=${EAPI}, please file a bug at https://bugs.gentoo.org"
}
epause() {
- ewarn "QA Notice: epause is not defined in EAPI=${EAPI}, please file a bug at http://bugs.gentoo.org"
+ ewarn "QA Notice: epause is not defined in EAPI=${EAPI}, please file a bug at https://bugs.gentoo.org"
}
fi
@@ -1402,7 +1402,7 @@ built_with_use() {
# Many configure scripts wrongly bail when a C++ compiler could not be
# detected. If dir is not specified, then it defaults to ${S}.
#
-# http://bugs.gentoo.org/73450
+# https://bugs.gentoo.org/73450
epunt_cxx() {
local dir=$1
[[ -z ${dir} ]] && dir=${S}
diff --git a/eclass/games.eclass b/eclass/games.eclass
index f9721d7e2af..03421b332e7 100644
--- a/eclass/games.eclass
+++ b/eclass/games.eclass
@@ -343,7 +343,7 @@ games_pkg_postinst() {
esac
echo
einfo "For more info about Gentoo gaming in general, see our website:"
- einfo " http://games.gentoo.org/"
+ einfo " https://games.gentoo.org/"
echo
fi
}
diff --git a/eclass/gnatbuild.eclass b/eclass/gnatbuild.eclass
index da8986a6cc8..43f7e59ad25 100644
--- a/eclass/gnatbuild.eclass
+++ b/eclass/gnatbuild.eclass
@@ -246,7 +246,7 @@ do_gnat_config() {
elog "Ada handling in Gentoo allows you to have multiple gnat variants"
elog "installed in parallel and automatically manage Ada libs."
elog "Please take a look at the Ada project page for some documentation:"
- elog "http://www.gentoo.org/proj/en/prog_lang/ada/index.xml"
+ elog "https://www.gentoo.org/proj/en/prog_lang/ada/index.xml"
}
diff --git a/eclass/gnome.org.eclass b/eclass/gnome.org.eclass
index eb84e1b0a07..3eeb4efc465 100644
--- a/eclass/gnome.org.eclass
+++ b/eclass/gnome.org.eclass
@@ -27,7 +27,7 @@ else
fi
# Even though xz-utils are in @system, they must still be added to DEPEND; see
-# http://archives.gentoo.org/gentoo-dev/msg_a0d4833eb314d1be5d5802a3b710e0a4.xml
+# https://archives.gentoo.org/gentoo-dev/msg_a0d4833eb314d1be5d5802a3b710e0a4.xml
if [[ ${GNOME_TARBALL_SUFFIX} == "xz" ]]; then
DEPEND="${DEPEND} app-arch/xz-utils"
fi
diff --git a/eclass/gst-plugins10.eclass b/eclass/gst-plugins10.eclass
index 0a6b0db79b0..1d4f4f729ee 100644
--- a/eclass/gst-plugins10.eclass
+++ b/eclass/gst-plugins10.eclass
@@ -79,7 +79,7 @@ else
fi
# Even though xz-utils are in @system, they must still be added to DEPEND; see
-# http://archives.gentoo.org/gentoo-dev/msg_a0d4833eb314d1be5d5802a3b710e0a4.xml
+# https://archives.gentoo.org/gentoo-dev/msg_a0d4833eb314d1be5d5802a3b710e0a4.xml
if [[ ${GST_TARBALL_SUFFIX} == "xz" ]]; then
DEPEND="${DEPEND} app-arch/xz-utils"
fi
@@ -254,7 +254,7 @@ gst-plugins10_src_configure() {
einfo "Configuring to build ${GST_PLUGINS_BUILD} plugin(s) ..."
econf \
--with-package-name="Gentoo GStreamer ebuild" \
- --with-package-origin="http://www.gentoo.org" \
+ --with-package-origin="https://www.gentoo.org" \
${gst_conf} $@
}
diff --git a/eclass/gstreamer.eclass b/eclass/gstreamer.eclass
index aef8bf57a34..0163493a76b 100644
--- a/eclass/gstreamer.eclass
+++ b/eclass/gstreamer.eclass
@@ -58,7 +58,7 @@ esac
: ${GST_TARBALL_SUFFIX:="xz"}
# Even though xz-utils are in @system, they must still be added to DEPEND; see
-# http://archives.gentoo.org/gentoo-dev/msg_a0d4833eb314d1be5d5802a3b710e0a4.xml
+# https://archives.gentoo.org/gentoo-dev/msg_a0d4833eb314d1be5d5802a3b710e0a4.xml
if [[ ${GST_TARBALL_SUFFIX} == "xz" ]]; then
DEPEND="${DEPEND} app-arch/xz-utils"
fi
@@ -236,7 +236,7 @@ gstreamer_multilib_src_configure() {
einfo "Configuring to build ${GST_PLUGINS_BUILD} plugin(s) ..."
econf \
--with-package-name="Gentoo GStreamer ebuild" \
- --with-package-origin="http://www.gentoo.org" \
+ --with-package-origin="https://www.gentoo.org" \
"${gst_conf[@]}" "${@}"
}
diff --git a/eclass/java-utils-2.eclass b/eclass/java-utils-2.eclass
index 6e333118f5b..9b670975895 100644
--- a/eclass/java-utils-2.eclass
+++ b/eclass/java-utils-2.eclass
@@ -2102,7 +2102,7 @@ java-pkg_init() {
}
# People do all kinds of weird things.
- # http://forums.gentoo.org/viewtopic-p-3943166.html
+ # https://forums.gentoo.org/viewtopic-p-3943166.html
local silence="${SILENCE_JAVA_OPTIONS_WARNING}"
local accept="${I_WANT_GLOBAL_JAVA_OPTIONS}"
if [[ -n ${_JAVA_OPTIONS} && -z ${accept} && -z ${silence} ]]; then
@@ -2765,7 +2765,7 @@ java-pkg_ensure-dep() {
eqawarn "java-pkg_ensure-dep: ${dev_error}"
# eerror "Because you have ${target_pkg} installed,"
# eerror "the package will build without problems, but please"
-# eerror "report this to http://bugs.gentoo.org."
+# eerror "report this to https://bugs.gentoo.org."
# fi
elif [[ ${limit_to} != build && ! ( "${RDEPEND}${PDEPEND}" =~ ${stripped_pkg} ) ]]; then
dev_error="The ebuild is attempting to use ${target_pkg}, which is not "
@@ -2776,7 +2776,7 @@ java-pkg_ensure-dep() {
eqawarn "java-pkg_ensure-dep: ${dev_error}"
# eerror "The package will build without problems, but may fail to run"
# eerror "if you don't have ${target_pkg} installed,"
-# eerror "so please report this to http://bugs.gentoo.org."
+# eerror "so please report this to https://bugs.gentoo.org."
# fi
fi
}
diff --git a/eclass/kde4-base.eclass b/eclass/kde4-base.eclass
index 8b9226a226c..477a544fdc3 100644
--- a/eclass/kde4-base.eclass
+++ b/eclass/kde4-base.eclass
@@ -433,7 +433,7 @@ _calculate_src_uri() {
4.4.20*)
# KDEPIM 4.4 no-akonadi branch, special case
# TODO: Remove this part when KDEPIM 4.4 gets out of the tree
- SRC_URI="http://dev.gentoo.org/~dilfridge/distfiles/${_kmname_pv}.tar.xz" ;;
+ SRC_URI="https://dev.gentoo.org/~dilfridge/distfiles/${_kmname_pv}.tar.xz" ;;
4.?.[6-9]? | 4.??.[6-9]?)
# Unstable KDE SC releases
SRC_URI="mirror://kde/unstable/${PV}/src/${_kmname_pv}.tar.xz" ;;
diff --git a/eclass/kernel-2.eclass b/eclass/kernel-2.eclass
index 50f318c4601..94231ecee5c 100644
--- a/eclass/kernel-2.eclass
+++ b/eclass/kernel-2.eclass
@@ -102,7 +102,7 @@ if [[ ${CTARGET} == ${CHOST} && ${CATEGORY/cross-} != ${CATEGORY} ]]; then
export CTARGET=${CATEGORY/cross-}
fi
-HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/ ${HOMEPAGE}"
+HOMEPAGE="https://www.kernel.org/ https://www.gentoo.org/ ${HOMEPAGE}"
: ${LICENSE:="GPL-2"}
# This is the latest KV_PATCH of the deblob tool available from the
diff --git a/eclass/mozilla-launcher.eclass b/eclass/mozilla-launcher.eclass
index 0d706385963..11c3fdbf652 100644
--- a/eclass/mozilla-launcher.eclass
+++ b/eclass/mozilla-launcher.eclass
@@ -87,7 +87,7 @@ install_mozilla_launcher_stub() {
#
# Stub script to run mozilla-launcher. We used to use a symlink here
# but OOo brokenness makes it necessary to use a stub instead:
-# http://bugs.gentoo.org/show_bug.cgi?id=78890
+# https://bugs.gentoo.org/show_bug.cgi?id=78890
export MOZILLA_LAUNCHER=${appname}
export MOZILLA_LIBDIR=${libdir}
@@ -101,7 +101,7 @@ EOF
#
# Stub script to run mozilla-launcher. We used to use a symlink here
# but OOo brokenness makes it necessary to use a stub instead:
-# http://bugs.gentoo.org/show_bug.cgi?id=78890
+# https://bugs.gentoo.org/show_bug.cgi?id=78890
export MOZILLA_LAUNCHER=${appname}
export MOZILLA_LIBDIR=${libdir}
@@ -117,7 +117,7 @@ EOF
warn_mozilla_launcher_stub() {
elog "Not all locales support the disabling of pango."
elog "If your locale does not support disabling pango,"
- elog "please open a bug report on http://bugs.gentoo.org"
+ elog "please open a bug report on https://bugs.gentoo.org"
elog "Then we can filter around the problem with those"
elog "specific locales."
}
diff --git a/eclass/mysql-multilib.eclass b/eclass/mysql-multilib.eclass
index ff701df41d9..da5594becdf 100644
--- a/eclass/mysql-multilib.eclass
+++ b/eclass/mysql-multilib.eclass
@@ -170,9 +170,9 @@ SRC_URI="${SERVER_URI}"
if [[ ${MY_EXTRAS_VER} != "live" && ${MY_EXTRAS_VER} != "none" ]]; then
SRC_URI="${SRC_URI}
mirror://gentoo/mysql-extras-${MY_EXTRAS_VER}.tar.bz2
- http://dev.gentoo.org/~robbat2/distfiles/mysql-extras-${MY_EXTRAS_VER}.tar.bz2
- http://dev.gentoo.org/~jmbsvicetto/distfiles/mysql-extras-${MY_EXTRAS_VER}.tar.bz2
- http://dev.gentoo.org/~grknight/distfiles/mysql-extras-${MY_EXTRAS_VER}.tar.bz2"
+ https://dev.gentoo.org/~robbat2/distfiles/mysql-extras-${MY_EXTRAS_VER}.tar.bz2
+ https://dev.gentoo.org/~jmbsvicetto/distfiles/mysql-extras-${MY_EXTRAS_VER}.tar.bz2
+ https://dev.gentoo.org/~grknight/distfiles/mysql-extras-${MY_EXTRAS_VER}.tar.bz2"
fi
DESCRIPTION="A fast, multi-threaded, multi-user SQL database server"
diff --git a/eclass/mysql-v2.eclass b/eclass/mysql-v2.eclass
index b317be46be0..8d38939e45a 100644
--- a/eclass/mysql-v2.eclass
+++ b/eclass/mysql-v2.eclass
@@ -184,9 +184,9 @@ if [[ ${MY_EXTRAS_VER} != "live" && ${MY_EXTRAS_VER} != "none" ]]; then
SRC_URI="${SRC_URI}
mirror://gentoo/mysql-extras-${MY_EXTRAS_VER}.tar.bz2
http://g3nt8.org/patches/mysql-extras-${MY_EXTRAS_VER}.tar.bz2
- http://dev.gentoo.org/~robbat2/distfiles/mysql-extras-${MY_EXTRAS_VER}.tar.bz2
- http://dev.gentoo.org/~jmbsvicetto/distfiles/mysql-extras-${MY_EXTRAS_VER}.tar.bz2
- http://dev.gentoo.org/~grknight/distfiles/mysql-extras-${MY_EXTRAS_VER}.tar.bz2"
+ https://dev.gentoo.org/~robbat2/distfiles/mysql-extras-${MY_EXTRAS_VER}.tar.bz2
+ https://dev.gentoo.org/~jmbsvicetto/distfiles/mysql-extras-${MY_EXTRAS_VER}.tar.bz2
+ https://dev.gentoo.org/~grknight/distfiles/mysql-extras-${MY_EXTRAS_VER}.tar.bz2"
fi
DESCRIPTION="A fast, multi-threaded, multi-user SQL database server"
diff --git a/eclass/nvidia-driver.eclass b/eclass/nvidia-driver.eclass
index 44ef003fd13..647c32a0877 100644
--- a/eclass/nvidia-driver.eclass
+++ b/eclass/nvidia-driver.eclass
@@ -21,7 +21,7 @@ DEPEND="sys-apps/pciutils"
DISABLE_AUTOFORMATTING="yes"
DOC_CONTENTS="You must be in the video group to use the NVIDIA device
For more info, read the docs at
-http://www.gentoo.org/doc/en/nvidia-guide.xml#doc_chap3_sect6
+https://www.gentoo.org/doc/en/nvidia-guide.xml#doc_chap3_sect6
This ebuild installs a kernel module and X driver. Both must
match explicitly in their version. This means, if you restart
diff --git a/eclass/qmail.eclass b/eclass/qmail.eclass
index eb6e0122998..e6694b08fa8 100644
--- a/eclass/qmail.eclass
+++ b/eclass/qmail.eclass
@@ -475,7 +475,7 @@ qmail_config_fast() {
eerror
eerror "Cannot determine your fully-qualified hostname"
eerror "Please setup your /etc/hosts as described in"
- eerror "http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=1&chap=8#doc_chap2_sect4"
+ eerror "https://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=1&chap=8#doc_chap2_sect4"
eerror
die "cannot determine FQDN"
fi
diff --git a/eclass/ruby-ng.eclass b/eclass/ruby-ng.eclass
index 4b99b399e6c..d560ba8ed90 100644
--- a/eclass/ruby-ng.eclass
+++ b/eclass/ruby-ng.eclass
@@ -369,7 +369,7 @@ _ruby_each_implementation() {
eerror "You need to select at least one compatible Ruby installation target via RUBY_TARGETS in make.conf."
eerror "Compatible targets for this package are: ${USE_RUBY}"
eerror
- eerror "See http://www.gentoo.org/proj/en/prog_lang/ruby/index.xml#doc_chap3 for more information."
+ eerror "See https://www.gentoo.org/proj/en/prog_lang/ruby/index.xml#doc_chap3 for more information."
eerror
die "No compatible Ruby target selected."
fi
diff --git a/eclass/selinux-policy-2.eclass b/eclass/selinux-policy-2.eclass
index 92f2f820350..eb27c89ae29 100644
--- a/eclass/selinux-policy-2.eclass
+++ b/eclass/selinux-policy-2.eclass
@@ -90,7 +90,7 @@ HOMEPAGE="https://wiki.gentoo.org/wiki/Project:SELinux"
if [[ -n ${BASEPOL} ]] && [[ "${BASEPOL}" != "9999" ]];
then
SRC_URI="https://raw.githubusercontent.com/wiki/TresysTechnology/refpolicy/files/refpolicy-${PV}.tar.bz2
- http://dev.gentoo.org/~swift/patches/selinux-base-policy/patchbundle-selinux-base-policy-${BASEPOL}.tar.bz2"
+ https://dev.gentoo.org/~swift/patches/selinux-base-policy/patchbundle-selinux-base-policy-${BASEPOL}.tar.bz2"
elif [[ "${BASEPOL}" != "9999" ]];
then
SRC_URI="https://raw.githubusercontent.com/wiki/TresysTechnology/refpolicy/files/refpolicy-${PV}.tar.bz2"
diff --git a/eclass/subversion.eclass b/eclass/subversion.eclass
index f0f33791bca..c45c725cdb5 100644
--- a/eclass/subversion.eclass
+++ b/eclass/subversion.eclass
@@ -343,7 +343,7 @@ subversion_fetch() {
mkdir -p "${S}"
# export to the ${WORKDIR}
- #* "svn export" has a bug. see http://bugs.gentoo.org/119236
+ #* "svn export" has a bug. see https://bugs.gentoo.org/119236
#* svn export . "${S}" || die "${ESVN}: can't export to ${S}."
rsync -rlpgo --exclude=".svn/" . "${S}" || die "${ESVN}: can't export to ${S}."
fi
diff --git a/eclass/toolchain-binutils.eclass b/eclass/toolchain-binutils.eclass
index f13506085bc..cb2b4ad8a7d 100644
--- a/eclass/toolchain-binutils.eclass
+++ b/eclass/toolchain-binutils.eclass
@@ -76,7 +76,7 @@ add_src_uri() {
else
a+=".bz2"
fi
- set -- mirror://gentoo http://dev.gentoo.org/~vapier/dist
+ set -- mirror://gentoo https://dev.gentoo.org/~vapier/dist
SRC_URI="${SRC_URI} ${@/%//${a}}"
}
add_src_uri binutils-${BVER}-patches-${PATCHVER}.tar ${PATCHVER}
@@ -210,7 +210,7 @@ _eprefix_init() {
# Intended for ebuilds to override to set their own versioning information.
toolchain-binutils_bugurl() {
- printf "http://bugs.gentoo.org/"
+ printf "https://bugs.gentoo.org/"
}
toolchain-binutils_pkgversion() {
printf "Gentoo ${BVER}"
diff --git a/eclass/toolchain-funcs.eclass b/eclass/toolchain-funcs.eclass
index 19a1cd8adb2..b6d1ab0fd1f 100644
--- a/eclass/toolchain-funcs.eclass
+++ b/eclass/toolchain-funcs.eclass
@@ -825,7 +825,7 @@ gen_usr_ldscript() {
redirects the linker to the real lib. And yes, this works in the cross-
compiling scenario as the sysroot-ed linker will prepend the real path.
- See bug http://bugs.gentoo.org/4411 for more info.
+ See bug https://bugs.gentoo.org/4411 for more info.
*/
${output_format}
GROUP ( ${EPREFIX}/${libdir}/${tlib} )
diff --git a/eclass/toolchain.eclass b/eclass/toolchain.eclass
index d93f51d7025..c8d547d3faa 100644
--- a/eclass/toolchain.eclass
+++ b/eclass/toolchain.eclass
@@ -238,7 +238,7 @@ S=$(
gentoo_urls() {
local devspace="HTTP~vapier/dist/URI HTTP~rhill/dist/URI
HTTP~zorry/patches/gcc/URI HTTP~blueness/dist/URI"
- devspace=${devspace//HTTP/http:\/\/dev.gentoo.org\/}
+ devspace=${devspace//HTTP/https:\/\/dev.gentoo.org\/}
echo mirror://gentoo/$1 ${devspace//URI/$1}
}
@@ -1617,7 +1617,7 @@ toolchain_src_install() {
# We remove the generated fixincludes, as they can cause things to break
# (ncurses, openssl, etc). We do not prevent them from being built, as
# in the following commit which we revert:
- # http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/eclass/toolchain.eclass?r1=1.647&r2=1.648
+ # https://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/eclass/toolchain.eclass?r1=1.647&r2=1.648
# This is because bsd userland needs fixedincludes to build gcc, while
# linux does not. Both can dispose of them afterwards.
while read x ; do
@@ -1957,7 +1957,7 @@ toolchain_pkg_postinst() {
echo
ewarn "You might want to review the GCC upgrade guide when moving between"
ewarn "major versions (like 4.2 to 4.3):"
- ewarn "http://www.gentoo.org/doc/en/gcc-upgrading.xml"
+ ewarn "https://www.gentoo.org/doc/en/gcc-upgrading.xml"
echo
# Clean up old paths
diff --git a/eclass/unpacker.eclass b/eclass/unpacker.eclass
index 9aacf654812..7ff00685648 100644
--- a/eclass/unpacker.eclass
+++ b/eclass/unpacker.eclass
@@ -212,7 +212,7 @@ unpack_makeself() {
eerror "I'm sorry, but I was unable to support the Makeself file."
eerror "The version I detected was '${ver}'."
eerror "Please file a bug about the file ${src##*/} at"
- eerror "http://bugs.gentoo.org/ so that support can be added."
+ eerror "https://bugs.gentoo.org/ so that support can be added."
die "makeself version '${ver}' not supported"
;;
esac
diff --git a/eclass/vim-plugin.eclass b/eclass/vim-plugin.eclass
index 4da8bd3c997..7779cd533ab 100644
--- a/eclass/vim-plugin.eclass
+++ b/eclass/vim-plugin.eclass
@@ -17,7 +17,7 @@ DEPEND="|| ( >=app-editors/vim-${VIM_PLUGIN_VIM_VERSION}
RDEPEND="${DEPEND}"
if [[ ${PV} != 9999* ]] ; then
SRC_URI="mirror://gentoo/${P}.tar.bz2
- http://dev.gentoo.org/~radhermit/vim/${P}.tar.bz2"
+ https://dev.gentoo.org/~radhermit/vim/${P}.tar.bz2"
fi
SLOT="0"
diff --git a/eclass/vim-spell.eclass b/eclass/vim-spell.eclass
index 05c38dadc1c..60ae8bb9b6c 100644
--- a/eclass/vim-spell.eclass
+++ b/eclass/vim-spell.eclass
@@ -36,7 +36,7 @@
# files):
#
# <?xml version="1.0" encoding="UTF-8"?>
-# <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+# <!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
# <pkgmetadata>
# <herd>vim</herd>
# <maintainer>
diff --git a/eclass/webapp.eclass b/eclass/webapp.eclass
index 1dddec1edaf..d14d922f41d 100644
--- a/eclass/webapp.eclass
+++ b/eclass/webapp.eclass
@@ -78,7 +78,7 @@ webapp_checkfileexists() {
if [[ ! -e "${my_prefix}${1}" ]]; then
msg="ebuild fault: file '${1}' not found"
eerror "$msg"
- eerror "Please report this as a bug at http://bugs.gentoo.org/"
+ eerror "Please report this as a bug at https://bugs.gentoo.org/"
die "$msg"
fi
}
@@ -338,12 +338,12 @@ webapp_src_preinst() {
eerror "This ebuild did not call webapp_pkg_setup() at the beginning"
eerror "of the pkg_setup() function"
eerror
- eerror "Please log a bug on http://bugs.gentoo.org"
+ eerror "Please log a bug on https://bugs.gentoo.org"
eerror
eerror "You should use emerge -C to remove this package, as the"
eerror "installation is incomplete"
eerror
- die "Ebuild did not call webapp_pkg_setup() - report to http://bugs.gentoo.org"
+ die "Ebuild did not call webapp_pkg_setup() - report to https://bugs.gentoo.org"
fi
# Hint, see the webapp_read_config() function to find where these are
@@ -473,12 +473,12 @@ webapp_pkg_postinst() {
eerror "This ebuild did not call webapp_src_install() at the end"
eerror "of the src_install() function"
eerror
- eerror "Please log a bug on http://bugs.gentoo.org"
+ eerror "Please log a bug on https://bugs.gentoo.org"
eerror
eerror "You should use emerge -C to remove this package, as the"
eerror "installation is incomplete"
eerror
- die "Ebuild did not call webapp_src_install() - report to http://bugs.gentoo.org"
+ die "Ebuild did not call webapp_src_install() - report to https://bugs.gentoo.org"
fi
if has vhosts ${IUSE}; then