summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2020-01-05 00:45:27 +0100
committerJohannes Huber <johu@gentoo.org>2020-01-05 00:45:53 +0100
commit112f52e9b69ad555d62ffb74b9bdb701c49369f1 (patch)
tree778ed0a648104cfe95933a31dd3a36a7768b4e80
parentprofiles: package.mask, mass pmask of media-plugins/vdr-* (diff)
downloadgentoo-112f52e9.tar.gz
gentoo-112f52e9.tar.bz2
gentoo-112f52e9.zip
app-admin/packagekit-qt: Migrate to cmake eclass
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Johannes Huber <johu@gentoo.org>
-rw-r--r--app-admin/packagekit-qt/packagekit-qt-1.0.1-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-admin/packagekit-qt/packagekit-qt-1.0.1-r1.ebuild b/app-admin/packagekit-qt/packagekit-qt-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..c6d6da99c4d4
--- /dev/null
+++ b/app-admin/packagekit-qt/packagekit-qt-1.0.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="PackageKit-Qt"
+MY_P=${MY_PN}-${PV}
+inherit cmake
+
+DESCRIPTION="Qt PackageKit backend library"
+HOMEPAGE="https://www.freedesktop.org/software/PackageKit/"
+SRC_URI="https://github.com/hughsie/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+BDEPEND="
+ dev-libs/libxslt
+ virtual/pkgconfig
+"
+DEPEND="
+ >=app-admin/packagekit-base-0.9
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"