summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-10 10:58:29 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-10 11:15:37 +0100
commit1189471f58c1c4c751a33ea21cebf38d29cc97b8 (patch)
tree3750af3cb3ba75618b306b24efaab167251cc4c9
parentnet-misc/electrum: Bump to 4.0.7 (diff)
downloadgentoo-1189471f58c1c4c751a33ea21cebf38d29cc97b8.tar.gz
gentoo-1189471f58c1c4c751a33ea21cebf38d29cc97b8.tar.bz2
gentoo-1189471f58c1c4c751a33ea21cebf38d29cc97b8.zip
dev-python/watchdog: Bump to 0.10.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/watchdog/Manifest1
-rw-r--r--dev-python/watchdog/watchdog-0.10.5.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/watchdog/Manifest b/dev-python/watchdog/Manifest
index e6f603028d71..f7b7ef3d61ee 100644
--- a/dev-python/watchdog/Manifest
+++ b/dev-python/watchdog/Manifest
@@ -1,3 +1,4 @@
DIST watchdog-0.10.3.tar.gz 89215 BLAKE2B bbe8a2ab3f84b7eff60d4ebd38ac928db85998910fc5b107dcd645c9b91388a9e45d317777f08288ce3bc2befcf9310bb7c8aef4f8e3309481919dc87e84b2a1 SHA512 6061b1393cd07038ee22271101bd6d5c847ee9732b14f63bbb5d94fba9f8273ca728cdc58b6f53a95d8213d0ed35bc71e8bb9c54960bf3aea2f64da066a864f5
DIST watchdog-0.10.4.tar.gz 90303 BLAKE2B 0c057fe35383deaa6b7a66c24c07b2260153e94072b2769dd023210e0e5af90b4556ac18a4e8cab8af794c9dad8709205d9f48022458ee6c93fc0f2926b6f372 SHA512 abaadebd74dd869af545b5a3f10edc9d58f4f0f31f43aaf2244aed2c0ef56828f0b4cf9eda919727c832b20c79e95f50df7193dc8ea9d05d28a52dc322a3a497
+DIST watchdog-0.10.5.tar.gz 91432 BLAKE2B 0f10a94edf4cb79d68b83f0cc6eebc1eae9a00a0fd7b8164977a2511b952b6dda9d0b26404ef316a57524f948eb6676a5da65bb711530f64a4a37ab82576b9a9 SHA512 b107fe23b123360ba8ad049576bdbbb40061c70157bee0663bcf9ee9a9a9f65b95234540a477ba9ae6d617199ca1d77fe30b3b9dc4868bfef08a6b9099d6fe51
DIST watchdog-0.8.3.tar.gz 83154 BLAKE2B d5d0635e83bbcd31544d5ea5811c2f202b0da76bd7a4086e8fc61e3293640e701b04599f95decaa82bee3705dbd6b91ad24b9dbd20edcfc329913600c8a3c932 SHA512 61f1db886e8e9a6d78b569329f4d5944c296778a5a34f94fbf115a748fb4c3be422bf4d3cc828e22fcdcd380fdf9009f5bd91a8a5edc87089afc58297a0b946f
diff --git a/dev-python/watchdog/watchdog-0.10.5.ebuild b/dev-python/watchdog/watchdog-0.10.5.ebuild
new file mode 100644
index 000000000000..44f305c9f08e
--- /dev/null
+++ b/dev-python/watchdog/watchdog-0.10.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python API and shell utilities to monitor file system events"
+HOMEPAGE="https://github.com/gorakhargosh/watchdog"
+SRC_URI="https://github.com/gorakhargosh/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+
+CDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ dev-python/argh[${PYTHON_USEDEP}]
+ dev-python/pathtools[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ test? (
+ >=dev-python/pytest-timeout-0.3[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/--cov/d' setup.cfg || die
+ # broken when django is installed
+ sed -i -e 's:test_eventlet_monkey_patching:_&:' \
+ tests/test_skip_repeats_queue.py || die
+ default
+}
+
+pkg_postinst() {
+ optfeature "Bash completion" dev-python/argcomplete
+}