summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2022-05-27 12:05:09 -0400
committerMike Gilbert <floppym@gentoo.org>2022-05-27 12:05:50 -0400
commit11a9a9dae6476c69f140bbf2938e75b6b11c3959 (patch)
tree8a3e350bbd67b36d9907f219e015e098246a01dc
parentapp-misc/inputlircd: fix kernel headers version test (diff)
downloadgentoo-11a9a9dae6476c69f140bbf2938e75b6b11c3959.tar.gz
gentoo-11a9a9dae6476c69f140bbf2938e75b6b11c3959.tar.bz2
gentoo-11a9a9dae6476c69f140bbf2938e75b6b11c3959.zip
sys-fs/ntfs3g: add 2022.5.17
Bug: https://bugs.gentoo.org/847598 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--sys-fs/ntfs3g/Manifest1
-rw-r--r--sys-fs/ntfs3g/ntfs3g-2022.5.17.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/sys-fs/ntfs3g/Manifest b/sys-fs/ntfs3g/Manifest
index 44a4ffdeed56..0934b57fac7f 100644
--- a/sys-fs/ntfs3g/Manifest
+++ b/sys-fs/ntfs3g/Manifest
@@ -1 +1,2 @@
DIST ntfs-3g_ntfsprogs-2021.8.22.tgz 1317499 BLAKE2B 403036c68a37ba83873b5faadbb2088deb25e0ff31deb1958d4f869a198d830caa44edea879492a7894f5e7a5ad6205a6fda57bf8de722ce49bf3187239ad993 SHA512 e0544df78a6c352999e1206d7b5d71c56e39396b7a0936a261d728c2ac9d61c6b95ef297f8529ac2a5146f31c1c9e43066d3e281064d4f5d781a04eba51f536d
+DIST ntfs-3g_ntfsprogs-2022.5.17.tgz 1318476 BLAKE2B 0f3d5b3ca6186886b1a4f1fc59242a1f4ccdc842cbe53b0869f707c1dbebdd58058d40b265dae663b71a2a611f7ce5392c63afa3053dc075155759c10499d529 SHA512 25e6d3412958576b0cd614f5d93201c0d7e8bbee78fbaf956718a3825c1435b3f0c3631ea1cc60b5b1be6e9ae7d58c0c03b0bebb69edee3bf181a966734336df
diff --git a/sys-fs/ntfs3g/ntfs3g-2022.5.17.ebuild b/sys-fs/ntfs3g/ntfs3g-2022.5.17.ebuild
new file mode 100644
index 000000000000..333eeaf0b761
--- /dev/null
+++ b/sys-fs/ntfs3g/ntfs3g-2022.5.17.ebuild
@@ -0,0 +1,83 @@
+# Copyright 2006-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_P="ntfs-3g_ntfsprogs-${PV}"
+
+DESCRIPTION="Open source read-write NTFS driver that runs under FUSE"
+HOMEPAGE="http://www.tuxera.com/community/ntfs-3g-download/"
+HOMEPAGE="https://jp-andre.pagesperso-orange.fr/advanced-ntfs-3g.html"
+SRC_URI="http://tuxera.com/opensource/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+# The subslot matches the SONAME major #.
+SLOT="0/89"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="acl debug +fuse +mount-ntfs ntfsdecrypt +ntfsprogs static-libs suid xattr"
+
+RDEPEND="
+ sys-apps/util-linux:0=
+ ntfsdecrypt? (
+ >=dev-libs/libgcrypt-1.2.2:0
+ >=net-libs/gnutls-1.4.4
+ )
+"
+DEPEND="${RDEPEND}
+ sys-apps/attr
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ tc-ld-disable-gold
+
+ local myconf=(
+ # passing --exec-prefix is needed as the build system is trying to be clever
+ # and install itself into / instead of /usr in order to be compatible with
+ # separate-/usr setups (which we don't support without an initrd).
+ --exec-prefix="${EPREFIX}"/usr
+
+ --disable-ldconfig
+ --enable-extras
+ $(use_enable debug)
+ $(use_enable fuse ntfs-3g)
+ $(use_enable acl posix-acls)
+ $(use_enable xattr xattr-mappings)
+ $(use_enable ntfsdecrypt crypto)
+ $(use_enable ntfsprogs)
+ $(use_enable static-libs static)
+
+ --with-uuid
+
+ # disable hd library until we have the right library in the tree and
+ # don't links to hwinfo one causing issues like bug #602360
+ --without-hd
+
+ # Needed for suid
+ # https://bugs.gentoo.org/822024
+ --with-fuse=internal
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ if use fuse; then
+ # Plugins directory
+ keepdir "/usr/$(get_libdir)/ntfs-3g"
+ if use suid; then
+ fperms u+s /usr/bin/ntfs-3g
+ fi
+ if use mount-ntfs; then
+ dosym mount.ntfs-3g /sbin/mount.ntfs
+ fi
+ fi
+ find "${ED}" -name '*.la' -type f -delete || die
+}