summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-11-12 18:22:55 +0100
committerMichał Górny <mgorny@gentoo.org>2015-11-17 21:39:09 +0100
commit11b4249df9a07f93988a3007baca3cfd1f0fecaa (patch)
treec422cc47433ba95fb08b535de0aade8983db1688
parentdev-lang/python-exec: Bump to 2.1 (diff)
downloadgentoo-11b4249df9a07f93988a3007baca3cfd1f0fecaa.tar.gz
gentoo-11b4249df9a07f93988a3007baca3cfd1f0fecaa.tar.bz2
gentoo-11b4249df9a07f93988a3007baca3cfd1f0fecaa.zip
app-eselect/eselect-python: Bump to 20151117
The new version no longer alters executable symlinks but instead replaces all executables with python-exec wrappers, relying on changes done in revbump of all dev-lang/python versions. Furthermore, the choice of split python[23] interpreters is done in a config file rather than through symlinks.
-rw-r--r--app-eselect/eselect-python/Manifest1
-rw-r--r--app-eselect/eselect-python/eselect-python-20151117.ebuild53
-rw-r--r--app-eselect/eselect-python/eselect-python-99999999.ebuild28
-rw-r--r--profiles/package.mask3
4 files changed, 71 insertions, 14 deletions
diff --git a/app-eselect/eselect-python/Manifest b/app-eselect/eselect-python/Manifest
index 98a02a21b9f6..4465049cab8c 100644
--- a/app-eselect/eselect-python/Manifest
+++ b/app-eselect/eselect-python/Manifest
@@ -2,3 +2,4 @@ DIST eselect-python-20111108.tar.bz2 64959 SHA256 34d7618808a3c1d22e6763bc6c67d5
DIST eselect-python-20131210.tar.bz2 71802 SHA256 61ff5a5a3ae7982c6ffd503886cbcd35142df05f07008722b90ab5036e4bf8f2 SHA512 8c523019e2a8fe7f1679b96a3da22326dbe65888739bb8cce3c4e2aa7c2c08cada01196a65c8fe35e08b3b7682a3f695e453e9ef1fb53f6b8886c51c09107d60 WHIRLPOOL e8c75eb1ad6fcaaba50cae9d10d2414b29b3cfc8d06c79257948b0d0b4e7c2156d1672be4f5edd28055b5ae3f6aa54b1b8ef6eaaae9dfa1ce9b7b0b68dbc712a
DIST eselect-python-20140115.tar.bz2 71910 SHA256 5898ee19015ae905168e8b7aa76552b96f691285ab77c426b6a9238ecf742e45 SHA512 65d6a6b9dfa0a0f4bea5352f965bed8942a16382135edea093342fa79a824d114b900cbcf607490f260b4ce4e5a2eb57872169e5494f8e6e65f41dd63cd5d335 WHIRLPOOL 633bca3e8a87e04c54a3790bb207da92d41af604cce7f8600c5317f6a759c55efbd3e5ba658e893d2d079248d2dadb1a0bb60248960e3d20cd766768a228d8c5
DIST eselect-python-20140125.tar.bz2 72102 SHA256 ee7b470f7facc42285bab7f4b947280741515a85c9067339511c219248f8fdfb SHA512 94d4eb5a1af365c6f56a6fc2b75298018267cd4f6004f30b2e4d0c4744d3e82b33f6c82e6f0ea0f15132d5157c3ace99fa167bbf3ebada46edd2e005ca96eb51 WHIRLPOOL 70d5f9af2929507d26e56080ce934066d2de5f16030dfd63b016215465ad5fc89eb952d64cc545c7058d146108e26925741d2c8fbaba08abba1a5cae7b0c23b6
+DIST eselect-python-20151117.tar.bz2 62793 SHA256 6f2912ae4d4fc12949ae0c9bb8b93b3a3a8c372336c2138c758f042f91484561 SHA512 3e680f8c851251176d6bb916d003e421e4b414aa9cc59e20cb15d454a3251cdf1e587828e9b2a5db461641f277e3b764ca172f4466fe3f6ef9679a9a05a71732 WHIRLPOOL a2e4ca676ead692b08a6194fb4bf5dabdd383ad158f45a17cb21c59022af139b0646fe39b0f4c9b540c80c4c2a04362c75f90e3c7f1506056b7b0f01e5e51474
diff --git a/app-eselect/eselect-python/eselect-python-20151117.ebuild b/app-eselect/eselect-python/eselect-python-20151117.ebuild
new file mode 100644
index 000000000000..9968e7fac7c4
--- /dev/null
+++ b/app-eselect/eselect-python/eselect-python-20151117.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git"
+else
+ SRC_URI="https://dev.gentoo.org/~mgorny/dist/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-aix ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Eselect module for management of multiple Python versions"
+HOMEPAGE="https://www.gentoo.org/proj/en/Python/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=app-admin/eselect-1.2.3
+ >=dev-lang/python-exec-2.1:2
+ !<dev-lang/python-2.7.10-r3:2.7
+ !<dev-lang/python-3.3.5-r3:3.3
+ !<dev-lang/python-3.4.3-r3:3.4
+ !<dev-lang/python-3.5.0-r2:3.5"
+
+src_prepare() {
+ [[ ${PV} == "99999999" ]] && eautoreconf
+}
+
+src_install() {
+ keepdir /etc/env.d/python
+ emake DESTDIR="${D}" install || die
+
+ local f
+ for f in python{,2,3}{,-config} 2to3 pydoc pyvenv; do
+ dosym ../lib/python-exec/python-exec2 /usr/bin/"${f}"
+ done
+}
+
+pkg_postinst() {
+ if has_version 'dev-lang/python'; then
+ eselect python update --if-unset
+ fi
+ if has_version '=dev-lang/python-2*'; then
+ eselect python update --python2 --if-unset
+ fi
+ if has_version '=dev-lang/python-3*'; then
+ eselect python update --python3 --if-unset
+ fi
+}
diff --git a/app-eselect/eselect-python/eselect-python-99999999.ebuild b/app-eselect/eselect-python/eselect-python-99999999.ebuild
index 6b16b3d05248..9968e7fac7c4 100644
--- a/app-eselect/eselect-python/eselect-python-99999999.ebuild
+++ b/app-eselect/eselect-python/eselect-python-99999999.ebuild
@@ -2,15 +2,13 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-# Keep the EAPI low here because everything else depends on it.
-# We want to make upgrading simpler.
+EAPI=5
if [[ ${PV} == "99999999" ]] ; then
inherit autotools git-r3
EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git"
else
- SRC_URI="mirror://gentoo/${P}.tar.bz2
- https://dev.gentoo.org/~floppym/dist/${P}.tar.bz2"
+ SRC_URI="https://dev.gentoo.org/~mgorny/dist/${P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-aix ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
@@ -21,21 +19,25 @@ LICENSE="GPL-2"
SLOT="0"
IUSE=""
-RDEPEND=">=app-admin/eselect-1.2.3"
+RDEPEND=">=app-admin/eselect-1.2.3
+ >=dev-lang/python-exec-2.1:2
+ !<dev-lang/python-2.7.10-r3:2.7
+ !<dev-lang/python-3.3.5-r3:3.3
+ !<dev-lang/python-3.4.3-r3:3.4
+ !<dev-lang/python-3.5.0-r2:3.5"
-src_unpack() {
- if [[ ${PV} == "99999999" ]] ; then
- git-r3_src_unpack
- cd "${S}"
- eautoreconf
- else
- unpack ${A}
- fi
+src_prepare() {
+ [[ ${PV} == "99999999" ]] && eautoreconf
}
src_install() {
keepdir /etc/env.d/python
emake DESTDIR="${D}" install || die
+
+ local f
+ for f in python{,2,3}{,-config} 2to3 pydoc pyvenv; do
+ dosym ../lib/python-exec/python-exec2 /usr/bin/"${f}"
+ done
}
pkg_postinst() {
diff --git a/profiles/package.mask b/profiles/package.mask
index bc5eafafac0d..b17d5e98e67c 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -69,10 +69,11 @@ sci-chemistry/pymol-apbs-plugin
# Cleaned up Python versions masked for testing:
# - python-config-X.Y compatibility removed,
# - python[23] choice is now stored in config file rather than symlink,
-# - python-exec symlinks added (to replace eselect-python's wrapper),
+# - eselect-python reworked to reuse python-exec and wrap all execs,
# - ABIFLAGS reintroduced for 3.3+.
# Resulting API/ABI change can break reverse dependencies, especially
# if upstream hardcodes paths or library names.
+=app-eselect/eselect-python-20151117
=dev-lang/python-2.7.10-r4
=dev-lang/python-3.3.5-r4
=dev-lang/python-3.4.3-r4