summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-12-01 17:00:46 +0200
committerViorel Munteanu <ceamac@gentoo.org>2023-12-01 17:13:42 +0200
commit129c9b59114392f4ac29952046e5d0a3e56e88ab (patch)
tree43bd33703c20aa8b574eb1a76d752e15014719ac
parentdev-libs/libpcre2: Enable 32bit also by default, needed by other packages (diff)
downloadgentoo-129c9b59114392f4ac29952046e5d0a3e56e88ab.tar.gz
gentoo-129c9b59114392f4ac29952046e5d0a3e56e88ab.tar.bz2
gentoo-129c9b59114392f4ac29952046e5d0a3e56e88ab.zip
dev-python/openapi3: new package, add 1.8.2
Move from ::guru. Switch from pypi to github to have at least some tests. Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
-rw-r--r--dev-python/openapi3/Manifest1
-rw-r--r--dev-python/openapi3/metadata.xml11
-rw-r--r--dev-python/openapi3/openapi3-1.8.2.ebuild33
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/openapi3/Manifest b/dev-python/openapi3/Manifest
new file mode 100644
index 000000000000..697d01605b7e
--- /dev/null
+++ b/dev-python/openapi3/Manifest
@@ -0,0 +1 @@
+DIST openapi3-1.8.2.gh.tar.gz 41402 BLAKE2B a22af8ce1d1c94f3dd2b5f1871222c8c2ec902e9f8b5b065a9a3dd8143ed361df4b26438215e88ac416b6012b015a38c9709b9ed290aaf5cfdaff5b2d1d439f7 SHA512 5555ef0495f7d459fabef98c56da4b1b9d758aa06c4dc83adf1388c044dd0f6b09b933e105ef8665737359fbf98b9699ca2d7127ead2aa86e3f99682b29dbf1e
diff --git a/dev-python/openapi3/metadata.xml b/dev-python/openapi3/metadata.xml
new file mode 100644
index 000000000000..b0af68e225aa
--- /dev/null
+++ b/dev-python/openapi3/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ceamac@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">openapi3</remote-id>
+ <remote-id type="github">Dorthu/openapi3</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/openapi3/openapi3-1.8.2.ebuild b/dev-python/openapi3/openapi3-1.8.2.ebuild
new file mode 100644
index 000000000000..77cb4b50a85a
--- /dev/null
+++ b/dev-python/openapi3/openapi3-1.8.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python OpenAPI 3 Specification client and validator"
+HOMEPAGE="
+ https://pypi.org/project/openapi3/
+ https://github.com/Dorthu/openapi3
+"
+SRC_URI="https://github.com/Dorthu/openapi3/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # the fastapi test is broken for fastapi 0.94+
+ rm -f tests/fastapi_test.py || die
+ epytest
+}