summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-01-11 00:14:02 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-01-11 00:15:00 +0100
commit12be7a9cb56db1761bcc8a440952d90ef671e988 (patch)
treece10f56b13bd91246952a0db675611f190bd59a9
parentmedia-sound/lilypond: Add patch to remove ly protects (diff)
downloadgentoo-12be7a9cb56db1761bcc8a440952d90ef671e988.tar.gz
gentoo-12be7a9cb56db1761bcc8a440952d90ef671e988.tar.bz2
gentoo-12be7a9cb56db1761bcc8a440952d90ef671e988.zip
dev-python/httpstat: New package
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--dev-python/httpstat/Manifest1
-rw-r--r--dev-python/httpstat/files/httpstat-1.2.1-gentoo-tests.patch30
-rw-r--r--dev-python/httpstat/httpstat-1.2.1.ebuild28
-rw-r--r--dev-python/httpstat/metadata.xml12
4 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/httpstat/Manifest b/dev-python/httpstat/Manifest
new file mode 100644
index 000000000000..0e2667a7ad50
--- /dev/null
+++ b/dev-python/httpstat/Manifest
@@ -0,0 +1 @@
+DIST httpstat-1.2.1.tar.gz 97012 BLAKE2B 2c2ae97fe7c5f6563b3b29e8f40ec18ca62ab0efecd81bda404a57f594574d1647b9f72bea644a3e934670c0d142e4e1f9b866ed6cf215cd4183d6f574b252a5 SHA512 58636eacc7ad57fc6ab5fe477117547c515828e1dd50980d7c1d7c70d2fd04a8539339331bbf4e8a9ac9fea199626a45e7c3e2e458e11b78fb848027ff7c6a76
diff --git a/dev-python/httpstat/files/httpstat-1.2.1-gentoo-tests.patch b/dev-python/httpstat/files/httpstat-1.2.1-gentoo-tests.patch
new file mode 100644
index 000000000000..2ce199a94b75
--- /dev/null
+++ b/dev-python/httpstat/files/httpstat-1.2.1-gentoo-tests.patch
@@ -0,0 +1,30 @@
+- Testscript doesn't need to run tests for multiple python implementations,
+ PM will take care of that.
+
+- Disabling test which requires specific locales.
+
+--- a/httpstat_test.sh
++++ b/httpstat_test.sh
+@@ -19,8 +19,7 @@ function title() {
+ http_url="google.com"
+ https_url="https://http2.akamai.com"
+
+-for pybin in python python3; do
+-#for pybin in python; do
++for pybin in python; do
+ echo
+ echo "# Test in $pybin"
+
+@@ -40,9 +39,9 @@ for pybin in python python3; do
+ main_silent $https_url
+ assert_exit 0
+
+- title "comma decimal language (ru_RU)"
+- LC_ALL=ru_RU main_silent $http_url
+- assert_exit 0
++ #title "comma decimal language (ru_RU)"
++ #LC_ALL=ru_RU main_silent $http_url
++ #assert_exit 0
+
+ title "HTTPSTAT_DEBUG"
+ HTTPSTAT_DEBUG=true main $http_url | grep -q 'HTTPSTAT_DEBUG=true'
diff --git a/dev-python/httpstat/httpstat-1.2.1.ebuild b/dev-python/httpstat/httpstat-1.2.1.ebuild
new file mode 100644
index 000000000000..2b9302f689b2
--- /dev/null
+++ b/dev-python/httpstat/httpstat-1.2.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="httpstat visualizes cURL statistics in a way of beauty and clarity"
+HOMEPAGE="https://github.com/reorx/httpstat"
+SRC_URI="https://github.com/reorx/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND="net-misc/curl:*"
+
+# Requires access to google.com and http2.akamai.com
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.2.1-gentoo-tests.patch )
+
+python_test() {
+ ./httpstat_test.sh || die
+}
diff --git a/dev-python/httpstat/metadata.xml b/dev-python/httpstat/metadata.xml
new file mode 100644
index 000000000000..2dcc864feab4
--- /dev/null
+++ b/dev-python/httpstat/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>whissi@gentoo.org</email>
+ <name>Thomas Deutschmann</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/reorx/httpstat/issues</bugs-to>
+ <remote-id type="github">reorx/httpstat</remote-id>
+ </upstream>
+</pkgmetadata>