summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2020-07-29 16:02:29 +0200
committerAgostino Sarubbo <ago@gentoo.org>2020-07-29 16:02:29 +0200
commit1309b356719c71d1c58478a4e55f92945f09c152 (patch)
treee44ab3614907b073120cffdd131a787b44f6010a
parentprofiles: unmask renamed app-dicts/sword-* packages, expand comment (diff)
downloadgentoo-1309b356719c71d1c58478a4e55f92945f09c152.tar.gz
gentoo-1309b356719c71d1c58478a4e55f92945f09c152.tar.bz2
gentoo-1309b356719c71d1c58478a4e55f92945f09c152.zip
app-admin/exo: version bump to 1.15.0
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
-rw-r--r--app-admin/exo/Manifest1
-rw-r--r--app-admin/exo/exo-1.15.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-admin/exo/Manifest b/app-admin/exo/Manifest
index 5e32c724c23d..32d0fae6eef0 100644
--- a/app-admin/exo/Manifest
+++ b/app-admin/exo/Manifest
@@ -1 +1,2 @@
DIST exo-1.14.0.tar.gz 4268326 BLAKE2B 5449003cf3b4828c40ecee2027174a407096a926807e781d847bf04fe5a10913da8308300bfe0b1bd444bb1696afb73369237a5e3260271c72239cfdf96d0c1b SHA512 ba8379580e1ae964e97b6f45f9f5c0c74803ce4ec6c0fbdef1885771c7ed0d30ebe332dcdbb45875365894c105136588880ef26fa8769f9a4c700cf67b3f1430
+DIST exo-1.15.0.tar.gz 4267440 BLAKE2B 5b5f38df929c538528084ecae8ae73f2c2486b2a3ad45c7c4ba55021680912490c90d820c72ac1e858caf023382b2de3a573a6e7f096b3b84abf3da237a3bca0 SHA512 d42887a24de2385acc7e66daab0c51b413304fd96589755874716702747aaea74ea0f080e334f2a4ebcf8b6c6699257f6e36e5ddf9acf9c7aca2693555edbfb2
diff --git a/app-admin/exo/exo-1.15.0.ebuild b/app-admin/exo/exo-1.15.0.ebuild
new file mode 100644
index 000000000000..0c2c8d861fe4
--- /dev/null
+++ b/app-admin/exo/exo-1.15.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Command-line tool for everything at Exoscale: compute, storage, dns."
+HOMEPAGE="https://github.com/exoscale/cli"
+SRC_URI="https://github.com/exoscale/cli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+DEPEND="dev-lang/go:="
+RESTRICT="strip"
+QA_FLAGS_IGNORED=".*"
+
+S="${WORKDIR}/cli-${PV}"
+
+src_compile() {
+ go build -mod vendor -o ${PN} || die "build failed"
+}
+
+src_test() {
+ # run at least 'exo version' for test
+ ./exo version > /dev/null 2>&1
+ if [[ $? -ne 0 ]]
+ then
+ die "Test failed"
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+}