summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2016-05-08 18:39:26 +0200
committerDavide Pesavento <pesa@gentoo.org>2016-05-08 18:39:26 +0200
commit133b5ca6296a6c21ba0176bd81a8310b1ff06ed4 (patch)
tree2152d64a022df08f0d0b277b8ef91bc2f560152a
parentmedia-video/qx11grab: sort RDEPEND (diff)
downloadgentoo-133b5ca6296a6c21ba0176bd81a8310b1ff06ed4.tar.gz
gentoo-133b5ca6296a6c21ba0176bd81a8310b1ff06ed4.tar.bz2
gentoo-133b5ca6296a6c21ba0176bd81a8310b1ff06ed4.zip
app-editors/tea: version bump
Package-Manager: portage-2.2.28
-rw-r--r--app-editors/tea/Manifest1
-rw-r--r--app-editors/tea/tea-41.1.1.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/app-editors/tea/Manifest b/app-editors/tea/Manifest
index a68f959734dc..35b7fe2b8b8d 100644
--- a/app-editors/tea/Manifest
+++ b/app-editors/tea/Manifest
@@ -1 +1,2 @@
DIST tea-41.1.0.tar.bz2 381370 SHA256 65ea128739802b7626a5a59de12b0e885dcef7a83f7bcd06b6d3aea830ed8717 SHA512 a46e0cdfce5c7d453c7783c59ad98b2b029847ddcc8ce0655c6e1ae45825426ac1b271ca7ad90f0219d8f796f507f6bdba0f2c764c563c8c23503b94be817eb7 WHIRLPOOL a3d00f5e42a145be2a7f3bf846832bf2a7e95e957abf4c928118be7607adb57fddfb906fbedaf7fa51665b25629beae0fe5b4db40886f42dfcf5c166e43717b5
+DIST tea-41.1.1.tar.bz2 382592 SHA256 5f17a1f190c7a31f326273f5c987378f9fdbc3fc34a7d0a97529bc926492bef9 SHA512 087325a80f86b27c20174849a8477d1d994176f560fc0bc353cfa6bfcfc1e916bac42607d94640cd1c2e1abd6385db7a836557a6ef2defae6de0901195fc7975 WHIRLPOOL d1e48c2ba40d2978a06c2069927ba664b17f84039e96b349937ae5f159e32998a964fd86e8c89725bb36845aba541ba4eccfb91f939fb352b727e1cf2aa72548
diff --git a/app-editors/tea/tea-41.1.1.ebuild b/app-editors/tea/tea-41.1.1.ebuild
new file mode 100644
index 000000000000..b834812e4bca
--- /dev/null
+++ b/app-editors/tea/tea-41.1.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PLOCALES="de fr ru"
+
+inherit eutils l10n qmake-utils
+
+DESCRIPTION="Small, lightweight Qt text editor"
+HOMEPAGE="http://tea.ourproject.org/ http://semiletov.org/tea/"
+SRC_URI="http://tea.ourproject.org/dloads/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86 ~x86-fbsd"
+IUSE="aspell hunspell"
+
+RDEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ sys-libs/zlib
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell )
+"
+DEPEND="${RDEPEND}
+ hunspell? ( virtual/pkgconfig )
+"
+
+DOCS=( AUTHORS ChangeLog NEWS TODO )
+
+src_configure() {
+ eqmake4 src.pro \
+ $(use aspell || echo CONFIG+=noaspell) \
+ $(use hunspell || echo CONFIG+=nohunspell)
+}
+
+src_install() {
+ dobin bin/tea
+
+ newicon icons/tea-icon-v3-01.png ${PN}.png
+ make_desktop_entry ${PN} 'Tea Editor'
+
+ # translations
+ insinto /usr/share/qt4/translations
+ local lang
+ for lang in $(l10n_get_locales); do
+ doins translations/${PN}_${lang}.qm
+ done
+
+ # docs
+ dohtml manuals/en.html
+ if use linguas_ru; then
+ dodoc NEWS-RU
+ dohtml manuals/ru.html
+ fi
+}