summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-08-02 01:03:33 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-08-02 05:16:24 -0400
commit1399b9f2f3b01b12153eab1e9dc7546b2e1ea168 (patch)
tree1de9c9d1aff9e23468794fa4b58c1d87a7c20078
parentsys-apps/diffutils: Remove modern EAPI defaults (diff)
downloadgentoo-1399b9f2f3b01b12153eab1e9dc7546b2e1ea168.tar.gz
gentoo-1399b9f2f3b01b12153eab1e9dc7546b2e1ea168.tar.bz2
gentoo-1399b9f2f3b01b12153eab1e9dc7546b2e1ea168.zip
games-simulation/gl117: EAPI6->8, replace homepage, fix icon
* HOMEPAGE is 404, use sourceforge project page as alternative * Non-square .jpg is not a valid XDG icon, replaced with png * Add bugref to patch Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--games-simulation/gl117/Manifest1
-rw-r--r--games-simulation/gl117/files/gl117-1.3.2-mode.patch5
-rw-r--r--games-simulation/gl117/gl117-1.3.2-r1.ebuild38
3 files changed, 25 insertions, 19 deletions
diff --git a/games-simulation/gl117/Manifest b/games-simulation/gl117/Manifest
index 4d4c66267bdd..8d1db3b9506d 100644
--- a/games-simulation/gl117/Manifest
+++ b/games-simulation/gl117/Manifest
@@ -1 +1,2 @@
DIST gl-117-1.3.2-src.tar.bz2 2411075 BLAKE2B efd2c7b9dd3f71bf0b8b1aac79f90dcc6286301997913346f8ee536b3f5981564438e6a805c658678b5ae0402f84da762b60472ddc553cab49f9ffb421d69993 SHA512 1d2382576c6399d8c84d56ddc7eb2b11b9e1e3ffeebcc1bd30e258ef231626d15d1be649f8c791f30e4f2f78aca2b4290c5d08036c5f482eef01eda8f4f48b5f
+DIST gl117.png 2274 BLAKE2B dfa2b8fe0e858e1f0fa1af27bd8e38d3bba55c31d4c26abe831cd08f01a9d198c2a38ec7c9c1c49af851da24cce692c489220624b93eae0ed4692139c73f8f7d SHA512 374b41af6cb5ec10e3b59b983f28206cb7bc88c3559a24332ef43bd4b135971c0541dbf6f3b5e97c7b7e329bc3d5bbfa5119b9be6cbec243193e5a4ac0220c3b
diff --git a/games-simulation/gl117/files/gl117-1.3.2-mode.patch b/games-simulation/gl117/files/gl117-1.3.2-mode.patch
index d3f13084a96f..c63fdaa26074 100644
--- a/games-simulation/gl117/files/gl117-1.3.2-mode.patch
+++ b/games-simulation/gl117/files/gl117-1.3.2-mode.patch
@@ -1,5 +1,6 @@
---- a/src/main.cpp 2010-07-13 09:35:18.374122609 +0100
-+++ b/src/main.cpp 2010-07-13 09:35:45.334955120 +0100
+https://bugs.gentoo.org/327965
+--- a/src/main.cpp
++++ b/src/main.cpp
@@ -71,8 +71,7 @@ int mode = 0;
// pre-defined screen resolutions (x, y, bpp, fullscreen)
diff --git a/games-simulation/gl117/gl117-1.3.2-r1.ebuild b/games-simulation/gl117/gl117-1.3.2-r1.ebuild
index f5c52f6068ab..8f27db3990a6 100644
--- a/games-simulation/gl117/gl117-1.3.2-r1.ebuild
+++ b/games-simulation/gl117/gl117-1.3.2-r1.ebuild
@@ -1,37 +1,41 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils
+EAPI=8
+
+inherit desktop
MY_P="gl-117-${PV}-src"
-DESCRIPTION="An action flight simulator"
-HOMEPAGE="http://www.heptargon.de/gl-117/gl-117.html"
-SRC_URI="mirror://sourceforge/gl-117/${MY_P}.tar.bz2"
-LICENSE="GPL-2"
+DESCRIPTION="Action flight simulator"
+HOMEPAGE="https://sourceforge.net/projects/gl-117/"
+SRC_URI="
+ mirror://sourceforge/gl-117/${MY_P}.tar.bz2
+ https://dev.gentoo.org/~ionen/distfiles/${PN}.png"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND="
+RDEPEND="
media-libs/freeglut
- media-libs/libsdl[sound,joystick,opengl,video]
+ media-libs/libsdl[joystick,opengl,sound,video]
media-libs/sdl-mixer[mod]
virtual/glu
virtual/opengl"
-RDEPEND=${DEPEND}
-
-S=${WORKDIR}/${MY_P}
+DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${P}-mode.patch
)
src_install() {
- DOCS="doc/gl-117.pdf AUTHORS ChangeLog FAQ NEWS README" \
- default
- newicon doc/src/falcon.jpg ${PN}.jpg
- make_desktop_entry gl-117 GL-117 /usr/share/pixmaps/${PN}.jpg
+ default
+
doman doc/gl-117.6
+ dodoc doc/gl-117.pdf
+
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry gl-117 GL-117
}