summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-03-02 10:11:38 -0500
committerMatt Turner <mattst88@gentoo.org>2023-03-02 10:20:47 -0500
commit147781be6197ab09e764975a67ae3803dccdec6f (patch)
tree143ac9c90e7fc23b5a54d45bdafe1acdc0fcbd6f
parentgnome-extra/gnome-shell-extension-alphabetical-grid: drop 26.0 (diff)
downloadgentoo-147781be6197ab09e764975a67ae3803dccdec6f.tar.gz
gentoo-147781be6197ab09e764975a67ae3803dccdec6f.tar.bz2
gentoo-147781be6197ab09e764975a67ae3803dccdec6f.zip
x11-libs/pango: Version bump to 1.50.14
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-libs/pango/Manifest1
-rw-r--r--x11-libs/pango/pango-1.50.14.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/x11-libs/pango/Manifest b/x11-libs/pango/Manifest
index 7ce655fb8b7c..2354f47add75 100644
--- a/x11-libs/pango/Manifest
+++ b/x11-libs/pango/Manifest
@@ -2,3 +2,4 @@ DIST pango-1.42.4-patchset.tar.xz 6040 BLAKE2B ec3f1a6a4de30e0864e7f0bf0950cb7a7
DIST pango-1.42.4.tar.xz 833876 BLAKE2B 7de1094a29750b9e59ea1e5c92644fa5d6b835828d027963a53cce3f204ee1ea0042ec492e209de9136f05ca131ccda959bc477d4f6e9c72e5f620ddf4235f26 SHA512 993e97f647eba0c5ed90bcfcb8228bf67fa3f20b1f4331e4e40a30788d7c3ac55eee1209471bf21df125cb8fc6121acc8062a9da2f8a7d6cbe8e9ad13a9320dc
DIST pango-1.50.12.tar.xz 4272856 BLAKE2B 60a06416f82e8e5419bca7c89cae17bcd60605b944f483bc7a4ce4405710f00dd40c78abfbe9fdbf8d4786780540f92adfde45e615be4175450e608ba618df08 SHA512 488a55e875487ded8c298151d67a3a7ec4653f2c311145fe83b1297417b1154d5e86b199013ee986c7d2575c889fafcb2f148ee4e5ff9ca143f9fb716a71512d
DIST pango-1.50.13.tar.xz 4273188 BLAKE2B 8524d5ff478137e6f3795aff8428a8bc864d72338d93c579c039c94eba368526d38f999b7a9b1964e3649d748393dbe2fffaa29a11732df5bd0adff010d79e05 SHA512 1a8ccf645b4340d3ad450c7edc8f236279d1577234b06587ca74dd94fbcfb9ee625c3a27616771a91d6dc1db24900a9557fb0a1b861ad0c004422a36678e41de
+DIST pango-1.50.14.tar.xz 4273776 BLAKE2B 24f70c56aee117e09d53c0ccf7cb3605bf8fec847816a163d9d39ce970c11339ca2eb4463c40e2d53a68c32e45d8ae40be81250caea8591ae340004936f3c2a7 SHA512 2c9330b65920fdd0ab6d645aed785a364158d78068bdcd7ba15b6a7368835677f06f2f8fd158cd23b05f98a37fb903e29526ade8f4d62913dbc5809f737d5166
diff --git a/x11-libs/pango/pango-1.50.14.ebuild b/x11-libs/pango/pango-1.50.14.ebuild
new file mode 100644
index 000000000000..fca45be53855
--- /dev/null
+++ b/x11-libs/pango/pango-1.50.14.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic gnome2-utils meson-multilib xdg
+
+DESCRIPTION="Internationalized text layout and rendering library"
+HOMEPAGE="https://www.pango.org/ https://gitlab.gnome.org/GNOME/pango"
+SRC_URI="http://ftp.gnome.org/pub/GNOME/sources/pango/$(ver_cut 1-2)/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+IUSE="debug +introspection sysprof test X"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.62.2:2[${MULTILIB_USEDEP}]
+ >=dev-libs/fribidi-1.0.6[${MULTILIB_USEDEP}]
+ >=media-libs/harfbuzz-2.6.0:=[glib(+),introspection?,truetype(+),${MULTILIB_USEDEP}]
+ >=media-libs/fontconfig-2.13.0:1.0=[${MULTILIB_USEDEP}]
+ >=x11-libs/cairo-1.12.10:=[X?,${MULTILIB_USEDEP}]
+ >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+ X? (
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXft-2.3.1-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXrender-0.9.8[${MULTILIB_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}
+ sysprof? ( >=dev-util/sysprof-capture-3.40.1:4[${MULTILIB_USEDEP}] )
+ X? ( x11-base/xorg-proto )
+"
+BDEPEND="
+ dev-util/glib-utils
+ sys-apps/help2man
+ virtual/pkgconfig
+ test? ( media-fonts/cantarell )
+"
+
+src_prepare() {
+ default
+ xdg_environment_reset
+ gnome2_environment_reset
+}
+
+multilib_src_configure() {
+ if use debug; then
+ append-cflags -DPANGO_ENABLE_DEBUG
+ else
+ append-cflags -DG_DISABLE_CAST_CHECKS
+ fi
+
+ local emesonargs=(
+ # Never use gi-docgen subproject
+ --wrap-mode nofallback
+
+ -Dgtk_doc=false # we ship pregenerated docs
+ $(meson_native_use_feature introspection)
+ -Dinstall-tests=false
+ -Dfontconfig=enabled
+ $(meson_feature sysprof)
+ -Dlibthai=disabled
+ -Dcairo=enabled
+ $(meson_feature X xft)
+ -Dfreetype=enabled
+ )
+ meson_src_configure
+}
+
+multilib_src_install_all() {
+ insinto /usr/share/gtk-doc/html
+ # This will install PangoXft API docs regardless of USE=-X, but this is intentional
+ doins -r "${S}"/docs/Pango*
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if has_version 'media-libs/freetype[-harfbuzz]' ; then
+ ewarn "media-libs/freetype is installed without harfbuzz support. This may"
+ ewarn "lead to minor font rendering problems, see bug 712374."
+ fi
+}