summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-07 09:44:07 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-07 09:56:19 +0100
commit14ee9cf46fd62823636fe883b2def926c5c4bc02 (patch)
treede1a713c0951388c2672abf8ce6b4eb64f79b7df
parentdev-python/genty: Version Bump (diff)
downloadgentoo-14ee9cf46fd62823636fe883b2def926c5c4bc02.tar.gz
gentoo-14ee9cf46fd62823636fe883b2def926c5c4bc02.tar.bz2
gentoo-14ee9cf46fd62823636fe883b2def926c5c4bc02.zip
dev-python/flaky: Version Bump
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/flaky/Manifest1
-rw-r--r--dev-python/flaky/flaky-3.0.1.ebuild48
-rw-r--r--dev-python/flaky/metadata.xml2
3 files changed, 50 insertions, 1 deletions
diff --git a/dev-python/flaky/Manifest b/dev-python/flaky/Manifest
index 4b1686b37a5f..c618a323314f 100644
--- a/dev-python/flaky/Manifest
+++ b/dev-python/flaky/Manifest
@@ -1,2 +1,3 @@
DIST flaky-2.4.0.tar.gz 27157 SHA256 6446e186674db9d67be5e85857b6e98a68a6491d5d307447d9a1a6721aca9fad SHA512 e3f51dab94a2e2140714f15ae088113c2e5cb65f58d38d5ae20b91c567c207568403c1267edeaf9f0f8c6bec7b03ebb0c02178cca30f3dd3a16aa4d099ca8153 WHIRLPOOL 20571c64d46ebbb87173a0e6bc859473528270c179c7cde045fded2a98708034f95864a92c137596b936f78e21984ca17ec0670063c470f14d1ce6ce1213c70f
DIST flaky-2.4.1.tar.gz 27430 SHA256 e8e94450c7c5d56bd30e0634fc6c725936e7585322d60469195dfa416c0ab2ea SHA512 2c4736ee370a9462bed29239a525a8a0296ebbb0abc6f194ac36db1fa6fab78d41c3927f1cd3d5c50649f374406e3203c16f0d2f4e3fac6a458392db110ed0f9 WHIRLPOOL a5665b1ae1e8f82ac96ca07675e719f3c5f29a0347c5c5dc1b1badcfc2454b3fa97e9606299f2b23ef30f61a6342d399eedbafb02931b6f9746af6dcc73f53e2
+DIST flaky-3.0.1.tar.gz 21683 SHA256 9004f24832130835a89c1d767b1353f867b1e6aae434cde13749485d377a515e SHA512 4774d53cfc4b32f6555a00605c4ccb776811e04baf1de3a96dcb4029eefe83d3f2534f97f8021a0bf2fadf3bb041a863833dc4ef08c782fe979ac52cd4e9a1c6 WHIRLPOOL a32734fd09b88e9889062574bdf6c1c4f179ecbd7381e8964183ada06a53c0669db81edf16f0096cd4a4a7c1df49917ffd97387a8f0c7c92587b0f0697fd0d6b
diff --git a/dev-python/flaky/flaky-3.0.1.ebuild b/dev-python/flaky/flaky-3.0.1.ebuild
new file mode 100644
index 000000000000..ae33750559dc
--- /dev/null
+++ b/dev-python/flaky/flaky-3.0.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Plugin for nose or py.test that automatically reruns flaky tests"
+HOMEPAGE="https://pypi.python.org/pypi/flaky https://github.com/box/flaky"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/genty[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+# https://github.com/box/flaky/issues/87
+RESTRICT="test"
+
+python_prepare_all() {
+ cat >> test/__init__.py <<- EOF
+ # coding: utf-8
+
+ from __future__ import unicode_literals
+ EOF
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests --with-flaky --exclude="test_nose_options_example" test/test_nose/ || die
+ py.test -k 'example and not options' --doctest-modules test/test_pytest/ || die
+ py.test -p no:flaky test/test_pytest/test_flaky_pytest_plugin.py || die
+ nosetests --with-flaky --force-flaky --max-runs 2 test/test_nose/test_nose_options_example.py || die
+ py.test --force-flaky --max-runs 2 test/test_pytest/test_pytest_options_example.py || die
+}
diff --git a/dev-python/flaky/metadata.xml b/dev-python/flaky/metadata.xml
index a0aa18eab723..1e9592034036 100644
--- a/dev-python/flaky/metadata.xml
+++ b/dev-python/flaky/metadata.xml
@@ -1,4 +1,4 @@
-<?xml version='1.0' encoding='UTF-8'?>
+<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer>