summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-14 07:52:29 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-14 09:08:03 +0100
commit1572ef90a5e258028373d48fbc4679812c50c186 (patch)
treee51d5b9b7dc4f7e2a398240305db7c6f368bb962
parentdev-python/django-timezone-field: Bump to 4.2.3 (diff)
downloadgentoo-1572ef90a5e258028373d48fbc4679812c50c186.tar.gz
gentoo-1572ef90a5e258028373d48fbc4679812c50c186.tar.bz2
gentoo-1572ef90a5e258028373d48fbc4679812c50c186.zip
dev-python/google-api-python-client: Bump to 2.35.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/google-api-python-client/Manifest1
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.35.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 9de040ee5dfc..b7a968d1f3a4 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1 +1,2 @@
DIST google-api-python-client-2.34.0.tar.gz 28469433 BLAKE2B aa2c8849b629fe489cf39cddd410a40a0af0bddfa5f370a4a41c1446aeadf69cd4592eeb1d76e6c63da9737906801aea9c8a4d706328b63a7bf5b34a43b83e00 SHA512 321dfdd3ba821beabc6c3a96575afd06c75a0c8e3db61b1ff5fa9db472e62de81b037c435a1051d6294c2a37e471bcaa068cd27ad7434a3416231d31931dd74e
+DIST google-api-python-client-2.35.0.tar.gz 28553015 BLAKE2B 8ff92145f280e090b8f43c10e425dd4a8fe65b4cf565c5b5a0df2813cdb8ba1bcea50e37556efb9dd0b270a21fe11b7d6d1b445c8fdaa83326c7dc6230ee1fdb SHA512 4d0325b79250a26ae252568759e8345d31d692aa1d8f1d7aae623bb9a1a950efae654cd689d39f30450789c6d4fa9ca264111f8a9e798820cf6d0c3acba904f6
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.35.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.35.0.ebuild
new file mode 100644
index 000000000000..b7db8f42faf4
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.35.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="https://github.com/googleapis/google-api-python-client"
+SRC_URI="https://github.com/googleapis/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ dev-python/google-api-core[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+ "
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ distutils_install_for_testing
+ epytest tests
+}