summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2018-03-02 07:32:17 +0100
committerUltrabug <ultrabug@gentoo.org>2018-03-02 15:35:22 +0100
commit15a2e0e70f8cddcf60e3444a98edf695d1033cbd (patch)
tree3a63f8220a6cbe94a6cf793374d812a22c55ed30
parentapp-admin/mongo-tools: drop old (diff)
downloadgentoo-15a2e0e7.tar.gz
gentoo-15a2e0e7.tar.bz2
gentoo-15a2e0e7.zip
dev-libs/libbson: bump to 1.9.3
Package-Manager: Portage-2.3.24, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/7332
-rw-r--r--dev-libs/libbson/Manifest1
-rw-r--r--dev-libs/libbson/libbson-1.9.3.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-libs/libbson/Manifest b/dev-libs/libbson/Manifest
index 571b6805294a..507fdb270031 100644
--- a/dev-libs/libbson/Manifest
+++ b/dev-libs/libbson/Manifest
@@ -5,3 +5,4 @@ DIST libbson-1.3.5.tar.gz 4547720 BLAKE2B e5e258344aea0969ac74d88d040a464b72d460
DIST libbson-1.3.6.tar.gz 4546329 BLAKE2B fa9102cd02e40e0ddb7518d34502f6ff63109b91af18a2285422530dae8c6cc04041b7589f340f2e6ed7a80e2474fea2684001b7ced5e8c911d4ba51e1a6edcc SHA512 a7da914ed0f03212d4fb01879543f0b2c7629923e33200fe30335a9a90a1082ffa2566c7a556b90a6c7ffbef5665a45ec67f87ffff2a5fcb89830769b1df5130
DIST libbson-1.6.2.tar.gz 4835257 BLAKE2B ebe20a6c9ac8a4fcbd8e838d1a7cd319a6b31956690aa2dfca2be42eaafb646405ea01fe2bf20b2dc21bf933c0eafc330fd45409f7c902a7bf0c0641cfe0891d SHA512 f95f5bb829cff3aac6c1d95a159e38396d8fccef66d3026dac8085ba13ec376274cddeb92277d711ac4d40cafd8b89b73e9a9d1cf29e22f7f79aa9422c69488b
DIST libbson-1.8.2.tar.gz 4885188 BLAKE2B bd867dc2b93fbc45d155e0433cf20202ccabc8fc20414cf0dec9401242ed4469f89f067c56a9c1e304bd2e806c94682fd9b7a26300f56f7da690338b8df72811 SHA512 a0d9e0e3acdeb03f2de4507330cda36b2bcdeb2420ab4a0b342fe666799113f4384859af70d02d3c01ef1e4e0b8f2a06732ed14f86b386452508c680acb9b94d
+DIST libbson-1.9.3.tar.gz 4957319 BLAKE2B a4e4ebc96f876e52173fbf41e9cb995824683f6eaef7d49dd71ad834f313bf182bec456ca8e78d697d1688a54c497702783a18424bf32b485a205a9ad7044453 SHA512 ad2fdba2138c3197d236740ed2765848737afc847cb7b9e9a418c1fb98eceabccc561dab040aab1b7d67160f5969930c51caa17962667a35102475d909b4cbb7
diff --git a/dev-libs/libbson/libbson-1.9.3.ebuild b/dev-libs/libbson/libbson-1.9.3.ebuild
new file mode 100644
index 000000000000..8d74b74a4e4f
--- /dev/null
+++ b/dev-libs/libbson/libbson-1.9.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A BSON utility library"
+HOMEPAGE="https://github.com/mongodb/libbson"
+SRC_URI="https://github.com/mongodb/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="debug examples static-libs"
+
+src_configure() {
+ econf --disable-optimizations \
+ $(use_enable debug) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ # Installing all the manuals conflicts with man-pages
+ doman doc/man/bson_*.3
+
+ if ! use static-libs; then
+ find "${D}" -name '*.la' -delete || die
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc examples/*.c
+ fi
+
+ einstalldocs
+}
+
+src_test() {
+ emake test
+}