summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-08-07 09:06:51 +0200
committerJeroen Roovers <jer@gentoo.org>2018-08-07 09:25:11 +0200
commit164be846fbd618f85f363437f7a5b48d0389fbdb (patch)
tree5bc7b5c7843423b8adc450dd925c9277726231d1
parentkde-plasma/plasma-pa: Drop obsolete pulseaudio[gnome(+)] requirement (diff)
downloadgentoo-164be846fbd618f85f363437f7a5b48d0389fbdb.tar.gz
gentoo-164be846fbd618f85f363437f7a5b48d0389fbdb.tar.bz2
gentoo-164be846fbd618f85f363437f7a5b48d0389fbdb.zip
net-firewall/psad: Version 2.4.6.
Package-Manager: Portage-2.3.44, Repoman-2.3.10
-rw-r--r--net-firewall/psad/Manifest1
-rw-r--r--net-firewall/psad/psad-2.4.6.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/net-firewall/psad/Manifest b/net-firewall/psad/Manifest
index 91418476e3bf..7b76497a3da2 100644
--- a/net-firewall/psad/Manifest
+++ b/net-firewall/psad/Manifest
@@ -2,3 +2,4 @@ DIST psad-2.2.5.tar.bz2 1243987 BLAKE2B f6b3a86a841b2685a21c4f46cab8cbb720a79556
DIST psad-2.4.3.tar.bz2 1395260 BLAKE2B ec48705c90fb9acf7f6f534c103ce83fb39933f6431539be50873b26dd51bf49eee709261c0c036136bf08c6820e7344315b6162664e54b455d380b1987efebf SHA512 8a25ef377e3f4f406c2179a42217110a670f1c0eb8e7991e32a99fd695ca1866218274e9aaeb48552e1bd9bd91b5fbf34b226d767c28f1db27f15b08fba2b0e8
DIST psad-2.4.4.tar.bz2 1429113 BLAKE2B 3eed68eb1752051f4cab8320c168b9a66e3aebdbcef41a78990202e05ff4a317714f345baf3c5998975b6c8db2ca95d2b354ce4ebaea50feb9749701ae6af046 SHA512 0437a489fcb54458dbb33e0139385e577a89db0c07bd872e4e56780feb8033080d59c99aeff419f3c94b22be8fb41995674749123d15f7d578cc8b0a77d7783f
DIST psad-2.4.5.tar.bz2 1631602 BLAKE2B 83d5a6811743e56e86984e79f0176db7982243cefcbdef7bdc30300de6a3e2c1d5033e75ec5b7e68e89784b04c98a0ed6b9475a93f4e633ad96380facaf08c21 SHA512 6466cf3191092672557fb6c044c6126290f1d89aea37a20aad1b3eb148b5b8be5bc2cf3700938b91263d7403f776613f304bd491c24a7e16b0975b81f24481a0
+DIST psad-2.4.6.tar.bz2 2548405 BLAKE2B 7479ce4496343ca988da4dbe82190053385f1a8fa2e190002545c63f2e36283bc84293d932ebe147c9078923fa9e0527b4265fffdb8e1fd99bfc5d9955f9f3cd SHA512 a5de29b9ca0108aa8c6a325b725145f408dc517aeee4654596c7a037762f495a78827c64fc2e9c4284bc8db65caf0321982ecaf02de6d73784c2038e1078f42d
diff --git a/net-firewall/psad/psad-2.4.6.ebuild b/net-firewall/psad/psad-2.4.6.ebuild
new file mode 100644
index 000000000000..f4eea7be20fb
--- /dev/null
+++ b/net-firewall/psad/psad-2.4.6.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+#PERL_EXPORT_PHASE_FUNCTIONS=no
+inherit perl-module toolchain-funcs
+
+DESCRIPTION="Port Scanning Attack Detection daemon"
+SRC_URI="https://www.cipherdyne.org/psad/download/${P}.tar.bz2"
+HOMEPAGE="https://www.cipherdyne.org/psad/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="virtual/perl-ExtUtils-MakeMaker"
+RDEPEND="
+ dev-perl/Bit-Vector
+ dev-perl/Date-Calc
+ dev-perl/NetAddr-IP
+ dev-perl/Unix-Syslog
+ net-firewall/iptables
+ net-misc/whois
+ virtual/logger
+ virtual/mailx
+ virtual/perl-Storable
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2.4-var-run.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's|/usr/bin/gcc|$(CC)|g' \
+ -e 's|-O|$(CFLAGS) $(LDFLAGS)|g' \
+ Makefile || die
+ # Fix up default paths
+ sed -i \
+ -e "s:/usr/bin/whois_psad:/usr/bin/whois:g" \
+ psad.conf || die
+}
+
+src_configure() {
+ default
+
+ local deps_subdir
+ for deps_subdir in IPTables-Parse IPTables-ChainMgr; do
+ cd "${S}"/deps/${deps_subdir} || die
+ SRC_PREP="no" perl-module_src_configure
+ done
+}
+
+src_compile() {
+ tc-export CC
+ default
+
+ local deps_subdir
+ for deps_subdir in IPTables-Parse IPTables-ChainMgr; do
+ cd "${S}"/deps/${deps_subdir} || die
+ perl-module_src_compile
+ done
+}
+
+src_install() {
+ newbin misc/pscan psad-pscan
+
+ insinto /usr
+ dosbin kmsgsd psad psadwatchd
+ newsbin fwcheck_psad.pl fwcheck_psad
+
+ insinto /etc/psad
+ doins \
+ *.conf auto_dl icmp{,6}_types ip_options psad_* pf.os posf \
+ protocols signatures
+
+ newinitd init-scripts/psad-init.gentoo psad
+
+ doman doc/*.8
+
+ dodoc doc/BENCHMARK CREDITS Change* doc/FW_EXAMPLE_RULES README \
+ doc/README.SYSLOG doc/SCAN_LOG
+
+ insinto /etc/psad/snort_rules
+ doins deps/snort_rules/*
+
+ local deps_subdir
+ for deps_subdir in IPTables-Parse IPTables-ChainMgr; do
+ cd "${S}"/deps/${deps_subdir} || die
+ perl-module_src_install
+ done
+}