summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2022-05-21 09:39:20 -0400
committerBrian Evans <grknight@gentoo.org>2022-05-21 09:39:20 -0400
commit16b5b03885a6220bd72c987409d430ce94eeb396 (patch)
tree08d22f746182c85a98008f422052a5eabfaa4094
parentdev-util/imediff2: Expand python targets (diff)
downloadgentoo-16b5b03885a6220bd72c987409d430ce94eeb396.tar.gz
gentoo-16b5b03885a6220bd72c987409d430ce94eeb396.tar.bz2
gentoo-16b5b03885a6220bd72c987409d430ce94eeb396.zip
dev-util/imediff2: Drop old
Signed-off-by: Brian Evans <grknight@gentoo.org>
-rw-r--r--dev-util/imediff2/Manifest1
-rw-r--r--dev-util/imediff2/files/1.1.2-python-3.patch155
-rw-r--r--dev-util/imediff2/imediff2-1.1.2-r6.ebuild39
3 files changed, 0 insertions, 195 deletions
diff --git a/dev-util/imediff2/Manifest b/dev-util/imediff2/Manifest
index f550529bdba8..90751ecabb58 100644
--- a/dev-util/imediff2/Manifest
+++ b/dev-util/imediff2/Manifest
@@ -1,2 +1 @@
DIST imediff2_1.1.2.1.orig.tar.gz 20393 BLAKE2B 560eef8600bac8ad302907563bd8520ef7881009c8a35c74427d0d5d9e8d4303446f1eb39c01fec201c798f286023765776a84b1e1aaa9e2d585a45870375f16 SHA512 ad0e22f5f2f16efb976a0d6d16c34798cc8aace4251a99cb7764df6841f93c2a6bb9dc8cbb59d8f3ae5a5ad7c161a05b9c3c7b36cc7bdf98eac3ef3b735ef6c4
-DIST imediff2_1.1.2.orig.tar.gz 17974 BLAKE2B f83b6ab652b1dd044587e75e4e7551a8132e1860b14f0d85d37f35383bd161a672860162e93554cf4db844d6a4700fa1876a30874c50fcb8442b4190a9b19185 SHA512 54d196d67107283bc3339eba30acb1c60972f256a268e86da397e0bdafa05220facc7979638a6a917b0c2dc7171edc3aa6b188295c9f40e9debf87a63731e748
diff --git a/dev-util/imediff2/files/1.1.2-python-3.patch b/dev-util/imediff2/files/1.1.2-python-3.patch
deleted file mode 100644
index 811f41583129..000000000000
--- a/dev-util/imediff2/files/1.1.2-python-3.patch
+++ /dev/null
@@ -1,155 +0,0 @@
---- a/imediff2 2017-11-14 09:28:57.007929569 -0500
-+++ b/imediff2 2017-11-14 10:11:12.618496692 -0500
-@@ -18,20 +18,20 @@
- # License along with the program; if not, write to the Free Software
- # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
-
--VERSION = '1.1.1'
-+VERSION = '1.1.2'
- PACKAGE = 'imediff2'
-
--import curses.wrapper
-+import sys
-+if sys.version_info<(3,0,0):
-+ import curses.wrapper
- import curses
- import tempfile
- import gettext
- import difflib
- import getopt
--import string
- import types
- import time
- import pty
--import sys
- import os
- import errno
-
-@@ -121,19 +122,19 @@
- def read_lines( filename ):
- global assume_empty
- try:
-- fp = file( filename )
-+ fp = open( filename )
- l = fp.readlines()
- fp.close()
- return l
-- except IOError, (error, message):
-- if error == errno.ENOENT and assume_empty:
-+ except IOError as e:
-+ if e.errno == errno.ENOENT and assume_empty:
- return ""
- else:
-- sys.stderr.write(_("Could not read '%s': %s\n") % (filename, message))
-+ sys.stderr.write(_("Could not read '%s': %s\n") % (filename, e.strerror))
- sys.exit(3)
-
- def strip_end_lines( txt ):
-- return string.replace(string.replace(txt,"%c"%10,""),"%c"%13,"")
-+ return txt.replace("%c"%10,"").replace("%c"%13,"")
-
- def main(stdscr, lines_a, lines_b, start_mode):
- global sel, active_chunks, x,y, lines, textpad, contw,conth
-@@ -237,7 +238,7 @@
- active_chunks.append( [j, j+len(line_list), i] )
-
- for l in line_list:
-- lines.append( [string.expandtabs(strip_end_lines(l)),
-+ lines.append( [strip_end_lines(l).expandtabs(),
- decor, color_pair] )
- j+=1
-
-@@ -287,9 +287,9 @@
- def sel_next( dir ):
- global sel, active_chunks
- if dir == 'up':
-- rng = range(sel-1, -1, -1)
-+ rng = list(range(sel-1, -1, -1))
- else:
-- rng = range(sel+1, len(active_chunks))
-+ rng = list(range(sel+1, len(active_chunks)))
- for j in rng:
- if active_chunks[j][1] > y and active_chunks[j][0] < y+winh:
- sel = j
-@@ -442,7 +441,7 @@
- elif c == ord('h') or c == ord('?') or c == curses.KEY_HELP:
- helpw = 0
- helph = 0
-- for l in string.split(helptext(), "%c"%10):
-+ for l in helptext().split("%c"%10):
- helpw = max(helpw, len(l))
- helph += 1
- helppad = curses.newpad(helph+2, helpw+2)
-@@ -512,21 +513,21 @@
- try:
- opts, args = getopt.getopt(sys.argv[1:], "hmuo:abcNV",
- ["help","mono","unresolved","output=", "version", "new-file"])
--except getopt.GetoptError, e:
-- print _("Error: ") + str(e)
-- print usagetext()
-+except getopt.GetoptError as e:
-+ print((_("Error: ") + str(e)))
-+ print((usagetext()))
- sys.exit(2)
-
- for o, a in opts:
- if o in ("-h", "--help"):
-- print usagetext()
-+ print((usagetext()))
- sys.exit()
- elif o in ("-V", "--version"):
-- print "%s %s" % (PACKAGE, VERSION)
-+ print(("%s %s" % (PACKAGE, VERSION)))
- sys.exit()
-
- if len(args)<2:
-- print usagetext()
-+ print((usagetext()))
- sys.exit(2)
-
- for o, a in opts:
-@@ -592,15 +592,15 @@
- if launch_editor:
- assert( not editor is None )
- try:
- (of, of_name) = tempfile.mkstemp(prefix='imediff2')
-- os.write( of, output )
-+ os.write( of, output.encode() )
- os.close(of)
- time.sleep(0.1) # make the change visible - many editor look a lot like imediff2
- editor_ret = os.system('%s %s' % (editor, of_name))
- time.sleep(0.1)
- if editor_ret == 0:
- new_b_lines = read_lines(of_name)
-- if string.join(new_b_lines, '') == output:
-+ if ''.join(new_b_lines) == output:
- chunk_mode = 'old'
- elif new_b_lines != lines_a:
- lines_b = new_b_lines
-@@ -607,8 +608,8 @@
- else:
- chunks = 'old'
- os.unlink(of_name)
-- except IOError, (error, message):
-- sys.stderr.write(_("Could not write to '%s': %s\n") % (of_name, message));
-+ except IOError as e:
-+ sys.stderr.write(_("Could not write to '%s': %s\n") % (of_name, e.strerror));
-
- if not launch_editor:
- break
-@@ -619,11 +620,11 @@
- else:
- try:
- if ofile is not None:
-- of = file(ofile, 'wb')
-+ of = open(ofile, 'wb')
-- of.write( output )
-+ of.write( output.encode() )
- of.close()
- sys.exit(0)
-- except IOError, (error, message):
-- sys.stderr.write(_("Could not write to '%s': %s\n") % (ofile, message));
-+ except IOError as e:
-+ sys.stderr.write(_("Could not write to '%s': %s\n") % (ofile, e.strerror));
-
- sys.exit(3)
diff --git a/dev-util/imediff2/imediff2-1.1.2-r6.ebuild b/dev-util/imediff2/imediff2-1.1.2-r6.ebuild
deleted file mode 100644
index 29db21793666..000000000000
--- a/dev-util/imediff2/imediff2-1.1.2-r6.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8} )
-PYTHON_REQ_USE="ncurses"
-
-inherit python-single-r1
-
-MY_P="${PN}_$(ver_rs 3 -)"
-
-DESCRIPTION="An interactive, user friendly 2-way merge tool in text mode"
-HOMEPAGE="https://elonen.iki.fi/code/imediff/"
-SRC_URI="mirror://debian/pool/main/i/${PN}/${MY_P}.orig.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm x86"
-IUSE=""
-
-DEPEND="${PYTHON_DEPS}"
-RDEPEND="${DEPEND}"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-S="${WORKDIR}/${PN}"
-
-PATCHES=( "${FILESDIR}/${PV}-python-3.patch" )
-
-src_compile() {
- # Otherwise the docs get regenerated :)
- :
-}
-
-src_install() {
- python_doscript imediff2
- dodoc AUTHORS README
- doman imediff2.1
-}