summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2019-03-24 00:46:52 +0100
committerPacho Ramos <pacho@gentoo.org>2019-03-24 00:47:14 +0100
commit1771255042e50ebd4d6105ea8e78284404938fa0 (patch)
tree30b6f00882c6a99fec2831057e9fd756f06e5a95
parentmedia-gfx/duhdraw: Fixed build with sys-libs/ncurses[tinfo] (diff)
downloadgentoo-1771255042e50ebd4d6105ea8e78284404938fa0.tar.gz
gentoo-1771255042e50ebd4d6105ea8e78284404938fa0.tar.bz2
gentoo-1771255042e50ebd4d6105ea8e78284404938fa0.zip
app-admin/gnome-abrt: Bump to 1.2.7
Also allow to build for multiple python versions, this allows to be able to switch system python version and keep it working too. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--app-admin/gnome-abrt/Manifest1
-rw-r--r--app-admin/gnome-abrt/gnome-abrt-1.2.7.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/app-admin/gnome-abrt/Manifest b/app-admin/gnome-abrt/Manifest
index 571b8de43dc1..d7391cac2c65 100644
--- a/app-admin/gnome-abrt/Manifest
+++ b/app-admin/gnome-abrt/Manifest
@@ -1 +1,2 @@
DIST gnome-abrt-1.2.6.tar.gz 340308 BLAKE2B 5221fe43fd72fe8798f2c11275863e6936e616632641448c53dd24118d3b6b808fc373fe98b8775f1f1c58820c06195a665f6d417c95eaa7cc333cd7660b2d0b SHA512 12bcdeefa481b7caa04da046ee11d6adc9fd582b32f709d79a2d94cf61ca02643edd418cd9257c0f732a30aa5714fe83a282a4c794ff4260ddad038f7721ff2c
+DIST gnome-abrt-1.2.7.tar.gz 339961 BLAKE2B cdacc079c4661c364f13af3102e2231adbeaf4226ba937436f5ce3ae109f28b87c9424c6dfbc016b912599205386f92c32b036ca31adbea79b9a54d7f3a27c4a SHA512 57446b1c1c312f3a47ea3dd2a40ac1d4ec5392df3181eac73086675b65d45cad9a01fba5252d073970878ef97d7d272508bc5b86a56779543ffdc8d083fb5413
diff --git a/app-admin/gnome-abrt/gnome-abrt-1.2.7.ebuild b/app-admin/gnome-abrt/gnome-abrt-1.2.7.ebuild
new file mode 100644
index 000000000000..a0fb1a7815e3
--- /dev/null
+++ b/app-admin/gnome-abrt/gnome-abrt-1.2.7.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+
+inherit autotools python-r1
+
+DESCRIPTION="A utility for viewing problems that have occurred with the system"
+HOMEPAGE="https://github.com/abrt/gnome-abrt"
+SRC_URI="https://github.com/abrt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=x11-libs/gtk+-3.10.0:3
+ >=dev-libs/libreport-2.0.20[python,${PYTHON_USEDEP}]
+ >=app-admin/abrt-2.10.10-r1
+ >=dev-python/pygobject-3.29.1:3[${PYTHON_USEDEP}]
+ x11-libs/libX11
+ >=dev-python/pyxdg-0.19[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/asciidoc
+ app-text/xmlto
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.17
+"
+
+src_prepare() {
+ default
+ ./gen-version > gnome-abrt-version || die
+ eautoreconf
+ python_copy_sources
+}
+
+src_configure() {
+ myeconfargs=(
+ --localstatedir="${EPREFIX}/var"
+ --with-nopylint
+ )
+
+ python_foreach_impl run_in_build_dir econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ python_foreach_impl run_in_build_dir default
+ find "${D}" -name '*.la' -type f -delete || die
+}