summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-12-22 22:58:56 +0200
committerDavid Seifert <soap@gentoo.org>2016-12-23 00:32:51 +0200
commit1842a17a0dacbcf414630b07b2e9a79bca455ddb (patch)
tree53903e638daccb9ac06ddb7f63a566357add138f
parentdev-java/jsr173: EAPI 6 bump and ebuild clean up. (diff)
downloadgentoo-1842a17a0dacbcf414630b07b2e9a79bca455ddb.tar.gz
gentoo-1842a17a0dacbcf414630b07b2e9a79bca455ddb.tar.bz2
gentoo-1842a17a0dacbcf414630b07b2e9a79bca455ddb.zip
sci-mathematics/octave: Fix QScintilla detection for Qt5
Gentoo-bug: 600482 * Also bring back USE=gui flag Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--sci-mathematics/octave/files/octave-4.2.0-fix-qscintilla-detection.patch14
-rw-r--r--sci-mathematics/octave/octave-4.2.0-r2.ebuild (renamed from sci-mathematics/octave/octave-4.2.0-r1.ebuild)9
2 files changed, 19 insertions, 4 deletions
diff --git a/sci-mathematics/octave/files/octave-4.2.0-fix-qscintilla-detection.patch b/sci-mathematics/octave/files/octave-4.2.0-fix-qscintilla-detection.patch
new file mode 100644
index 000000000000..9d18b6a6d7ce
--- /dev/null
+++ b/sci-mathematics/octave/files/octave-4.2.0-fix-qscintilla-detection.patch
@@ -0,0 +1,14 @@
+In Gentoo, QScintilla for Qt5 has the same library name
+as its Qt4 variant.
+
+--- a/m4/acinclude.m4
++++ b/m4/acinclude.m4
+@@ -1327,7 +1327,7 @@
+ ;;
+ 5)
+ QT_MODULES="Qt5Core Qt5Gui Qt5Network Qt5OpenGL Qt5PrintSupport"
+- octave_qscintilla_libnames="qscintilla2-qt5 qt5scintilla2"
++ octave_qscintilla_libnames=qscintilla2
+ ;;
+ *)
+ AC_MSG_ERROR([Unrecognized Qt version $qt_version])
diff --git a/sci-mathematics/octave/octave-4.2.0-r1.ebuild b/sci-mathematics/octave/octave-4.2.0-r2.ebuild
index 331bf0472a42..c2a64e23866a 100644
--- a/sci-mathematics/octave/octave-4.2.0-r1.ebuild
+++ b/sci-mathematics/octave/octave-4.2.0-r2.ebuild
@@ -12,8 +12,8 @@ HOMEPAGE="http://www.octave.org/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
SLOT="0/${PV}"
-IUSE="curl doc fftw +glpk gnuplot graphicsmagick hdf5 +imagemagick java opengl openssl
- portaudio postscript +qhull +qrupdate qt5 readline sndfile +sparse static-libs X zlib"
+IUSE="curl doc fftw +glpk gnuplot graphicsmagick gui hdf5 +imagemagick java opengl openssl
+ portaudio postscript +qhull +qrupdate readline sndfile +sparse static-libs X zlib"
REQUIRED_USE="?? ( graphicsmagick imagemagick )"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
@@ -47,7 +47,7 @@ RDEPEND="
media-gfx/transfig )
qhull? ( media-libs/qhull:0= )
qrupdate? ( sci-libs/qrupdate:0= )
- qt5? (
+ gui? (
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5
@@ -85,6 +85,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-4.2.0-pkgbuilddir.patch
"${FILESDIR}"/${PN}-4.2.0-ncurses-pkgconfig.patch
"${FILESDIR}"/${PN}-4.2.0-zlib-underlinking.patch
+ "${FILESDIR}"/${PN}-4.2.0-fix-qscintilla-detection.patch
)
src_prepare() {
@@ -143,7 +144,7 @@ src_configure() {
$(use_with portaudio) \
$(use_with qhull) \
$(use_with qrupdate) \
- $(use_with qt5 qt 5) \
+ $(use_with gui qt 5) \
$(use_with sndfile) \
$(use_with sparse arpack) \
$(use_with sparse umfpack) \