summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2024-07-19 20:12:17 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-07-20 14:20:00 +0300
commit1863e724158bd3a0ae44c12e3a68878aec365d38 (patch)
tree8d21b74a9bb57249188dd277dbbf1173d78a056a
parentnet-irc/ii: Stabilize 2.0 amd64, #936380 (diff)
downloadgentoo-1863e724158bd3a0ae44c12e3a68878aec365d38.tar.gz
gentoo-1863e724158bd3a0ae44c12e3a68878aec365d38.tar.bz2
gentoo-1863e724158bd3a0ae44c12e3a68878aec365d38.zip
media-libs/faun: add 0.1.4
Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--media-libs/faun/Manifest1
-rw-r--r--media-libs/faun/faun-0.1.4.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/media-libs/faun/Manifest b/media-libs/faun/Manifest
index ecbc4e4e6cab..db216d37a6b2 100644
--- a/media-libs/faun/Manifest
+++ b/media-libs/faun/Manifest
@@ -1 +1,2 @@
DIST faun-0.1.2.tar.gz 107751 BLAKE2B 5c8655aad59dfb8292f098af7f90d13e25c8df0d9cf7b3d2d5a0d7c94e68389c898e8d66abb67cb93ef70a4e4d81d63aca9e60afe48afcd4e96ef7371b6611e0 SHA512 b0ec4b7fccc4f17e1f37ed87c45b41f75faa42393143313264d77a117dbc76b37f9418886f425cf06d8baeebfe1269bcdabbe16aead634177021bc50ba1c5260
+DIST faun-0.1.4.tar.gz 110154 BLAKE2B a41e33282442a1b2999c7cc46fc6978607b6d6f2e6d8d7e92dd43386f2ff2ac61aa3c86e0219ffded8a35224c366a85cd7ab1c36a128eb746457be9fdea76c8e SHA512 4449c478109dd78933e346e87228639d0c5fcc33466a60a9649756cb69b087b82a7e0aa21591b4b2e8046858ac6ac9fc7cc43d84eb2e64624b49af8445dcda21
diff --git a/media-libs/faun/faun-0.1.4.ebuild b/media-libs/faun/faun-0.1.4.ebuild
new file mode 100644
index 000000000000..a5b0eb2e7089
--- /dev/null
+++ b/media-libs/faun/faun-0.1.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo toolchain-funcs
+
+DESCRIPTION="A high-level C audio library"
+HOMEPAGE="https://wickedsmoke.github.io/faun/"
+SRC_URI="https://github.com/WickedSmoke/faun/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# based on COPYING file
+LICENSE="MIT flac? ( GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="flac"
+
+DEPEND="
+ media-libs/libpulse
+ media-libs/libvorbis
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.1.2_makefile.patch"
+)
+
+src_configure() {
+ tc-export CC
+ # custom configure
+ edo ./configure $(usex !flac --no_flac "")
+}
+
+src_install() {
+ emake DESTDIR="${D}/usr" install
+ dodoc README.md
+}