summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-03-18 19:09:58 +0100
committerUlrich Müller <ulm@gentoo.org>2019-03-18 19:11:38 +0100
commit187ed6563f0116aea83531f9a29886ffd5d077e4 (patch)
treea251b7357b9978d4bfae05785939920e85d6887f
parentdev-db/qt5-sqlcipher: New snapshot, supports Qt 5.12. (diff)
downloadgentoo-187ed6563f0116aea83531f9a29886ffd5d077e4.tar.gz
gentoo-187ed6563f0116aea83531f9a29886ffd5d077e4.tar.bz2
gentoo-187ed6563f0116aea83531f9a29886ffd5d077e4.zip
net-im/openmittsu: Version bump.
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--net-im/openmittsu/Manifest1
-rw-r--r--net-im/openmittsu/files/openmittsu-0.9.13.32-fix-tests.patch11
-rw-r--r--net-im/openmittsu/openmittsu-0.9.13.32.ebuild62
3 files changed, 74 insertions, 0 deletions
diff --git a/net-im/openmittsu/Manifest b/net-im/openmittsu/Manifest
index a7d34aafaa5f..b2ec10b9ce71 100644
--- a/net-im/openmittsu/Manifest
+++ b/net-im/openmittsu/Manifest
@@ -1,2 +1,3 @@
DIST openmittsu-0.9.11.0.tar.xz 1408088 BLAKE2B 6c16ea2c35c0a4e02b2735d292516e22c238ca6d3f32f2869be8fec265f099761a5afef0303b2bd84c8f2e5383d7fff6dd18b2e57fc0d12da30a8d8a1637242b SHA512 534a589aa7bf4aa1be4e7d887ef1d4b025eeb1f82d8503cb048a7802ad4380c78224acae4a5f41a56be838a5a43af78f496bd0336034232208bc4de49a71b4d5
+DIST openmittsu-0.9.13.32.tar.xz 2078892 BLAKE2B 4960d3046dfe45568f56ddc4ad77677992ac4dc4d618a926a15b35431955c8f30aa20ad236cc3143bc1a24f64a4635fdc072a1c9f921238f1283b81b3d6befb7 SHA512 671ce8ed1a6f9aa8d15ee0d72ce78e2b5aef556243efacec4b0b434eaf5b0bd1b34aa6a0391e42ead9007011cca88e7ba2649f16456a2bf74d22355d1f308a0f
DIST openmittsu-0.9.9.48.tar.xz 2026628 BLAKE2B eafd2bc537a22b140e01e14da363d3943e24b86754a090fd1ed2ac80f1030e1a2fb30ee8a5395c6c9a143d5922354ac67e3376a94c34f670f8cbcfddc27da112 SHA512 e24ec8e0792df13e781080fe42934035f74b82be62a8ce4913175a13ee3acbead069d169871405f4312927165a7049291d009c7f968b088bdbb3e294f9ef2443
diff --git a/net-im/openmittsu/files/openmittsu-0.9.13.32-fix-tests.patch b/net-im/openmittsu/files/openmittsu-0.9.13.32-fix-tests.patch
new file mode 100644
index 000000000000..c89d24536ae9
--- /dev/null
+++ b/net-im/openmittsu/files/openmittsu-0.9.13.32-fix-tests.patch
@@ -0,0 +1,11 @@
+--- openmittsu-0.9.13.32-orig/CMakeLists.txt
++++ openmittsu-0.9.13.32/CMakeLists.txt
+@@ -570,7 +570,7 @@
+ target_link_libraries(openMittsu openMittsuCore Qt5::Core Qt5::Gui Qt5::Widgets Qt5::Network Qt5::Multimedia Qt5::MultimediaWidgets Qt5::Sql)
+ target_link_libraries(openMittsuVersionInfo Qt5::Core)
+ if (OPENMITTSU_ENABLE_TESTS)
+- target_link_libraries(openMittsuTests openMittsuCore Qt5::Core Qt5::Network Qt5::Multimedia Qt5::MultimediaWidgets Qt5::Sql gmock gtest)
++ target_link_libraries(openMittsuTests openMittsuCore Qt5::Core Qt5::Network Qt5::Multimedia Qt5::MultimediaWidgets Qt5::Sql gmock gtest pthread)
+ endif (OPENMITTSU_ENABLE_TESTS)
+
+ # Link against libc++abi if requested.
diff --git a/net-im/openmittsu/openmittsu-0.9.13.32.ebuild b/net-im/openmittsu/openmittsu-0.9.13.32.ebuild
new file mode 100644
index 000000000000..5c132dd83ec7
--- /dev/null
+++ b/net-im/openmittsu/openmittsu-0.9.13.32.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils desktop
+
+DESCRIPTION="An open source chat client for Threema-style end-to-end encrypted chat networks"
+HOMEPAGE="https://www.openmittsu.de/"
+# git-archive-all.sh snapshot of https://github.com/blizzard4591/openMittsu.git
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2+ BitstreamVera OFL-1.1 Apache-2.0 CC0-1.0 MIT BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-db/qt5-sqlcipher
+ >=dev-libs/libsodium-1.0.11:=
+ >=dev-qt/qtcore-5.7.1:5=
+ >=dev-qt/qtgui-5.7.1:5=
+ >=dev-qt/qtmultimedia-5.7.1:5=
+ >=dev-qt/qtnetwork-5.7.1:5=[ssl]
+ >=dev-qt/qtsql-5.7.1:5=[sqlite]
+ >=dev-qt/qtwidgets-5.7.1:5=
+ >=media-gfx/qrencode-3.4.4-r1:="
+DEPEND="${RDEPEND}
+ test? ( >=dev-cpp/gtest-1.8.0 )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-tests.patch
+)
+
+DOCS=(
+ README.md
+ Example-client-configuration-file.ini
+ Example-contacts-file.txt
+)
+
+src_configure() {
+ local mycmakeargs=(
+ # set version manually, since autodetection works only with git
+ "-DOPENMITTSU_CUSTOM_VERSION_STRING=${PV%.*}-${PV##*.}-00000000"
+ "-DOPENMITTSU_DISABLE_VERSION_UPDATE_CHECK=ON"
+ "-DOPENMITTSU_ENABLE_TESTS=$(usex test)"
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ cd "${BUILD_DIR}" || die
+ ./openMittsuTests || die
+}
+
+src_install() {
+ local my_pn="openMittsu"
+ cmake-utils_src_install
+ newicon resources/icon.png ${my_pn}.png
+ make_desktop_entry ${my_pn} ${my_pn} ${my_pn}
+ rm "${ED}"/usr/bin/${my_pn}VersionInfo || die
+ rm -f "${ED}"/usr/bin/${my_pn}Tests || die
+}