summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2022-09-25 20:52:56 -0400
committerAnthony G. Basile <blueness@gentoo.org>2022-09-25 20:53:20 -0400
commit18be51c7f17c65b4404af4832ba910456bdbb9b4 (patch)
tree70cbf20edac721bc1e85a60be3c161c3db018deb
parentdev-python/pydantic: Stabilize 1.10.1 arm64, #872893 (diff)
downloadgentoo-18be51c7f17c65b4404af4832ba910456bdbb9b4.tar.gz
gentoo-18be51c7f17c65b4404af4832ba910456bdbb9b4.tar.bz2
gentoo-18be51c7f17c65b4404af4832ba910456bdbb9b4.zip
dev-libs/xapian: version bump 1.4.21
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
-rw-r--r--dev-libs/xapian/Manifest1
-rw-r--r--dev-libs/xapian/xapian-1.4.21.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-libs/xapian/Manifest b/dev-libs/xapian/Manifest
index 65047553d905..0f9014cd8f3f 100644
--- a/dev-libs/xapian/Manifest
+++ b/dev-libs/xapian/Manifest
@@ -3,3 +3,4 @@ DIST xapian-core-1.4.17.tar.xz 2997700 BLAKE2B 882bc28c9a55731212a5c3ac6da3ad208
DIST xapian-core-1.4.18.tar.xz 2984508 BLAKE2B e5d680578e0a4605a8e99470921fba29cdd3d137d017608b8bf571951726055d2a1d49e9649829f0df92af3d27d0565f90baaca5a4eb5c67cb368f5d1e592d28 SHA512 ba6240054c0d2f92b9f1059aa934cdf35388ee7c7e05f4ef6f9856bdaed8ad821095a348ed9a892afdf18c3c0ad20e163028ad0ed3a9934bd69b861e814678ef
DIST xapian-core-1.4.19.tar.xz 2994860 BLAKE2B 9566df1646192370e346c1b0d1e1cda68034fe5d3ab94835709f969df643fd36da49a58a2d3b4177a42faf5af2e71df771277848169ae62f94fe0bb0378ba6aa SHA512 d596058d7f9bfa0b73c5b6354331a799936b45f27012894f6792872ade8656bb0387b504aea8c1c3edfbd48787190452e7a49d2b62d181cb050c46edd3e67346
DIST xapian-core-1.4.20.tar.xz 3003788 BLAKE2B c4bfa4af9112a206b14c8c2f4a76eb4c1267a752130287b6623233d3a09783b903a3275b2ec275f38f1d195119c730565a31ed303b8e2dedefc42cae10387600 SHA512 e2f62eebc946cc5d0641db85d2966e6ad9e84c6a23606e705f0461ab80b012933b46ed5b7e0691fe2070ca1c0755e99895c18bc055eaad0a9376def410aa7f35
+DIST xapian-core-1.4.21.tar.xz 3018384 BLAKE2B 61a25ee381c84e0a9f20650d94aa097225f2e947dafad7f6b5497db74f383f5b0fcf277a35ea27ff461b34cd2a9a0b6333f88264c5817cff09a2caf42fa3b398 SHA512 4071791daf47f5ae77f32f358c6020fcfa9aa81c15c8da25489b055eef30383695e449ab1cb73670f2f5db2b2a5f78056da0e8eea89d83aaad91dfe340a6b13a
diff --git a/dev-libs/xapian/xapian-1.4.21.ebuild b/dev-libs/xapian/xapian-1.4.21.ebuild
new file mode 100644
index 000000000000..d50c34543512
--- /dev/null
+++ b/dev-libs/xapian/xapian-1.4.21.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit multilib-minimal
+
+MY_P="${PN}-core-${PV}"
+
+DESCRIPTION="Xapian Probabilistic Information Retrieval library"
+HOMEPAGE="https://www.xapian.org/"
+SRC_URI="https://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/30" # ABI version of libxapian.so
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos ~x64-solaris"
+IUSE="doc static-libs cpu_flags_x86_sse cpu_flags_x86_sse2 +inmemory +remote"
+
+DEPEND="sys-apps/util-linux[${MULTILIB_USEDEP}]
+ sys-libs/zlib[${MULTILIB_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+multilib_src_configure() {
+ local myconf=""
+
+ if use cpu_flags_x86_sse2; then
+ myconf="${myconf} --enable-sse=sse2"
+ else
+ if use cpu_flags_x86_sse; then
+ myconf="${myconf} --enable-sse=sse"
+ else
+ myconf="${myconf} --disable-sse"
+ fi
+ fi
+
+ myconf="${myconf} $(use_enable static-libs static)"
+
+ use inmemory || myconf="${myconf} --disable-backend-inmemory"
+ use remote || myconf="${myconf} --disable-backend-remote"
+
+ myconf="${myconf} --enable-backend-glass --enable-backend-chert --program-suffix="
+
+ ECONF_SOURCE=${S} econf ${myconf}
+}
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/xapian/postingsource.h
+ /usr/include/xapian/attributes.h
+ /usr/include/xapian/valuesetmatchdecider.h
+ /usr/include/xapian/version.h
+ /usr/include/xapian/version.h
+ /usr/include/xapian/types.h
+ /usr/include/xapian/positioniterator.h
+ /usr/include/xapian/registry.h
+)
+
+multilib_src_test() {
+ emake check VALGRIND=
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ if use doc; then
+ rm -rf "${ED}/usr/share/doc/xapian-core-${PV}" || die
+ fi
+
+ dodoc AUTHORS HACKING PLATFORMS README NEWS
+
+ find "${ED}" -name "*.la" -type f -delete || die
+}