summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-04 14:27:24 +0100
committerSam James <sam@gentoo.org>2022-10-04 14:27:24 +0100
commit1945185042eded6a591548dc15c944d3085bcd66 (patch)
treef5483af7ae6c2e5ee2d4a41180ab347f97b2cf72
parentapp-editors/gvim: fix Lua 5.1 deprecated API implicit. func. decls (diff)
downloadgentoo-1945185042eded6a591548dc15c944d3085bcd66.tar.gz
gentoo-1945185042eded6a591548dc15c944d3085bcd66.tar.bz2
gentoo-1945185042eded6a591548dc15c944d3085bcd66.zip
app-editors/vim-core: sync live
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-editors/vim-core/vim-core-9999.ebuild7
1 files changed, 2 insertions, 5 deletions
diff --git a/app-editors/vim-core/vim-core-9999.ebuild b/app-editors/vim-core/vim-core-9999.ebuild
index f55b9057046f..d3d76cb7a879 100644
--- a/app-editors/vim-core/vim-core-9999.ebuild
+++ b/app-editors/vim-core/vim-core-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=8
# Please bump with app-editors/vim and app-editors/gvim
VIM_VERSION="9.0"
-inherit vim-doc flag-o-matic bash-completion-r1 prefix desktop xdg-utils
+inherit bash-completion-r1 desktop flag-o-matic prefix toolchain-funcs vim-doc xdg-utils
if [[ ${PV} == 9999* ]] ; then
inherit git-r3
@@ -29,9 +29,6 @@ IUSE="nls acl minimal"
# ncurses is only needed by ./configure, so no subslot operator required
DEPEND=">=sys-libs/ncurses-5.2-r2:0"
BDEPEND="sys-devel/autoconf"
-# Avoid icon file collision, bug #673880
-RDEPEND="!<app-editors/vim-8.2.4328-r1"
-PDEPEND="!minimal? ( app-vim/gentoo-syntax )"
pkg_setup() {
# people with broken alphabets run into trouble. bug #82186.
@@ -42,7 +39,7 @@ pkg_setup() {
src_prepare() {
if [[ ${PV} != 9999* ]] ; then
# Gentoo patches to fix runtime issues, cross-compile errors, etc
- eapply "${WORKDIR}/vim-patches-vim-9.0.0049-patches"
+ eapply "${WORKDIR}"/vim-patches-vim-9.0.0049-patches
fi
# Fixup a script to use awk instead of nawk