summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-03 21:33:42 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-03 21:52:57 +0100
commit1999d620e1da1a4bb54cda77217c09713ed3a87b (patch)
tree0327c602c72132986a884d678829b8b9aac4d465
parentdev-python/soupsieve: Bump to 2.3 (diff)
downloadgentoo-1999d620e1da1a4bb54cda77217c09713ed3a87b.tar.gz
gentoo-1999d620e1da1a4bb54cda77217c09713ed3a87b.tar.bz2
gentoo-1999d620e1da1a4bb54cda77217c09713ed3a87b.zip
dev-python/twine: Bump to 3.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/twine/Manifest1
-rw-r--r--dev-python/twine/twine-3.5.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/twine/Manifest b/dev-python/twine/Manifest
index 63d09da5cd7c..2aa0cbe7a0cf 100644
--- a/dev-python/twine/Manifest
+++ b/dev-python/twine/Manifest
@@ -1 +1,2 @@
DIST twine-3.4.2.tar.gz 212266 BLAKE2B 602bb72f4be1c0d28341fb3378a5d55737c14555495640ae3414a1c8e7ca0c06b2c2ce3c358130251c02f0a51b61eb362a1e999c3945d4d1d7afd7bcd4d17807 SHA512 3f6d8992294a35e2a26be64f56c88d31af63b05f3f477d545bc82d928ca1b9939d23fa489eca5232502a49def77d489eaf6a29663d150f78b5cdb99749ff9b50
+DIST twine-3.5.0.tar.gz 211946 BLAKE2B 7ec2eb88a4496f7e750927c83b2e6d6ed39a08bb1775cda8df555ee6ce5244d721e8aaf2d983f983219b9445f56e2a830979a5e5e6165ab7e6ec12b2a0602842 SHA512 37219c1078bb7209123aee79c2d2bd73390c8ce4ab2bf6b5493a54e4ccb9c714a6422ee4a782b3c19d3a5344c1431285c666230729f44615b7761c7a5aff07d6
diff --git a/dev-python/twine/twine-3.5.0.ebuild b/dev-python/twine/twine-3.5.0.ebuild
new file mode 100644
index 000000000000..97a82eff44d7
--- /dev/null
+++ b/dev-python/twine/twine-3.5.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Collection of utilities for publishing packages on PyPI"
+HOMEPAGE="https://twine.readthedocs.io/ https://github.com/pypa/twine https://pypi.org/project/twine/"
+SRC_URI="https://github.com/pypa/twine/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/colorama-0.4.3[${PYTHON_USEDEP}]
+ >=dev-python/importlib_metadata-3.6[${PYTHON_USEDEP}]
+ >=dev-python/keyring-15.1[${PYTHON_USEDEP}]
+ >=dev-python/pkginfo-1.4.2[${PYTHON_USEDEP}]
+ >=dev-python/readme_renderer-21.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/rfc3986-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/tqdm-4.14[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/jaraco-envs[${PYTHON_USEDEP}]
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+ dev-python/munch[${PYTHON_USEDEP}]
+ dev-python/portend[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pypiserver[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare_all() {
+ # requires internet
+ rm -f tests/test_integration.py || die
+ # pytest-socket dep relevant only to test_integration, and upstream
+ # disables it anyway
+ sed -i -e '/--disable-socket/d' pytest.ini || die
+ sed -i -e '/--cov/d' pytest.ini || die
+
+ distutils-r1_python_prepare_all
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}