summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-14 06:39:19 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-14 08:05:10 +0200
commit19cf65ca4239e7eeeedd1a2b13373aceb4e9fb78 (patch)
tree4884c5525b07a61c9be601a7025266ad52ddc374
parentdev-python/tox: Bump to 4.18.0 (diff)
downloadgentoo-19cf65ca4239e7eeeedd1a2b13373aceb4e9fb78.tar.gz
gentoo-19cf65ca4239e7eeeedd1a2b13373aceb4e9fb78.tar.bz2
gentoo-19cf65ca4239e7eeeedd1a2b13373aceb4e9fb78.zip
dev-python/pdm: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pdm/Manifest1
-rw-r--r--dev-python/pdm/pdm-2.17.1.ebuild119
2 files changed, 0 insertions, 120 deletions
diff --git a/dev-python/pdm/Manifest b/dev-python/pdm/Manifest
index 3b77b4ff533c..b9046821496e 100644
--- a/dev-python/pdm/Manifest
+++ b/dev-python/pdm/Manifest
@@ -1,2 +1 @@
-DIST pdm-2.17.1.tar.gz 2626200 BLAKE2B f0ab4586fe6af126398081a13bca007ea5fa7e4e2cd7bc99e415fa4fc56fa8cce7ea9028a18ce0e71ec966951ba12f678a000dbd3fe88c6a43b117f737e830dd SHA512 8be1ae474d00b0398f3b3bbf03e5cbe050911d18fa18ef3d7fe46116b6daa68a0e8b68cff90c2742803b167f10a66a66b1b68b84d43f39c3f006c96f38dfedb9
DIST pdm-2.17.2.tar.gz 2627131 BLAKE2B dba6435dd4995311a3bac4b23c35a3ee89cf8756b5e6fa443c6718b94880199fa20fbb89255b9523169171ccc1a87dc94593834e063b329ada299ff1727d882b SHA512 5230ed6303b24dbe75fe9c2021e78d1c2bbbd2fca95717399935ad4f07f227f5effbd6270310d6085fdf5cd656dfb26de7a4ca7fa34bbae0c757fb7d31978d2c
diff --git a/dev-python/pdm/pdm-2.17.1.ebuild b/dev-python/pdm/pdm-2.17.1.ebuild
deleted file mode 100644
index a12e4a8e60f4..000000000000
--- a/dev-python/pdm/pdm-2.17.1.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 2023-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=pdm-backend
-PYTHON_COMPAT=( python3_{10..13} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Python package and dependency manager supporting the latest PEP standards"
-HOMEPAGE="
- https://pdm-project.org/
- https://github.com/pdm-project/pdm/
- https://pypi.org/project/pdm/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-
-RDEPEND="
- dev-python/blinker[${PYTHON_USEDEP}]
- >=dev-python/dep-logic-0.4.3[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/platformdirs[${PYTHON_USEDEP}]
- dev-python/rich[${PYTHON_USEDEP}]
- dev-python/truststore[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
- dev-python/msgpack[${PYTHON_USEDEP}]
- dev-python/httpx[${PYTHON_USEDEP}]
- dev-python/filelock[${PYTHON_USEDEP}]
- dev-python/hishel[${PYTHON_USEDEP}]
- >=dev-python/pbs-installer-2024.4.18[${PYTHON_USEDEP}]
- dev-python/pyproject-hooks[${PYTHON_USEDEP}]
- >=dev-python/unearth-0.16.0[${PYTHON_USEDEP}]
- <dev-python/findpython-1[${PYTHON_USEDEP}]
- >=dev-python/findpython-0.6.0[${PYTHON_USEDEP}]
- dev-python/tomlkit[${PYTHON_USEDEP}]
- dev-python/shellingham[${PYTHON_USEDEP}]
- dev-python/python-dotenv[${PYTHON_USEDEP}]
- >=dev-python/resolvelib-1.0.1[${PYTHON_USEDEP}]
- dev-python/installer[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/tomli[${PYTHON_USEDEP}]
- ' 3.10)
-"
-BDEPEND="
- ${RDEPEND}
- test? (
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/pytest-httpserver[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # Internet
- 'tests/cli/test_build.py::test_build_with_no_isolation[False]'
- tests/test_project.py::test_access_index_with_auth
- "tests/test_project.py::test_find_interpreters_with_PDM_IGNORE_ACTIVE_VENV[True]"
- tests/cli/test_others.py::test_build_distributions
- 'tests/models/test_candidates.py::test_expand_project_root_in_url[demo @ file:///${PROJECT_ROOT}/tests/fixtures/artifacts/demo-0.0.1.tar.gz]'
- 'tests/models/test_candidates.py::test_expand_project_root_in_url[-e file:///${PROJECT_ROOT}/tests/fixtures/projects/demo-#-with-hash#egg=demo]'
- tests/models/test_candidates.py::test_find_candidates_from_find_links
- tests/cli/test_build.py::test_build_single_module
- tests/cli/test_build.py::test_build_single_module_with_readme
- tests/cli/test_build.py::test_build_package
- tests/cli/test_build.py::test_build_src_package
- tests/cli/test_build.py::test_build_package_include
- tests/cli/test_build.py::test_build_src_package_by_include
- tests/cli/test_build.py::test_build_with_config_settings
- tests/cli/test_build.py::test_cli_build_with_config_settings
- tests/cli/test_build.py::test_build_ignoring_pip_environment
- tests/cli/test_others.py::test_show_self_package
- tests/cli/test_publish.py::test_publish_and_build_in_one_run
- "tests/cli/test_hooks.py::test_hooks[build]"
- "tests/cli/test_hooks.py::test_hooks[publish]"
- "tests/cli/test_hooks.py::test_skip_option_from_signal[build-pre_build]"
- "tests/cli/test_hooks.py::test_skip_option_from_signal[build-post_build]"
- "tests/cli/test_hooks.py::test_skip_option_from_signal[publish-pre_publish]"
- "tests/cli/test_hooks.py::test_skip_option_from_signal[publish-pre_build]"
- "tests/cli/test_hooks.py::test_skip_option_from_signal[publish-post_build]"
- "tests/cli/test_hooks.py::test_skip_option_from_signal[publish-post_publish]"
- "tests/cli/test_hooks.py::test_skip_all_option_from_signal[:all-build]"
- "tests/cli/test_hooks.py::test_skip_all_option_from_signal[:all-publish]"
- "tests/cli/test_hooks.py::test_skip_all_option_from_signal[:pre,:post-build]"
- "tests/cli/test_hooks.py::test_skip_all_option_from_signal[:pre,:post-publish]"
- "tests/cli/test_hooks.py::test_skip_pre_post_option_from_signal[pre-build]"
- "tests/cli/test_hooks.py::test_skip_pre_post_option_from_signal[pre-publish]"
- "tests/cli/test_hooks.py::test_skip_pre_post_option_from_signal[post-build]"
- "tests/cli/test_hooks.py::test_skip_pre_post_option_from_signal[post-publish]"
- "tests/cli/test_venv.py::test_conda_backend_create[True]"
- "tests/cli/test_venv.py::test_conda_backend_create[False]"
- tests/cli/test_lock.py::test_lock_all_with_excluded_groups
- # hangs on interactive keyring prompts
- tests/cli/test_config.py::test_repository_overwrite_default
- tests/cli/test_config.py::test_hide_password_in_output_repository
- tests/cli/test_config.py::test_hide_password_in_output_pypi
- # junk output, sigh
- tests/cli/test_others.py::test_info_command_json
- # why does it try to use python 2.7?!
- tests/cli/test_run.py::test_import_another_sitecustomize
- # fails in tinderbox (bug #928964)
- tests/test_project.py::test_project_packages_path
- # i guess doesn't expect some dep to be present
- tests/cli/test_build.py::test_build_with_no_isolation
- )
- [[ ${EPYTHON} != python3.10 ]] && EPYTEST_DESELECT+=(
- # test seems hardcoded to 3.10
- tests/test_project.py::test_project_packages_path
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -m "not network and not integration and not path" \
- -p pytest_mock
-}