summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-08-24 07:49:33 -0400
committerMatthew Thode <prometheanfire@gentoo.org>2022-06-25 14:12:44 -0500
commit1a0cbb9052632e827c64f96752e3e2c0d1d391c7 (patch)
tree1f6c22d4a54683b684301c4d6d2fcec1a7d48e4c
parentapp-backup/mirdir: fix build with LTO (diff)
downloadgentoo-1a0cbb9052632e827c64f96752e3e2c0d1d391c7.tar.gz
gentoo-1a0cbb9052632e827c64f96752e3e2c0d1d391c7.tar.bz2
gentoo-1a0cbb9052632e827c64f96752e3e2c0d1d391c7.zip
gui-apps/swaybg: upgrade to 1.1.1, various fixes
- fix cross-compile deps - make gdk-pixbuf optional - add ~riscv to -9999 Signed-off-by: Alex Xu (Hello71) <alex_y_xu@yahoo.ca> Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--gui-apps/swaybg/Manifest1
-rw-r--r--gui-apps/swaybg/metadata.xml3
-rw-r--r--gui-apps/swaybg/swaybg-1.1.1.ebuild46
-rw-r--r--gui-apps/swaybg/swaybg-9999.ebuild12
4 files changed, 57 insertions, 5 deletions
diff --git a/gui-apps/swaybg/Manifest b/gui-apps/swaybg/Manifest
index 562a59c8a6d5..63a13a1ba054 100644
--- a/gui-apps/swaybg/Manifest
+++ b/gui-apps/swaybg/Manifest
@@ -1 +1,2 @@
DIST swaybg-1.0.tar.gz 15851 BLAKE2B 820edbce4161f2d109bc8e842fb2bef101a5793d1da90f4258e5771fe85ab089e184c063a0a7073adbe218c59307946f86bd02c4d62b0585aeb3f9cd5c7963f8 SHA512 67d0e0109b906ece51800729182940374cc59fa07d0866b57cf876d12191fe12e796b84350a849dc85183fa58a3b2d196191e48dcc03dcc3708a980ed4a8cff0
+DIST swaybg-1.1.1.tar.gz 16474 BLAKE2B 21e966e28b5228688aa452f6086feea58bcd56d7fccfe53babe086b9e26702429705870b7d5c7e4900db40e281eab6e1f4077c4cc58f0be745e2d5a9a7d7f46f SHA512 e5ac7af1690974206f916e1d99a8dde0e837acbc686e2de2c46d505201f239a059f998adc22192205d1ad75b5905222f16aed243b31920e19c0ff2229b8eda2c
diff --git a/gui-apps/swaybg/metadata.xml b/gui-apps/swaybg/metadata.xml
index c00e68acd181..98797bd88f43 100644
--- a/gui-apps/swaybg/metadata.xml
+++ b/gui-apps/swaybg/metadata.xml
@@ -22,4 +22,7 @@
<bugs-to>https://github.com/swaywm/swaybg/issues</bugs-to>
<changelog>https://github.com/swaywm/swaybg/releases</changelog>
</upstream>
+ <use>
+ <flag name="gdk-pixbuf">Support image types other than PNG</flag>
+ </use>
</pkgmetadata>
diff --git a/gui-apps/swaybg/swaybg-1.1.1.ebuild b/gui-apps/swaybg/swaybg-1.1.1.ebuild
new file mode 100644
index 000000000000..ce371ad99d1a
--- /dev/null
+++ b/gui-apps/swaybg/swaybg-1.1.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A wallpaper utility for Wayland"
+HOMEPAGE="https://github.com/swaywm/swaybg"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
+else
+ SRC_URI="https://github.com/swaywm/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="gdk-pixbuf +man"
+
+DEPEND="
+ dev-libs/wayland
+ >=dev-libs/wayland-protocols-1.14
+ x11-libs/cairo
+ gdk-pixbuf? ( x11-libs/gdk-pixbuf )
+"
+RDEPEND="
+ ${DEPEND}
+ !<gui-wm/sway-1.1_alpha1
+"
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+ man? ( app-text/scdoc )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=$(usex man enabled disabled)
+ -Dgdk-pixbuf=$(usex gdk-pixbuf enabled disabled)
+ )
+
+ meson_src_configure
+}
diff --git a/gui-apps/swaybg/swaybg-9999.ebuild b/gui-apps/swaybg/swaybg-9999.ebuild
index dfb9021263d7..a665232edee6 100644
--- a/gui-apps/swaybg/swaybg-9999.ebuild
+++ b/gui-apps/swaybg/swaybg-9999.ebuild
@@ -13,24 +13,25 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
else
SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~x86"
+ KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
fi
LICENSE="MIT"
SLOT="0"
-IUSE="+man"
+IUSE="gdk-pixbuf +man"
DEPEND="
dev-libs/wayland
+ >=dev-libs/wayland-protocols-1.14
+ x11-libs/cairo
+ gdk-pixbuf? ( x11-libs/gdk-pixbuf )
"
RDEPEND="
${DEPEND}
!<gui-wm/sway-1.1_alpha1
"
BDEPEND="
- >=dev-libs/wayland-protocols-1.14
- x11-libs/gdk-pixbuf
- x11-libs/cairo
+ dev-util/wayland-scanner
virtual/pkgconfig
man? ( app-text/scdoc )
"
@@ -38,6 +39,7 @@ BDEPEND="
src_configure() {
local emesonargs=(
-Dman-pages=$(usex man enabled disabled)
+ -Dgdk-pixbuf=$(usex gdk-pixbuf enabled disabled)
)
meson_src_configure