summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-11-13 14:26:24 +0100
committerLouis Sautier <sbraz@gentoo.org>2018-11-13 14:34:35 +0100
commit1a3d9b46f2ea10b95162968904a5b17714b0f075 (patch)
tree2856bf10b19e0504d9f6a14075b5a30d9507f481
parentmedia-libs/libjpeg-turbo: Removed old. (diff)
downloadgentoo-1a3d9b46f2ea10b95162968904a5b17714b0f075.tar.gz
gentoo-1a3d9b46f2ea10b95162968904a5b17714b0f075.tar.bz2
gentoo-1a3d9b46f2ea10b95162968904a5b17714b0f075.zip
dev-python/chump: bump to 1.6.0, add PyPy3 and Python 3.7 support
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
-rw-r--r--dev-python/chump/Manifest1
-rw-r--r--dev-python/chump/chump-1.6.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/chump/Manifest b/dev-python/chump/Manifest
index 9c1ac9641660..cc5f4c39bc13 100644
--- a/dev-python/chump/Manifest
+++ b/dev-python/chump/Manifest
@@ -1,2 +1,3 @@
DIST chump-1.5.1.tar.gz 9370 BLAKE2B 28c7280aa0fa3fb81a4981ea3892533eb0af6f1655c41bdf8f250ea78806eac7b3d5f21143af83f22b8063913185e77774eb7be2b8ff2bbe5371c690f726acb5 SHA512 778e043e4641b433a03860f1b1b144cdd34d0f79fb20ec0801cea1e1473eade8dd5211ffca391a57eb1f01456ec33cef4db6359839e7e39eab169411d00471e3
DIST chump-1.5.2.tar.gz 12920 BLAKE2B 5fde4774009ebda37e7a9f9c9cfedea3d4e19a9be1aeb165dd867a8ec8cc69385855c22763bc822d3a65d76c70cfe7ef41e4761319dbfaca9587301570765a8d SHA512 6b836bac1ab38c88084f9d6608a9ed88b305847faabcf5de6c13d587e91dc92b21334877cb9290dd56873de40be92f31f2bab3a345c7a7e62259004f5762cda4
+DIST chump-1.6.0.tar.gz 15646 BLAKE2B 8cab76e633fd4084d349115fae925c152439d06acbe629d5c23c474f2dc0a3cb1b5b727b856a9d54a82e39698b3cfd7470086a976cfc6b4870f1af02bac71f87 SHA512 d219f1b9e28dd17f834dc807cd42a288adc4f5579bf97cf6b1833e63f339bd811953c3a74cafad9021beb05cd5fddb46cf49b62a4803c62ece62d037fe38a4ee
diff --git a/dev-python/chump/chump-1.6.0.ebuild b/dev-python/chump/chump-1.6.0.ebuild
new file mode 100644
index 000000000000..8ded5413a5ff
--- /dev/null
+++ b/dev-python/chump/chump-1.6.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# PyPy is not properly supported:
+# https://github.com/karanlyons/chump/issues/17
+PYTHON_COMPAT=( pypy3 python{2_7,3_{4,5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="API wrapper for Pushover"
+HOMEPAGE="https://github.com/karanlyons/chump"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ sed -i "/'sphinx.ext.intersphinx'/d" docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ # Force sphinx to use the standard theme
+ READTHEDOCS=True sphinx-build docs docs/_build/html || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}