summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-09-26 01:42:54 +0100
committerMarek Szuba <marecki@gentoo.org>2022-09-26 02:01:39 +0100
commit1a57fe648eee0db5bbd79cacda28b41d950ddaeb (patch)
treea7ed7b7d5d531ca7ec19e917f1ffa99d909cb5e3
parentdev-python/sphinx_ansible_theme: drop 0.8.0 (diff)
downloadgentoo-1a57fe648eee0db5bbd79cacda28b41d950ddaeb.tar.gz
gentoo-1a57fe648eee0db5bbd79cacda28b41d950ddaeb.tar.bz2
gentoo-1a57fe648eee0db5bbd79cacda28b41d950ddaeb.zip
dev-cpp/prometheus-cpp: drop 1.0.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--dev-cpp/prometheus-cpp/Manifest1
-rw-r--r--dev-cpp/prometheus-cpp/prometheus-cpp-1.0.0.ebuild41
2 files changed, 0 insertions, 42 deletions
diff --git a/dev-cpp/prometheus-cpp/Manifest b/dev-cpp/prometheus-cpp/Manifest
index 699cad4a7e1f..f91fbfd5bb6b 100644
--- a/dev-cpp/prometheus-cpp/Manifest
+++ b/dev-cpp/prometheus-cpp/Manifest
@@ -1,2 +1 @@
-DIST prometheus-cpp-1.0.0.tar.gz 56244 BLAKE2B 51ff199c0cd09367de873310a835b7a4a5893de11a6115b3de8ef142eb12b326ea7498a8adc155f3bbea6389da41eef91b5ef23cb0227ef1d1ceb64e4d7eac2e SHA512 baeb12725dd47b170e1ac94c23b2b18ba8aa11dedd95af7adee8fdf9ddebaddfca1ef75c30b1d65c94e1cfbcba2c41e0f4686f1a1de66beaba7dcd70ab190164
DIST prometheus-cpp-1.0.1.tar.gz 56673 BLAKE2B 2f2396de0c3c544e92ecdf9f973941f7b61784db690bf3811841a522d3c40cb885e273ce62e66721674f8911fea7b58dc6ae5f0dc10cfdca803054445ca18250 SHA512 eb81b92de986853401f8900d19dfc58d68227d49c74be294b408adc0374292fb462b1f7f7aee522fb03d6fc2ea56f3187fa6ec182aeea169b8bdce38054ee805
diff --git a/dev-cpp/prometheus-cpp/prometheus-cpp-1.0.0.ebuild b/dev-cpp/prometheus-cpp/prometheus-cpp-1.0.0.ebuild
deleted file mode 100644
index 07f8033472af..000000000000
--- a/dev-cpp/prometheus-cpp/prometheus-cpp-1.0.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Prometheus Client Library for Modern C++"
-HOMEPAGE="https://github.com/jupp0r/prometheus-cpp"
-SRC_URI="https://github.com/jupp0r/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~riscv ~x86"
-IUSE="test zlib"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="net-misc/curl
- sys-libs/zlib
- www-servers/civetweb[cxx]"
-DEPEND="${RDEPEND}
- test? (
- dev-cpp/benchmark
- dev-cpp/gtest
- )"
-BDEPEND="virtual/pkgconfig"
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_PULL=yes
- -DENABLE_PUSH=yes
- -DENABLE_COMPRESSION=$(usex zlib)
- -DENABLE_TESTING=$(usex test)
- -DUSE_THIRDPARTY_LIBRARIES=OFF
- -DGENERATE_PKGCONFIG=ON
- -DRUN_IWYU=OFF
- )
-
- cmake_src_configure
-}