summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-03-11 11:33:08 +0100
committerDavid Seifert <soap@gentoo.org>2017-03-11 11:48:10 +0100
commit1a9e29c464bd733f12b95784c0b89ab9777891a8 (patch)
treeb36c2fcbb236db6db06169f5b8a0f662d4e76945
parentdev-ml/ocaml-cohttp: Initial import. Ebuild by me. (diff)
downloadgentoo-1a9e29c464bd733f12b95784c0b89ab9777891a8.tar.gz
gentoo-1a9e29c464bd733f12b95784c0b89ab9777891a8.tar.bz2
gentoo-1a9e29c464bd733f12b95784c0b89ab9777891a8.zip
sci-mathematics/otter: Port to EAPI 6
Package-Manager: Portage-2.3.4, Repoman-2.3.2
-rw-r--r--sci-mathematics/otter/otter-3.3-r3.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-mathematics/otter/otter-3.3-r3.ebuild b/sci-mathematics/otter/otter-3.3-r3.ebuild
new file mode 100644
index 000000000000..891dacf1de4e
--- /dev/null
+++ b/sci-mathematics/otter/otter-3.3-r3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="An Automated Deduction System"
+HOMEPAGE="http://www.cs.unm.edu/~mccune/otter/"
+SRC_URI="http://www.cs.unm.edu/~mccune/otter/${P}.tar.gz"
+
+LICENSE="otter"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXt"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-build.patch
+ "${FILESDIR}"/${P}-gold.patch
+)
+
+src_compile() {
+ tc-export CC
+
+ emake -C source
+ emake -C mace2
+}
+
+src_install() {
+ dobin bin/* source/formed/formed
+
+ dodoc README* Legal Changelog Contents documents/*.pdf
+
+ insinto /usr/share/${PN}
+ doins -r examples examples-mace2
+}