summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-27 17:59:48 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-27 19:24:25 +0200
commit1b0fdaed1f5912cb6efaed09e67eaa4d622e01b9 (patch)
treecbbf881bfdce79839b20bf7bffc70b9902772b61
parentdev-python/Faker: Bump to 18.6.0 (diff)
downloadgentoo-1b0fdaed1f5912cb6efaed09e67eaa4d622e01b9.tar.gz
gentoo-1b0fdaed1f5912cb6efaed09e67eaa4d622e01b9.tar.bz2
gentoo-1b0fdaed1f5912cb6efaed09e67eaa4d622e01b9.zip
dev-python/werkzeug: Bump to 2.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/werkzeug/Manifest1
-rw-r--r--dev-python/werkzeug/werkzeug-2.3.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/werkzeug/Manifest b/dev-python/werkzeug/Manifest
index d2594910d702..cf18b93ee249 100644
--- a/dev-python/werkzeug/Manifest
+++ b/dev-python/werkzeug/Manifest
@@ -1,2 +1,3 @@
DIST werkzeug-2.2.3.gh.tar.gz 847768 BLAKE2B 7d0b891a2b15e4fc469c3d331cfb2565f452ae77f772f7ab8e6254aedd172f9115cd3ebd9c82e951ea7505c0e58d6b6f07fb643a8e87af505e04686cccf56cd4 SHA512 3968e663f67e41da5148a4aa1d8e047ffd88416fa8df665e359bbe87992e4e723e1c915eed59ae86b53dd18817e41cdcef059483bce7aa8ed7b388dd4add1482
DIST werkzeug-2.3.0.gh.tar.gz 831666 BLAKE2B 2d4c792deab6e153794695e249ca97f24b5d70c7f912f7a6fd34b653a7e6e9e0fadb6178c3f388986d0c0dfc55fdbad9809894b70b38f32b3a6c7aaf4d1b4c3f SHA512 ec2bce1ae4311e99d931b96bb05fe98714e317e1d838edec1fd79a05e260ac544f680656b8d5957d123a59a94b40393eb12c3ca8d83e800cc46041b0c0968aea
+DIST werkzeug-2.3.1.gh.tar.gz 832058 BLAKE2B d92836c168339e4dfb07c27d8379548a6805e9aec884cb41b76b9b4196f982ec6d05a6e505bb2ad70e591e54a4a2cecd683b5b6b78a058f90adab704da154d1f SHA512 02b5feb1e4d5c7b24d7b890c579cd3211eb430101d14800ca6c1e2a244da90fee4d5c0cd4819ead58a2885df0c736c796720fd9a3378a1eabaf417aefaa5a919
diff --git a/dev-python/werkzeug/werkzeug-2.3.1.ebuild b/dev-python/werkzeug/werkzeug-2.3.1.ebuild
new file mode 100644
index 000000000000..05c674f456c0
--- /dev/null
+++ b/dev-python/werkzeug/werkzeug-2.3.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of various utilities for WSGI applications"
+HOMEPAGE="
+ https://palletsprojects.com/p/werkzeug/
+ https://pypi.org/project/Werkzeug/
+ https://github.com/pallets/werkzeug/
+"
+SRC_URI="
+ https://github.com/pallets/werkzeug/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test-rust"
+
+RDEPEND="
+ >=dev-python/markupsafe-2.1.1[${PYTHON_USEDEP}]
+"
+# NOTE: remove the loong mask after greenlet gains support for loong
+# see https://github.com/python-greenlet/greenlet/pull/257
+BDEPEND="
+ test? (
+ dev-python/ephemeral-port-reserve[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/pytest-xprocess[${PYTHON_USEDEP}]
+ >=dev-python/watchdog-2.3[${PYTHON_USEDEP}]
+ test-rust? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ )
+ !hppa? ( !ia64? ( !loong? (
+ $(python_gen_cond_dep '
+ dev-python/greenlet[${PYTHON_USEDEP}]
+ ' 'python3*')
+ ) ) )
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ if ! has_version "dev-python/cryptography[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ "tests/test_serving.py::test_server[https]"
+ tests/test_serving.py::test_ssl_dev_cert
+ tests/test_serving.py::test_ssl_object
+ )
+ fi
+
+ # the default portage tempdir is too long for AF_UNIX sockets
+ local -x TMPDIR=/tmp
+ epytest -p no:django -p no:httpbin tests
+}