summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-03-11 11:40:36 +0100
committerDavid Seifert <soap@gentoo.org>2018-03-11 11:40:36 +0100
commit1b359a2f6ccce336865e2fd197eea6425e7aa9ae (patch)
treeb8b78dcdce93ae208860a1cbf09621eed8494735
parentapp-text/qpdf: stable 7.0.0 for ppc64, bug #626446 (diff)
downloadgentoo-1b359a2f6ccce336865e2fd197eea6425e7aa9ae.tar.gz
gentoo-1b359a2f6ccce336865e2fd197eea6425e7aa9ae.tar.bz2
gentoo-1b359a2f6ccce336865e2fd197eea6425e7aa9ae.zip
dev-cpp/catch: Version bump to 2.2.0
Closes: https://bugs.gentoo.org/649760 Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--dev-cpp/catch/Manifest1
-rw-r--r--dev-cpp/catch/catch-2.2.0.ebuild37
-rw-r--r--dev-cpp/catch/files/catch-2.2.0-fix-pkg-config.patch22
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-cpp/catch/Manifest b/dev-cpp/catch/Manifest
index 9fb7539bccf0..b52d91471f06 100644
--- a/dev-cpp/catch/Manifest
+++ b/dev-cpp/catch/Manifest
@@ -1,2 +1,3 @@
DIST Catch-1.11.0.tar.gz 376132 BLAKE2B 23a1a6292dd91ec1c71923b4902b42b59ff6be5227b666f68ef0dc33756a58a63edd70a9b139dda0b1860c2b7a0cfec7ab9262e6447eff3184cfe28ea9b0aa77 SHA512 33085c2671f78c7562eace909564b2730eabcaf4490cd463402e66ab4ac2be1fe4fe360916c11aa589ba4a010622444126ee2ae747783b5869b5d7276361f132
DIST Catch2-2.1.1.tar.gz 481236 BLAKE2B 8a8110611aaf4ea913462884d8293bcae7d0abf3075253a26385a56b2cb5bf50b769e2117430c9712e4644f430cc16461fabfef921c5fbfceb82effb0da74e93 SHA512 64947672e614301a45efd812eb3eef98d871c9719005a441b6f6bb1dc26820bd9643ba285bcc0eaef9b212c5ab6ada4a875433c47a020ce436bcc411cdc8ad72
+DIST Catch2-2.2.0.tar.gz 487585 BLAKE2B 2d8f58e8d3630cb30e438da7a169df3afff387d38dd3054cfcdb8860aa507ecc3c614471fa1110f64b0dba3d6855edfc68ee4e0b7eb97164be833827078e82fd SHA512 9dcc409939df61f84b965ee3147a7a7578b3a816ff285e103b7666115bf38a608d9a0075e06e98f93b9f06882d2e41d6c51cdaae352abbfaa2a3c1b408f22df7
diff --git a/dev-cpp/catch/catch-2.2.0.ebuild b/dev-cpp/catch/catch-2.2.0.ebuild
new file mode 100644
index 000000000000..c9f6247c2842
--- /dev/null
+++ b/dev-cpp/catch/catch-2.2.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+inherit cmake-utils
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/catchorg/Catch2.git"
+else
+ MY_P=${PN^}2-${PV}
+ SRC_URI="https://github.com/catchorg/Catch2/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+
+ S=${WORKDIR}/${MY_P}
+fi
+
+DESCRIPTION="Modern C++ header-only framework for unit-tests"
+HOMEPAGE="https://github.com/catchorg/Catch2"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.2.0-fix-pkg-config.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ -DCATCH_ENABLE_WERROR=OFF
+ -DBUILD_TESTING=$(usex test)
+ -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
+ )
+ cmake-utils_src_configure
+}
diff --git a/dev-cpp/catch/files/catch-2.2.0-fix-pkg-config.patch b/dev-cpp/catch/files/catch-2.2.0-fix-pkg-config.patch
new file mode 100644
index 000000000000..1c1463921b2b
--- /dev/null
+++ b/dev-cpp/catch/files/catch-2.2.0-fix-pkg-config.patch
@@ -0,0 +1,22 @@
+From c778848b09df073b9f84f22622ea7a632642c4a5 Mon Sep 17 00:00:00 2001
+From: David Seifert <soap@gentoo.org>
+Date: Tue, 30 Jan 2018 11:13:53 +0100
+Subject: [PATCH] Fix pkg-config
+
+* All uses of Catch involve #include'ing it without
+ a prefixed folder, such as `#include "catch.hpp"`.
+ This requires fixing the pkg-config file.
+---
+ catch.pc.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/catch.pc.in b/catch.pc.in
+index abd0b66b1..4f48bc7fb 100644
+--- a/catch.pc.in
++++ b/catch.pc.in
+@@ -3,4 +3,4 @@ includedir=@CMAKE_INSTALL_FULL_INCLUDEDIR@
+ Name: Catch
+ Description: Testing library for C++
+ Version: @Catch2_VERSION@
+-Cflags: -I${includedir}
++Cflags: -I${includedir}/catch