summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Seifert <m.seifert@digitalernachschub.de>2019-03-08 10:57:24 +0100
committerPatrice Clement <monsieurp@gentoo.org>2019-03-29 00:12:29 +0100
commit1b43b8d1a8edc9efef65814410e0bbd2426ee1f8 (patch)
treee3ab28b2640cf1eefebf2ee5b1197ffe9f86a399
parentdev-python/pympler: Version bump to 0.6 (diff)
downloadgentoo-1b43b8d1a8edc9efef65814410e0bbd2426ee1f8.tar.gz
gentoo-1b43b8d1a8edc9efef65814410e0bbd2426ee1f8.tar.bz2
gentoo-1b43b8d1a8edc9efef65814410e0bbd2426ee1f8.zip
dev-util/stripe-mock: version bump to v0.47.0.
Closes: https://bugs.gentoo.org/679754 Signed-off-by: Michael Seifert <m.seifert@digitalernachschub.de> Closes: https://github.com/gentoo/gentoo/pull/11299 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--dev-util/stripe-mock/Manifest1
-rw-r--r--dev-util/stripe-mock/stripe-mock-0.47.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-util/stripe-mock/Manifest b/dev-util/stripe-mock/Manifest
index 74581965fda7..ae782b366121 100644
--- a/dev-util/stripe-mock/Manifest
+++ b/dev-util/stripe-mock/Manifest
@@ -1 +1,2 @@
DIST stripe-mock-0.34.1.tar.gz 340357 BLAKE2B 127d39b01bbd883141c75e63dc5e0b8834dbc86f375058768072b3de75d3f9e3fabebdfdd9d872c51ad52fec3e2057ae342887c25b496b987d64652c93b204bd SHA512 c9e35867c44bd7d127f91d0f668d39ff67ca9bb2937428f808122555360a77b91f9f5d5648478dc2c4fc04a7b9195fed0a927868fdd22b852022ae2fe0f1e695
+DIST stripe-mock-0.47.0.tar.gz 371383 BLAKE2B 0d619e62c9d071cd0706f0deeab5cb659d994f02df87fc638e319b346cda83548bec9a6068814b7c17a8f62e8f9c2206003bd62f66f844e8f38ee96b10f099fe SHA512 b387556526eea8b02fb3df74b345f5447bc81d7cc9e7f9fe9cd59dfdef7895bd31c882bc3c96c6815c69cc1e1fc3bed8390beb107ecfeb79e69aba4bc115a17e
diff --git a/dev-util/stripe-mock/stripe-mock-0.47.0.ebuild b/dev-util/stripe-mock/stripe-mock-0.47.0.ebuild
new file mode 100644
index 000000000000..466e59347a0b
--- /dev/null
+++ b/dev-util/stripe-mock/stripe-mock-0.47.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_SRC="github.com/stripe/stripe-mock"
+EGO_PN=${EGO_SRC}/...
+inherit golang-build golang-vcs-snapshot
+
+DESCRIPTION="Mock HTTP server that responds like the real Stripe API"
+HOMEPAGE="https://github.com/stripe/stripe-mock"
+SRC_URI="https://github.com/stripe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="MIT"
+SLOT="0"
+
+src_install() {
+ golang-build_src_install
+ dobin bin/stripe-mock
+ rm -rf "${D%/}$(get_golibdir_gopath)" || die
+}