summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-10-24 21:06:00 -0500
committerWilliam Hubbs <williamh@gentoo.org>2020-10-24 21:06:51 -0500
commit1b98a2d6dc52987a23e6fcc29cfddd39216c9cdb (patch)
tree825b5015973336e34ae2d35c159134740bfba473
parentdev-python/zipp: remove old (diff)
downloadgentoo-1b98a2d6.tar.gz
gentoo-1b98a2d6.tar.bz2
gentoo-1b98a2d6.zip
sys-apps/opentmpfiles: 0.3 bump
Closes: https://bugs.gentoo.org/741216 Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--sys-apps/opentmpfiles/Manifest1
-rw-r--r--sys-apps/opentmpfiles/opentmpfiles-0.3.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/sys-apps/opentmpfiles/Manifest b/sys-apps/opentmpfiles/Manifest
index 9865ce6a8dad..57e7b5941b44 100644
--- a/sys-apps/opentmpfiles/Manifest
+++ b/sys-apps/opentmpfiles/Manifest
@@ -2,3 +2,4 @@ DIST opentmpfiles-0.1.1.tar.gz 5626 BLAKE2B 2b2d21bae0c8280f31ea1ad35cd857a94b3d
DIST opentmpfiles-0.1.2.tar.gz 5614 BLAKE2B d49485535bc3b92ba7e9a2af511969b1793d94187a2600b3196314bef8de235fe7a640bb2b7f78f51727f94c18556fc27e7996ffccef71ff94e006b9f9a63810 SHA512 d86ba71e5fe96d7a8e1999e14b0b99c78e850c42fbfefd203916edca593d0269feaf2252aa01cc35a838906fc2909015430f72cde8370e2d5b1d478a11fe456d
DIST opentmpfiles-0.1.3.tar.gz 5691 BLAKE2B 56d79f0279a46ed3b4e13f94a7f2c7d494df245a17b8533c48cff357c21db56485bd076e375f3b4e2c9a140a65e8ab472a8a1030bbee0853463f734c316f71e8 SHA512 fd0b10ebfeb621466edadede50ec6e8f415861ab3b14b833c75bd71f7296e9c091e59144d39e1f9efd342b6d97776cade5a692c941085e33e9651fd885da7121
DIST opentmpfiles-0.2.tar.gz 5711 BLAKE2B e1ee7820b2d184d18e63e7e9d93227bb301eb82be8c2b6021c7a1092f55a4ca2bb5dfb7494ff00c3b6debace1963f6c89011ff557f665f0a93c907bd759a4c6f SHA512 bc384cc9156ba6c54d3308ddad4d26b1877f020aa8558e82df2ed49ffa65e0fed5a49eaa11b27193bfe2ad11a4d7368f7cdbc225b820b309af3b299327ddb07b
+DIST opentmpfiles-0.3.tar.gz 6831 BLAKE2B bed680dbbf3915086fcd9c47f8fadb25049b4b5f0687b623ece73ae2c40183ba10646c5bc32ec6c8a3d0c493f9a59f16de3d90cf17aa4add6caeead011c665c6 SHA512 02f12d03b75d3df84755dbea2fa27a075ae2b12eb34189aaa532b2b085fb1f455aaf6cc84d56eb7f299fd90922f704fcf0a585f983a7e14dbf843e2ab62de387
diff --git a/sys-apps/opentmpfiles/opentmpfiles-0.3.ebuild b/sys-apps/opentmpfiles/opentmpfiles-0.3.ebuild
new file mode 100644
index 000000000000..1bdbb4ca4146
--- /dev/null
+++ b/sys-apps/opentmpfiles/opentmpfiles-0.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit prefix
+
+if [[ ${PV} = 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/openrc/${PN}"
+else
+ SRC_URI="https://github.com/openrc/${PN}/archive/${PV}.tar.gz ->
+ ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="A standalone utility to process systemd-style tmpfiles.d files"
+HOMEPAGE="https://github.com/openrc/opentmpfiles"
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="selinux"
+
+RDEPEND="!<sys-apps/openrc-0.23
+ selinux? ( sec-policy/selinux-base-policy )"
+
+src_prepare() {
+ default
+ hprefixify tmpfiles
+}
+src_install() {
+ emake DESTDIR="${ED}" install
+ einstalldocs
+ cd openrc
+ for f in opentmpfiles-dev opentmpfiles-setup; do
+ newconfd ${f}.confd ${f}
+ newinitd ${f}.initd ${f}
+ done
+}
+
+add_service() {
+ local initd=$1
+ local runlevel=$2
+
+ elog "Auto-adding '${initd}' service to your ${runlevel} runlevel"
+ mkdir -p "${EROOT}"etc/runlevels/${runlevel}
+ ln -snf /etc/init.d/${initd} "${EROOT}"etc/runlevels/${runlevel}/${initd}
+}
+
+pkg_postinst() {
+ if [[ -z $REPLACING_VERSIONS ]]; then
+ add_service opentmpfiles-dev sysinit
+ add_service opentmpfiles-setup boot
+ fi
+}