summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-04-21 23:14:27 +0100
committerMarek Szuba <marecki@gentoo.org>2020-04-21 23:20:48 +0100
commit1bb5e99bc9a64e35b64b117049ebf0e75fadb18e (patch)
tree6fa7071ce1dc3f5c4b01b887cd69328187c92296
parentnet-wireless/hostapd: make USE flag for Suite B (diff)
downloadgentoo-1bb5e99bc9a64e35b64b117049ebf0e75fadb18e.tar.gz
gentoo-1bb5e99bc9a64e35b64b117049ebf0e75fadb18e.tar.bz2
gentoo-1bb5e99bc9a64e35b64b117049ebf0e75fadb18e.zip
app-misc/gramps: work around problems with --skip-build
Required to make new Gramps installations work following one of the recent changes to distutils-r1.eclass (commit 180fa85d7d00aea463c399f70348beaad9166eb7). Has the dubious distinction of being possibly the ugliest hack I have ever had to implement. Bug: https://bugs.gentoo.org/717922 Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--app-misc/gramps/gramps-5.1.2-r1.ebuild11
1 files changed, 11 insertions, 0 deletions
diff --git a/app-misc/gramps/gramps-5.1.2-r1.ebuild b/app-misc/gramps/gramps-5.1.2-r1.ebuild
index c13785854d7d..3144f1370d3d 100644
--- a/app-misc/gramps/gramps-5.1.2-r1.ebuild
+++ b/app-misc/gramps/gramps-5.1.2-r1.ebuild
@@ -63,6 +63,17 @@ python_test_all() {
esetup.py test
}
+# Ugly hack to work around Bug #717922
+python_install() {
+ local mydistutilsargs=(
+ --resourcepath=/usr/share
+ --no-compress-manpages
+ build
+ )
+ distutils-r1_python_install
+ echo -n "/usr/share" > "${D}$(python_get_sitedir)/gramps/gen/utils/resource-path" || die
+}
+
pkg_postinst() {
xdg_desktop_database_update
xdg_mimeinfo_database_update