summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-06-17 05:47:15 -0400
committerTim Harder <radhermit@gentoo.org>2018-06-17 05:56:58 -0400
commit1bfcbbb4f40754b1ed3f5c9aa77d578409e0e7ce (patch)
treeab8395bfd79ae9a6b2d0894247d2212e54b5d63b
parentapache-2.eclass: Added "gdbm" USE flag to IUSE. (diff)
downloadgentoo-1bfcbbb4f40754b1ed3f5c9aa77d578409e0e7ce.tar.gz
gentoo-1bfcbbb4f40754b1ed3f5c9aa77d578409e0e7ce.tar.bz2
gentoo-1bfcbbb4f40754b1ed3f5c9aa77d578409e0e7ce.zip
sys-apps/pick: version bump to 2.0.2
-rw-r--r--sys-apps/pick/Manifest1
-rw-r--r--sys-apps/pick/metadata.xml2
-rw-r--r--sys-apps/pick/pick-2.0.2.ebuild24
3 files changed, 26 insertions, 1 deletions
diff --git a/sys-apps/pick/Manifest b/sys-apps/pick/Manifest
index 5ea63a333ffb..a22fc3154171 100644
--- a/sys-apps/pick/Manifest
+++ b/sys-apps/pick/Manifest
@@ -1 +1,2 @@
DIST pick-2.0.1.tar.gz 108010 BLAKE2B 3fae7cfbbcf6913af9cf695e44f171aef58737038e94c779f0cedbe2e386577b4661cc9a55ad657b1a11873fc06bdb7bdc8eac032b6ca584778fe695f8ad4e68 SHA512 616c7889e2ad5d5bb267f683530327e9e121a678db4bd04d5cd720bb8bd81ae14e6bd83e342b33863ef18bd10943e6bbdef177c9639af513456e0146f9b73226
+DIST pick-2.0.2.tar.gz 132174 BLAKE2B 1f186d7dd0fc628d7a1b5fd41ad8c4b0c81f12c1855418354e77376232beb9fa500f43172d8d75f55972ee2589feafbefa6d777cb2149e4707509df355542744 SHA512 92d74fa62f6c829117c6c3faf6ec39fc5dd66465516be396d21d7b0a92ee10761a1d3f43aa4a454f8d19790ac02a4a1af145139d488344c97a511805c5d6965b
diff --git a/sys-apps/pick/metadata.xml b/sys-apps/pick/metadata.xml
index 10fe2acf6f32..6eab74ef0029 100644
--- a/sys-apps/pick/metadata.xml
+++ b/sys-apps/pick/metadata.xml
@@ -6,6 +6,6 @@
<name>Tim Harder</name>
</maintainer>
<upstream>
- <remote-id type="github">calleerlandsson/pick</remote-id>
+ <remote-id type="github">mptre/pick</remote-id>
</upstream>
</pkgmetadata>
diff --git a/sys-apps/pick/pick-2.0.2.ebuild b/sys-apps/pick/pick-2.0.2.ebuild
new file mode 100644
index 000000000000..54ee90179479
--- /dev/null
+++ b/sys-apps/pick/pick-2.0.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="a fuzzy search tool for the command-line"
+HOMEPAGE="https://github.com/mptre/pick"
+SRC_URI="https://github.com/mptre/pick/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}