summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-03-13 13:05:25 +0100
committerDavid Seifert <soap@gentoo.org>2021-03-13 13:05:25 +0100
commit1c0add7b1ba0584c0bddbc91e999380137a5033b (patch)
treebdc14e8ac7af47da17421a52ef4aa41163499065
parentsci-biology/embassy-iprscan: Port to EAPI 7 (diff)
downloadgentoo-1c0add7b1ba0584c0bddbc91e999380137a5033b.tar.gz
gentoo-1c0add7b1ba0584c0bddbc91e999380137a5033b.tar.bz2
gentoo-1c0add7b1ba0584c0bddbc91e999380137a5033b.zip
sci-biology/embassy-topo: Fix building against clang/LLD
Closes: https://bugs.gentoo.org/731926 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--sci-biology/embassy-topo/files/embassy-topo-2.0.650_fix-build-system.patch34
1 files changed, 17 insertions, 17 deletions
diff --git a/sci-biology/embassy-topo/files/embassy-topo-2.0.650_fix-build-system.patch b/sci-biology/embassy-topo/files/embassy-topo-2.0.650_fix-build-system.patch
index 3c37879de8c8..600e38928aff 100644
--- a/sci-biology/embassy-topo/files/embassy-topo-2.0.650_fix-build-system.patch
+++ b/sci-biology/embassy-topo/files/embassy-topo-2.0.650_fix-build-system.patch
@@ -1,13 +1,6 @@
- configure.ac | 49 +++++++------------------------------------------
- emboss_acd/Makefile.am | 2 +-
- src/Makefile.am | 6 ++----
- 3 files changed, 10 insertions(+), 47 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 8eeb8ca..4fd28ac 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -635,33 +635,6 @@ AS_CASE([${host_os}],
+@@ -635,33 +635,6 @@
@@ -41,7 +34,7 @@ index 8eeb8ca..4fd28ac 100644
dnl FIXME: This does no longer seem required with Autoconf 2.67?
dnl Intel MacOSX 10.6 puts X11 in a non-standard place
dnl AS_IF([test "x${with_x}" != "xno"],
-@@ -737,21 +710,6 @@ AX_LIB_POSTGRESQL
+@@ -737,21 +710,6 @@
@@ -63,7 +56,7 @@ index 8eeb8ca..4fd28ac 100644
dnl Test if --enable-localforce given
locallink="no"
embprefix="/usr/local"
-@@ -874,6 +832,13 @@ AC_ARG_ENABLE([systemlibs],
+@@ -874,6 +832,13 @@
AM_CONDITIONAL([ESYSTEMLIBS], [test "x${enable_systemlibs}" = "xyes"])
@@ -77,8 +70,6 @@ index 8eeb8ca..4fd28ac 100644
# Enable the purify tool: --enable-purify, sets CC and LIBTOOL
-diff --git a/emboss_acd/Makefile.am b/emboss_acd/Makefile.am
-index e1c1878..e253c95 100644
--- a/emboss_acd/Makefile.am
+++ b/emboss_acd/Makefile.am
@@ -1,3 +1,3 @@
@@ -86,11 +77,9 @@ index e1c1878..e253c95 100644
-pkgdata_DATA = *.acd
+pkgdata_DATA = $(srcdir)/*.acd
pkgdatadir=$(prefix)/share/EMBOSS/acd
-diff --git a/src/Makefile.am b/src/Makefile.am
-index 1cdb0b1..0e86a4b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
-@@ -17,9 +17,7 @@ AM_CPPFLAGS = -I../../../nucleus -I../../../ajax/pcre \
+@@ -17,9 +17,7 @@
-I../../../ajax/ensembl -I../../../ajax/ajaxdb \
-I../../../ajax/acd -I../../../plplot
else
@@ -101,10 +90,21 @@ index 1cdb0b1..0e86a4b 100644
endif
if ISSHARED
-@@ -60,5 +58,5 @@ LDADD = ../../../nucleus/libnucleus.la ../../../ajax/acd/libacd.la \
+@@ -34,7 +32,7 @@
+ -lnucleus -lacd -lajaxdb -lensembl -lajaxg -lajax -lepcre \
+ $(NLAIXLIBS) -leplplot
+ else
+-AIX_CFLAGS = -Wl,-bdynamic -Wl,-brtl -L${embprefix}/lib -lnucleus -lacd \
++AIX_CFLAGS = -Wl,-bdynamic -Wl,-brtl -lnucleus -lacd \
+ -lajaxdb -lensembl -lajaxg -lajax -lepcre $(NLAIXLIBS) -leplplot
+ endif
+ endif
+@@ -59,6 +57,6 @@
+ ../../../plplot/libeplplot.la \
$(XLIB)
else
- LDADD = -L${embprefix}/lib -lnucleus -lacd -lajaxdb -lensembl -lajaxg \
+-LDADD = -L${embprefix}/lib -lnucleus -lacd -lajaxdb -lensembl -lajaxg \
- -lajax -lepcre $(NLADD) -leplplot $(XLIB)
++LDADD = -lnucleus -lacd -lajaxdb -lensembl -lajaxg \
+ -lajax $(NLADD) $(XLIB)
endif