summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-30 13:47:50 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-30 14:09:31 +0100
commit1c6c3c39d974cbfd7bc0f0962e9f9698e9eab3fa (patch)
tree176c02374943c10f9a51c54939614e8c55974492
parentdev-python/signature_dispatch: Switch to PEP 517 build (diff)
downloadgentoo-1c6c3c39.tar.gz
gentoo-1c6c3c39.tar.bz2
gentoo-1c6c3c39.zip
dev-python/smartypants: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/smartypants/smartypants-2.0.1-r1.ebuild31
-rw-r--r--dev-python/smartypants/smartypants-9999.ebuild8
2 files changed, 35 insertions, 4 deletions
diff --git a/dev-python/smartypants/smartypants-2.0.1-r1.ebuild b/dev-python/smartypants/smartypants-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..c5c6b78000bf
--- /dev/null
+++ b/dev-python/smartypants/smartypants-2.0.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{6..10} )
+
+MY_PN="${PN}.py"
+MY_P="${MY_PN}-${PV}"
+
+inherit distutils-r1
+
+DESCRIPTION="ASCII quote-dot-dash to HTML entity converter"
+HOMEPAGE="https://pypi.python.org/pypi/smartypants/"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/leohemsted/smartypants.py.git"
+ EGIT_BRANCH="master"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/leohemsted/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~sparc ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+distutils_enable_sphinx docs
+distutils_enable_tests setup.py
diff --git a/dev-python/smartypants/smartypants-9999.ebuild b/dev-python/smartypants/smartypants-9999.ebuild
index 418910a52b87..c5c6b78000bf 100644
--- a/dev-python/smartypants/smartypants-9999.ebuild
+++ b/dev-python/smartypants/smartypants-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{6..10} )
-DISTUTILS_USE_SETUPTOOLS=no
MY_PN="${PN}.py"
MY_P="${MY_PN}-${PV}"
@@ -20,7 +20,7 @@ if [[ ${PV} = 9999* ]]; then
inherit git-r3
else
SRC_URI="https://github.com/leohemsted/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~sparc ~x86"
S="${WORKDIR}/${MY_P}"
fi