summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-05-11 16:12:23 -0400
committerMike Gilbert <floppym@gentoo.org>2016-05-11 16:33:21 -0400
commit1c79658096b3460914ac1ade65ad4b9ad16cfaa6 (patch)
treeccc690ba1e92005b8666100d64c9b1c5c97f8c38
parentdev-python/APScheduler: bump to 3.1.0 (diff)
downloadgentoo-1c79658096b3460914ac1ade65ad4b9ad16cfaa6.tar.gz
gentoo-1c79658096b3460914ac1ade65ad4b9ad16cfaa6.tar.bz2
gentoo-1c79658096b3460914ac1ade65ad4b9ad16cfaa6.zip
net-misc/flexget: Update deps in live ebuild
Package-Manager: portage-2.2.28_p106
-rw-r--r--net-misc/flexget/flexget-9999.ebuild43
1 files changed, 13 insertions, 30 deletions
diff --git a/net-misc/flexget/flexget-9999.ebuild b/net-misc/flexget/flexget-9999.ebuild
index 16bf2175193..c274e8aed31 100644
--- a/net-misc/flexget/flexget-9999.ebuild
+++ b/net-misc/flexget/flexget-9999.ebuild
@@ -1,12 +1,13 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python2_7 )
+# TODO: Add python3_5 once deps have it
-inherit distutils-r1 eutils
+inherit distutils-r1
if [[ ${PV} != 9999 ]]; then
MY_P="FlexGet-${PV}"
@@ -27,50 +28,32 @@ IUSE="test transmission"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/feedparser-5.1.3[${PYTHON_USEDEP}]
+ >=dev-python/feedparser-5.2.1[${PYTHON_USEDEP}]
>=dev-python/sqlalchemy-0.7.5[${PYTHON_USEDEP}]
<dev-python/sqlalchemy-1.999[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
>=dev-python/beautifulsoup-4.1:4[${PYTHON_USEDEP}]
- <dev-python/beautifulsoup-4.4:4[${PYTHON_USEDEP}]
+ <dev-python/beautifulsoup-4.5:4[${PYTHON_USEDEP}]
!~dev-python/beautifulsoup-4.2.0
>=dev-python/html5lib-0.11[${PYTHON_USEDEP}]
dev-python/PyRSS2Gen[${PYTHON_USEDEP}]
dev-python/pynzb[${PYTHON_USEDEP}]
- dev-python/progressbar[${PYTHON_USEDEP}]
dev-python/rpyc[${PYTHON_USEDEP}]
dev-python/jinja[${PYTHON_USEDEP}]
- >=dev-python/requests-1.0[${PYTHON_USEDEP}]
- <dev-python/requests-2.99[${PYTHON_USEDEP}]
- >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
- !~dev-python/python-dateutil-2.2
+ >=dev-python/requests-2.8.0[${PYTHON_USEDEP}]
+ <dev-python/requests-3.0[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.5.2[${PYTHON_USEDEP}]
>=dev-python/jsonschema-2.0[${PYTHON_USEDEP}]
- dev-python/python-tvrage[${PYTHON_USEDEP}]
- dev-python/tmdb3[${PYTHON_USEDEP}]
dev-python/path-py[${PYTHON_USEDEP}]
- >=dev-python/guessit-0.9.3[${PYTHON_USEDEP}]
- dev-python/APScheduler[${PYTHON_USEDEP}]
+ >=dev-python/pathlib-1.0[${PYTHON_USEDEP}]
+ <=dev-python/guessit-2.0.4[${PYTHON_USEDEP}]
+ >=dev-python/APScheduler-3.0.3[${PYTHON_USEDEP}]
"
RDEPEND="${DEPEND}
transmission? ( dev-python/transmissionrpc[${PYTHON_USEDEP}] )
"
DEPEND+=" test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-if [[ ${PV} == 9999 ]]; then
- DEPEND+=" dev-python/paver[${PYTHON_USEDEP}]"
-else
+if [[ ${PV} != 9999 ]]; then
S="${WORKDIR}/${MY_P}"
fi
-
-python_prepare_all() {
- # Prevent setup from grabbing nose from pypi
- sed -e /setup_requires/d -i pavement.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- cp -lr tests setup.cfg "${BUILD_DIR}" || die
- run_in_build_dir nosetests -v --attr=!online > "${T}/tests-${EPYTHON}.log" \
- || die "Tests fail with ${EPYTHON}"
-}