summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-31 23:31:46 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-01 00:46:50 +0100
commit1ce46bd541028a1003211c08f19b03165b32316f (patch)
treefd5302310527033adf9cf0cd48aa433281d19c09
parentmedia-libs/harfbuzz: add 3.3.1, drop 3.3.0 (diff)
downloadgentoo-1ce46bd5.tar.gz
gentoo-1ce46bd5.tar.bz2
gentoo-1ce46bd5.zip
dev-python/cfn-lint: Bump to 0.58.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.58.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index c0ee18d44e7f..0f1b4ebb3f60 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -1,3 +1,4 @@
DIST cfn-lint-0.56.3.tar.gz 8278034 BLAKE2B 894d30add7a193d256dc2195c0cd1d4b75f10f60abe9e37c5b0bdd84178d9559759326ad3e55d2321b99588094b436dc2dc8dff1cc561ae56dd4cee98d6b43bd SHA512 8aeaf44a626f9bfc05ebeefc8aec9211fcac1a65de681d5d700f3621631bff15e74ed644b9d0dc8af4d9b0b14802c2259dbc4ccf38594705040f5fd3af1cf482
DIST cfn-lint-0.56.4.tar.gz 8550039 BLAKE2B 99efd99b423e068717f3050e4da444436463c16b0a55dfc36ca7ca45b1136d08bbce84441c8c4170eff7c82cbd4ecf87b6f78504b1d09d850d803a7e957903c9 SHA512 b7c94d85d58f9e44ff8d5575bb33c8c7fafcb908afe144d585765f02d645436d6583ecc802f0fa376597b75c72ada9a23862141cf1170c1ac1f64f2467d346fb
DIST cfn-lint-0.57.0.tar.gz 8579636 BLAKE2B 5e9cadcbd695b1047c4cf51132fcdf5a254a89fcd89a86e3c5d86096e8cd376f7f02422757f7daaf98490ff82df88933a976faba1ea6504a463ed7c485c83631 SHA512 11ec66bc5a98c928e059778462766100fb47f4b45a4cc7023d3d2b70ae664a1b199ec4df0d95cb9ada5a09a1f7a609fcec7d76339b3d9d6430bbe85462e1c020
+DIST cfn-lint-0.58.0.tar.gz 8645209 BLAKE2B b198c8e6a56095782ab5fbd70f1f5872d951da133ee7056ef468e5d1cd0ba1a7831ebd4263248ec2cec04980211e01cf3525e18f8ad272d6b1aaeee07527028d SHA512 238929a79d25b6a5945fd43f29fa3c432c650923634495c2ace7e3f6ace0c7701bcc278ea151a9172691bd04164f8a7b409dd8387e82e5917a9f65e1a556a4d2
diff --git a/dev-python/cfn-lint/cfn-lint-0.58.0.ebuild b/dev-python/cfn-lint/cfn-lint-0.58.0.ebuild
new file mode 100644
index 000000000000..b8ea9d7827e1
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.58.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="https://pypi.org/project/cfn-lint/ https://github.com/aws-cloudformation/cfn-lint/"
+SRC_URI="
+ https://github.com/aws-cloudformation/cfn-lint/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.42.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema_to_python-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/sarif_om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.11[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_2
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+)
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}